|Linux & Unix Commands - Search Man Pages
UHIDEV(4) BSD Kernel Interfaces Manual UHIDEV(4)
uhidev -- USB Human Interface Device support
uhidev* at uhub?
ucycom* at uhidev? reportid ?
uhid* at uhidev? reportid ?
ukbd* at uhidev? reportid ?
ums* at uhidev? reportid ?
The uhidev driver handles all Human Interface Devices. Each HID device can have several
components, e.g., a keyboard and a mouse. These components use different report identifiers
(a byte) to distinguish which one data is coming from. The uhidev driver has other drivers
attached that handle particular kinds of devices and uhidev only dispatches data to them
based on the report id.
ucycom(4), uhid(4), ukbd(4), ums(4), usb(4)
The uhidev driver appeared in NetBSD 1.6.
BSD July 30, 2005 BSD
All times are GMT -4. The time now is 09:21 PM.