TI(4) BSD Kernel Interfaces Manual TI(4)
ti -- Alteon Networks Tigon I and Tigon II gigabit Ethernet driver
ti* at pci? dev ? function ?
The ti driver provides support for PCI gigabit Ethernet adapters based on the Alteon Net-
works Tigon gigabit Ethernet controller chip. The Tigon contains an embedded R4000 CPU,
gigabit MAC, dual DMA channels and a PCI interface unit. The Tigon II contains two R4000
CPUs and other refinements. Either chip can be used in either a 32-bit or 64-bit PCI slot.
Communication with the chip is achieved via PCI shared memory and bus master DMA. The Tigon
I and II support hardware multicast address filtering, VLAN tag extraction and insertion,
and jumbo Ethernet frames sizes up to 9000 bytes. Note that the Tigon I chipset is no
longer in active production: all new adapters should come equipped with Tigon II chipsets.
There are several PCI boards available from both Alteon and other vendors that use the Tigon
chipset under OEM contract. The ti driver has been tested with the following Tigon-based
o The Alteon AceNIC V gigabit (1000BASE-SX and 1000BASE-T variants) Ethernet adapter
o The 3Com 3c985-SX gigabit Ethernet adapter
o The Netgear GA620 gigabit (1000BASE-SX and 1000BASE-T variants) Ethernet adapter
o The Digital EtherWORKS 1000SX PCI Gigabit Adapter (DEGPA)
The following should also be supported but have not yet been tested:
o Silicon Graphics PCI gigabit Ethernet adapter
While the Tigon chipset supports 10, 100 and 1000Mbps speeds, support for 10 and 100Mbps
speeds is only available on boards with the proper transceivers. Most adapters are only
designed to work at 1000Mbps, however the driver should support those NICs that work at
lower speeds as well.
Support for jumbo frames is provided via the interface MTU setting. Selecting an MTU larger
than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit
jumbo frames. Using jumbo frames can greatly improve performance for certain tasks, such as
file transfers and data streaming.
The ti driver supports the following media types:
autoselect Enable autoselection of the media type and options.
10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used to select
either full-duplex or half-duplex modes.
100baseTX Set 100Mbps (fast Ethernet) operation. The mediaopt option can also
be used to select either full-duplex or half-duplex modes.
1000baseSX Set 1000Mbps (gigabit Ethernet over multimode fiber) operation. Only
full full-duplex mode is supported at this speed.
1000baseT Set 1000Mbps (gigabit Ethernet over twisted pair) operation. Only full
full-duplex mode is supported at this speed.
The ti driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
The Alteon Tigon and Tigon II support IPv4/TCP/UDP checksumming in hardware. The ti sup-
ports this feature of the chip's firmware. See ifconfig(8) for information on how to enable
For more information on configuring this device, see ifconfig(8).
ti%d: can't map memory space A fatal initialization error has occurred.
ti%d: couldn't map / establish interrupt A fatal initialization error has occurred.
ti%d: jumbo buffer allocation failed The driver failed to allocate memory for jumbo frames
ti%d: bios thinks we're in a 64 bit slot, but we aren't The BIOS has programmed the NIC as
though it had been installed in a 64-bit PCI slot, but in fact the NIC is in a 32-bit slot.
This happens as a result of a bug in some BIOSes. This can be worked around on the Tigon
II, but on the Tigon I initialization will fail.
ti%d: board self-diagnostics failed! The ROMFAIL bit in the CPU state register was set
after system startup, indicating that the on-board NIC diagnostics failed.
ti%d: unknown hwrev The driver detected a board with an unsupported hardware revision. The
ti driver supports revision 4 (Tigon 1) and revision 6 (Tigon 2) chips and has firmware only
for those devices.
ti%d: watchdog timeout The device has stopped responding to the network, or there is a
problem with the network connection (cable).
netintro(4), pci(4), ifconfig(8)
The ti device driver first appeared in NetBSD 1.4.2.
The ti driver was written by Bill Paul <firstname.lastname@example.org>.
The driver currently tries to access some on-board memory transparently. This mapping
(BUS_SPACE_MAP_LINEAR) fails on systems where the corresponding PCI memory range is located
in "sparse" space only.
This driver currently does not work on big-endian systems.
BSD June 2, 2001 BSD