|Linux & Unix Commands - Search Man Pages
NJATA(4) BSD Kernel Interfaces Manual NJATA(4)
njata -- Workbit NinjaATA-32 CardBus IDE controller driver
njata* at cardbus? function ?
njata* at cardbus? function ? flags 0x01 # with wait 0x01
The njata driver provides support for the following Workbit Bus-Master CardBus IDE con-
NinjaATA-32Bi CardBus / PCMCIA dual mode IDE controller (``DuoATA''). This con-
troller is mainly used for portable drives. This driver supports the
NPATA-32 CardBus IDE controller. This controller is widely used for CardBus
These controllers are capable of bus-mastering for ATA PIO transfer. The njata driver uses
the bus-mastering PIO transfer unless transfer buffer is unaligned, and significantly
reduces CPU usage for PIO-only ATA devices compared with usual PIO transfer.
The optional flags parameter is the ``wait'' value for ATA transfers. Some combinations of
host and device may fail without flags parameter or flags 0x00. In this case try adding
wait values like flags 0x01 or flags 0x11 (the wait parameter is composed of two 4bit val-
ues). Smaller wait values should be faster. Too long waits may cause transfer errors.
ata(4), atapi(4), cardbus(4), intro(4), wd(4), wdc(4)
The njata device driver first appeared in NetBSD 4.0.
BSD September 7, 2006 BSD
All times are GMT -4. The time now is 02:16 AM.