NFSMB(4) BSD Kernel Interfaces Manual NFSMB(4)NAME
nfsmb, nfsmbc -- NVIDIA nForce 2/3/4 SMBus controller and SMBus driver
nfsmbc* at pci? dev ? function ?
nfsmb* at nfsmbc?
iic* at nfsmb?
The nfsmbc provides support for the NVIDIA nForce 2/3/4 SMBus controller. The nfsmbc has two SMBus (nfsmb).
SEE ALSO iic(4), pci(4)HISTORY
The nfsmb driver appeared in NetBSD 4.0.
BSD January 8, 2010 BSD
Check Out this Related Man Page
ACPISMBUS(4) BSD Kernel Interfaces Manual ACPISMBUS(4)NAME
acpismbus -- ACPI SMBus Control Method Interface
acpismbus* at acpi?
iic* at acpismbus?
The acpismbus driver supports instances of the ACPI SMBus Control Method Interface. This enables i2c access to bus segments which might not
otherwise be accessible due to missing "native" driver support. The SMBus Process Call protocol is not supported. All other SMBus protocols
are supported to the extent that the underlying controller supports them.
SEE ALSO acpi(4), iic(4)HISTORY
The acpismbus driver appeared in NetBSD 6.0.
Although acpismbus SMBus Alerts can be associated with individual devices, this capability is ignored. When an acpismbus SMBus Alert is gen-
erated, all devices on the i2c bus segment which have registered an interrupt routine are notified.
The SMBus CMI protocol defines a method to provide a list of devices on an i2c bus segment and their addresses. The acpismbus driver makes
no attempt to retrieve or process this device list.
There is currently no way to determine if the i2c controller managed by an instance of the ACPI SMBus CMI can also be accessed using a native
device driver. Therefore, the acpismbus driver should not be enabled by default. If both a native driver and the acpismbus driver attempt
to access the same i2c bus segment, the results are undefined.
BSD February 6, 2010 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)