HCIDE(4) BSD Kernel Interfaces Manual HCIDE(4)NAME
dtide -- HCCS IDE interface driver
hcide* at podulebus0 slot ?
ata* at hcide? channel ?
The dtide driver handles an HCCS IDE interface plugged into an Acorn expansion slot. It uses the standard NetBSD IDE controller driver, and
hence can use the standard atabus driver.
The card provides three IDE channels. The internal 44-way IDE connector is channel 0, the internal 40-way connector is channel 1 and the
external connector is channel 2.
SEE ALSO atabus(4), atapibus(4), podulebus(4), wd(4)BUGS
The driver was derived by reverse-engineering the card, so it may not handle the card entirely optimally.
BSD October 8, 2003 BSD
Check Out this Related Man Page
IXPIDE(4) BSD Kernel Interfaces Manual IXPIDE(4)NAME
ixpide -- PCI IDE disk controllers driver
ixpide* at pci? dev ? function ? flags 0x0000
The ixpide driver supports the ATI Technologies IXP IDE controller, and provides the interface with the hardware for the ata(4) driver.
The 0x0002 flag forces the ixpide driver to disable DMA on chipsets for which DMA would normally be enabled. This can be used as a debugging
aid, or to work around problems where the IDE controller is wired up to the system incorrectly.
The supported IDE controllers are
o ATI SB200
o ATI SB300
o ATI SB400, Parallel ATA
o ATI SB400, Serial ATA
o ATI SB700, Serial and Parallel ATA
SEE ALSO ata(4), atapi(4), intro(4), pci(4), pciide(4), wd(4), wdc(4)CAVEATS
Some SB700 controllers can hang under load when Native IDE mode is selected in the system BIOS, but work fine in AHCI mode.
BSD October 16, 2008 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)