CUDA(4) BSD Kernel Interfaces Manual CUDA(4)NAME
cuda -- support for CUDA microcontrollers found in many Power Macintosh and compatible computers
cuda* at obio?
nadb* at cuda?
iic* at cuda?
The cuda driver provides support for the CUDA microcontroller found in many Power Macintosh and compatible computers, mostly Old World desk-
top machines. CUDA controls the real time clock, ADB, power and on some machines an iic(9) bus.
SEE ALSO iic(4), nadb(4), obio(4), pmu(4), sgsmix(4)BSD May 14, 2007 BSD
Check Out this Related Man Page
PMU(4) BSD Kernel Interfaces Manual PMU(4)NAME
pmu -- support for Power Management Units found in all Apple laptops and some desktop Power Macintosh computers
pmu* at obio?
nadb* at pmu?
battery* at pmu?
smartbat* at pmu?
The pmu driver provides support for the Power Management Unit found in Apple laptops and some desktop Power Macintosh computers. Functions
controlled by the PMU include the real time clock, ADB, power, batteries, on some laptops like the PowerBook 3400c and similar machines it
also controls hotkeys and display brightness, on others it provides an iic(9) bus and on some it controls CPU speed. On many older machines
it also provides access to some non-volatile memory and thermal sensors. Not all those features are present on all machines, for instance
Power Macintosh G4 and later machines don't have ADB, many more recent laptops have display brightness and backlight control built into the
graphics controller instead of the PMU, only a few older PowerBooks use the PMU for CPU speed control and newer machines use a different way
to access non-volatile memory. However, all known PMUs so far provide a real time clock and power control.
Notes by model
Real time clock and power control are present and supported on all machines that can run NetBSD/macppc, ADB is supported when present.
PowerBook 2400, 3400c, and 3500
Battery status and thermal sensors found on the mainboard and in the battery pack are supported by the battery(4) driver, val-
ues can be read via envsys(4). Hotkeys for brightness control are supported, CPU speed control and parameter RAM are present
Power Macintosh G4
ADB is not present, iic(9) is present but unsupported.
SEE ALSO battery(4), cuda(4), nadb(4), nvram(4), obio(4), iic(9)BUGS
Some features are currently unsupported, like the iic(9) bus, access to parameter RAM and CPU speed control.
BSD May 14, 2007 BSD
i want begin programming using CUDA
which enviroment can i get .I don't have desktop to buy GPU graphics card.
what should to do to get CUDA enviroment.
i'm thinking to buy desktop has this card or laptop (1 Reply)
I am trying to start troubleshooting an error on a virtual server that uses the ubuntu 14.04 OS. Basically what happens (seeming random) is that the GPU stops processing and terminates. What Imean by seeming random is that for 3 runs there is no error then on run 4 the error appears. It has... (2 Replies)