Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ttys(5) [bsd man page]

TTYS(5) 							File Formats Manual							   TTYS(5)

NAME
ttys - terminal initialization data DESCRIPTION
The ttys file contains information that is used by various routines to initialize and control the use of terminal special files. This information is read with the getttyent(3) library routines. There is one line in the ttys file per special file. Fields are separated by tabs and/or spaces. Some fields may contain more than one word and should be enclosed in double quotes. Blank lines and comments can appear anywhere in the file; comments are delimited by `#' and new line. Unspecified fields default to null. The first field is the termi- nal's entry in the device directory, /dev. The second field of the file is the command to execute for the line, typically getty(8), which performs such tasks as baud-rate recognition, reading the login name, and calling login(1). It can be, however, any desired command, for example the start up for a window system terminal emulator or some other daemon process, and can contain multiple words if quoted. The third field is the type of terminal normally connected to that tty line, as found in the termcap(5) data base file. The remaining fields set flags in the ty_status entry (see getttyent(3)) or specify a window system process that init(8) will maintain for the terminal line. As flag values, the strings `on' and `off' specify whether init should execute the command given in the second field, while `secure' in addition to `on' allows root to login on this line. These flag fields should not be quoted. The string `window=' is followed by a quoted command string which init will execute before starting getty. If the line ends in a comment, the comment is included in the ty_comment field of the ttyent structure. Some examples: console "/usr/libexec/getty std.1200" vt100 on secure ttyd0 "/usr/libexec/getty d1200" dialup on # 555-1234 ttyh0 "/usr/libexec/getty std.9600" hp2621-nl on # 254MC ttyh1 "/usr/libexec/getty std.9600" plugboard on # John's office ttyp0 none network ttyp1 none network off ttyv0 "/usr/new/xterm -L :0" vs100 on window="/usr/new/Xvs100 0" The first example permits root login on the console at 1200 baud, the second allows dialup at 1200 baud without root login, the third and fourth allow login at 9600 baud with terminal types of "hp2621-nl" and "plugboard" respectively, the fifth and sixth line are examples of network pseudo ttys, which should not have getty enabled on them, and the last example shows a terminal emulator and window system startup entry. FILES
/etc/ttys SEE ALSO
login(1), getttyent(3), gettytab(5), init(8), getty(8) 7th Edition November 16, 1996 TTYS(5)

Check Out this Related Man Page

GETTTYENT(3)						   BSD Library Functions Manual 					      GETTTYENT(3)

NAME
getttyent, getttynam, setttyent, endttyent -- get ttys file entry LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <ttyent.h> struct ttyent * getttyent(void); struct ttyent * getttynam(const char *name); int setttyent(void); int endttyent(void); DESCRIPTION
The getttyent(), and getttynam() functions each return a pointer to an object, with the following structure, containing the broken-out fields of a line from the tty description file. struct ttyent { char *ty_name; /* terminal device name */ char *ty_getty; /* command to execute, usually getty */ char *ty_type; /* terminal type for termcap */ #define TTY_ON 0x01 /* enable logins (start ty_getty program) */ #define TTY_SECURE 0x02 /* allow uid of 0 to login */ #define TTY_DIALUP 0x04 /* is a dialup tty */ #define TTY_NETWORK 0x08 /* is a network tty */ int ty_status; /* status flags */ char *ty_window; /* command to start up window manager */ char *ty_comment; /* comment field */ char *ty_group; /* tty group name */ }; The fields are as follows: ty_name The name of the character-special file. ty_getty The name of the command invoked by init(8) to initialize tty line characteristics. ty_type The name of the default terminal type connected to this tty line. ty_status A mask of bit fields which indicate various actions allowed on this tty line. The possible flags are as follows: TTY_ON Enables logins (i.e., init(8) will start the command referenced by ty_getty on this entry). TTY_SECURE Allow users with a uid of 0 to login on this terminal. TTY_DIALUP Identifies a tty as a dialin line. TTY_NETWORK Identifies a tty used for network connections. ty_window The command to execute for a window system associated with the line. ty_group A group name to which the tty belongs. If no group is specified in the ttys description file, then the tty is placed in an anonymous group called "none". ty_comment Any trailing comment field, with any leading hash marks (``#'') or whitespace removed. If any of the fields pointing to character strings are unspecified, they are returned as null pointers. The field ty_status will be zero if no flag values are specified. See ttys(5) for a more complete discussion of the meaning and usage of the fields. The getttyent() function reads the next line from the ttys file, opening the file if necessary. The setttyent() function rewinds the file if open, or opens the file if it is unopened. The endttyent() function closes any open files. The getttynam() function searches from the beginning of the file until a matching name is found (or until EOF is encountered). RETURN VALUES
The routines getttyent() and getttynam() return a null pointer on EOF or error. The setttyent() function and endttyent() return 0 on failure and 1 on success. FILES
/etc/ttys SEE ALSO
login(1), ttyslot(3), gettytab(5), termcap(5), ttys(5), getty(8), init(8) HISTORY
The getttyent(), getttynam(), setttyent(), and endttyent() functions appeared in 4.3BSD. BUGS
These functions use static data storage; if the data is needed for future use, it should be copied before any subsequent calls overwrite it. BSD
November 17, 1996 BSD
Man Page