I would worry what is consuming your memory first:-
Highest consuming process at the bottom. Process ID is third column.
The general rule of thumb was always double memory but I've heard more recently it should be 4 times, but at your allocated memory size, that's getting quite large. There is no fixed rule. You can add as much as you have disk space for pretty much.
I would suggest a volume group just for paging LVs though. Keeping it out of rootvg will improve performance (assuming that the disks are sensible) because of rootvg contention. Similarly, you don't want it on your application or data disks.
Keeping only a minimal hd6 will give you more chance of recovering a mksysb too. If you put huge paging LVs in rootvg, you must be able to accommodate them (and any mirror) on your DR server.
Have a measure of paging activity too. Something like vmstat 10 will give you a good report of how much reading and writing you are doing. If it's high, this will affect performance, so you are looking at real memory to alleviate that. Search out the high memory users first though.
We had an issue where code was firing up another module based on a user request and then no freeing memory at the end. The on-line users had huge allocation by the end of the day as they used each function. Our programmers found how to de-allocated memory when it was not required and the performance boost was very impressive. The cost of re-reading code was far less than the strain on the machine with all the paging.
For 32Gb memory, I would suggest starting at around 128Gb paging. Do you have the space for that? If you allocate it in a few large chunks, then you will be better able to adjust it later, rather that 128 x 1Gb LVs or 1 x 128Gb LV.
Is your server suffering from no-memory and getting failures?
Have a look with errpt -a | more which shows the most recent issues at the top. There may be comments about dump space, swap/page space exhaustion along with full filesystem alerts and hardware failures.
You seem to have lost the end of your post. What else were you about to say?
It's only a suggestion and open to adjustment as murali969 sees fit, also hence why (s)he should create several paging spaces to meet the needs, so they are flexible. The real issue is whatever is using all that real memory.
I haven't got anything that big available to me because we do everything on the super cheap for hardware and pay the price in performance and upgrades later.
Sorry, but I do not agree with such large Paging Spaces at all.
You don't want your application to use Paging Space since it will be really slow and will decrease the performance of your application considerably up to uselessness.
The old factors to size Paging Space do not fit anymore today at all.
For now 6 GB should be ok - you need to find out why your box is paging at all. There is some things you can tune on the behaviour how the Virtual Memory Manager (VMM) behaves when checking for the rate of RAM being used for file caching and for process data.
The other problem you could be, that you have a memory leak somewhere and that could be the reason you are running out of RAM and so it starts paging after some time.
For a start, please post the output of the following commands and use [code] and [/code] tags when doing so:
Last edited by zaxxon; 11-12-2013 at 01:18 PM..
Reason: added stuff, typos
These 3 Users Gave Thanks to zaxxon For This Post:
Whilst perfoming some tests on lvm's I managed to crash our test box. No real problem as it is only used by our tech team.
however I would like to know why this was actually caused as the task being performed at the time was one which I though would not have any impact.
Using dd I was... (5 Replies)
Hi,
I have paging size 2048M showed from topas and 10240M showed from "lsps -a", can anyone tell what is the difference? and how to change the PAGING SIZE (showed in topas) to 8192M?
Can you please tell in detail step?
Thanks!
Victor
#topas
Topas Monitor for host: egsprc01dev ... (10 Replies)
Hello dear friends, We have VG filevg which consists of 2 PVs when I rechecked the VG there is no Pagingspace LV.. The VG is usually Highly loaded because much reads and writes.. Is this a must to create Paging space on the specified LV? (2 Replies)
Hello everyone
I have a doubt about how many paging space can have in the same disk.
lsps -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type
paging00 hdisk0 rootvg 3072MB 1 yes yes lv
hd6 hdisk0 ... (4 Replies)
Hi
I have used gzip on AIX and the used paging space has jumped from 7% to 20%. The gzip process is finished since a long time. But the used paging space is still the same. How to release this space ? (1 Reply)
Hello everyone
I have 4g of paging space in my rootvg disk
I´m going to reduce them to 1gb in my rootvg disk and add 3gb of paging space on my san disk.
My rootvg disk is mirror.
My question is I can do this on line ?
and I can do with the mirror ? or I need to unmirror first my... (2 Replies)
sorry for this silly question, I am new to UNIX,
what is meant by paging space and what is its purpose?
what is also meant by hd6 paging space? (2 Replies)
Hello, we have a problem with lpar with AIX 5.3, the issue is that has high level paging space with: _sqlsrv2 and its incremented continously (1 Reply)
This is my first post, and I am new to the UNIX world. Hopefully this question won't be too lame.
I know that I can use topas to see the paging space used by some processes. I would like to script something that can add up the paging space used by process owned by or associated with an... (1 Reply)