Sponsored Content
Full Discussion: Unable to create a SPOT
Operating Systems AIX Unable to create a SPOT Post 302927200 by trivium012 on Monday 1st of December 2014 01:12:43 PM
Old 12-01-2014
Unable to create a SPOT

Hi everyone!

Ok so I'm trying for the first time to install AIX on a LPAR with NIM.

The NIM:
Code:
root@oaexpnimp01(/home/root) # oslevel -s
6100-08-02-1316

I'm trying to install AIX 6.1 TL1. I successfully created a new lpp source

Code:
root@oaexpnimp01(/home/root) # lsnim -l AIX61_TL1_2
AIX61_TL1_2:
   class       = resources
   type        = lpp_source
   arch        = power
   Rstate      = ready for use
   prev_state  = unavailable for use
   location    = /nim/lppsource/AIX61_TL1_2
   simages     = yes
   alloc_count = 0
   server      = master

Now I'm trying to create the SPOT

Code:
root@oaexpnimp01(/home/root) # nim -o define -t spot -a server=master -a location=/nim/spot -a source=AIX61_TL1_2  spot-LPP_AIX61_TL1_2

 Creating SPOT in "/nim/spot" on machine "master" from "AIX61_TL1_2" ...

 Restoring files from BOS image.  This may take several minutes ...


 Checking filesets and network boot images for SPOT "spot-LPP_AIX61_TL1_2".
 This may take several minutes ...

warning: 0042-001 m_mkspot: processing error encountered on "master":
   0042-175 c_ch_nfsexp: An unexpected result was returned by the
        "/usr/sbin/exportfs" command:
        exportfs: 1831-186 /nim/lppsource/AIX61_TL1_2 not found in /etc/exports


rc=0
warning: 0042-001 m_instspot: processing error encountered on "master":
   0042-175 c_ch_nfsexp: An unexpected result was returned by the
        "/usr/sbin/exportfs" command:
        exportfs: 1831-186 /nim/lppsource/AIX61_TL1_2 not found in /etc/exports


rc=0
warning: 0042-001 m_instspot: processing error encountered on "master":
   0042-062 m_ckspot: "spot-LPP_AIX61_TL1_2" is missing something which is
        required

It said it failed but when i look it up, it exists with an error:

Code:
root@oaexpnimp01(/home/root) # lsnim -l spot-LPP_AIX61_TL1_2
spot-LPP_AIX61_TL1_2:
   class         = resources
   type          = spot
   arch          = power
   Rstate        = information is missing from this object's definition
   prev_state    = verification is being performed
   info          = warning: 0042-157 c_ckspot: unable to access the "/nim/spot/spot-LPP_AIX61_TL1_2/usr/./lpp/bosinst/image.template" file
   location      = /nim/spot/spot-LPP_AIX61_TL1_2/usr
   version       = 6
   release       = 1
   mod           = 1
   oslevel_r     = 6100-01
   alloc_count   = 0
   server        = master
   Rstate_result = success
   mk_netboot    = yes
   missing       = "network boot image"
   missing       = bos.64bit
   missing       = bos.diag
   missing       = bos.mp64
   missing       = bos.net.nfs.client
   missing       = bos.net.tcp.client
   missing       = bos.net.tcp.smit
   missing       = bos.sysmgt.nim.client
   missing       = bos.sysmgt.nim.spot
   missing       = bos.sysmgt.serv_aid
   missing       = bos.sysmgt.smit
   missing       = bos.sysmgt.sysbr
   missing       = bos.terminfo
   missing       = bos.wpars
   missing       = mcr.rte

I know the error message is quite explicit, but when I look at my exported file, everything is there:

Code:
root@oaexpnimp01(/home/root) # exportfs
/nim/VIOS        -vers=3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=ottvio1:oaexpviop01:oaexpviop02
/opera/scripts   -sec=sys:krb5p:krb5i:krb5:dh,rw
/nim/HMC         -vers=3,sec=sys:krb5p:krb5i:krb5:dh,access=otthmc1,root=otthmc1
/opera/nimfs     -vers=3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=ottwaspsp:ottland1:ottutil:ottwas1:ottfircoqa:oaexpswpp01:ottdb1:oadejlandt01:oaexpnimp01:oaexpaix06:ottapps:oaexpsaap01:oaexpfffp01:oablcsaap01:oadejsaap01:oadejmqmdt01:oablclanp01:oadejlanp01:oahedwasp01:oablcsaat1:oadejmqmp01:otticdqa:oamcbappp01:oldejwasdt01:oldejdb2dt01:oldejwasp01:oldejdb2p01:oaacpwasp01:olicdlanp01:olsncwasp01:olsncdb2p01
/nim/mksysb      -vers=2:3,sec=sys:krb5p:krb5i:krb5:dh,root=ottwaspsp:ottland1:ottutil:ottwas1:ottfircoqa:oaexpswpp01:ottvio1:oaexpviop01:oaexpviop02:ottdb1:oaexpfffp01:oadejlandt01:oaexpnimp01:oaexpaix06:ottapps:oaexpsaap01:oablcsaap01:oadejsaap01:oadejmqmdt01:oablclanp01:oadejlanp01:oahedwasp01:oablcsaat1:oadejmqmp01:oamcbappp01:oaacpwasp01
/opera/logiciels -vers=3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=olicdlanp01:olsncwasp01:olsncdb2p01:olexpwpsr01
/nim/lppsource   -vers=2:3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=ottland1:oaexpnimp01
root@oaexpnimp01(/home/root) # exportfs -ua
root@oaexpnimp01(/home/root) # exportfs
exportfs: 1831-182 nothing exported
root@oaexpnimp01(/home/root) # exportfs -a
root@oaexpnimp01(/home/root) # exportfs
/nim/VIOS        -vers=3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=ottvio1:oaexpviop01:oaexpviop02
/opera/scripts   -sec=sys:krb5p:krb5i:krb5:dh,rw
/nim/HMC         -vers=3,sec=sys:krb5p:krb5i:krb5:dh,access=otthmc1,root=otthmc1
/opera/nimfs     -vers=3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=ottwaspsp:ottland1:ottutil:ottwas1:ottfircoqa:oaexpswpp01:ottdb1:oadejlandt01:oaexpnimp01:oaexpaix06:ottapps:oaexpsaap01:oaexpfffp01:oablcsaap01:oadejsaap01:oadejmqmdt01:oablclanp01:oadejlanp01:oahedwasp01:oablcsaat1:oadejmqmp01:otticdqa:oamcbappp01:oldejwasdt01:oldejdb2dt01:oldejwasp01:oldejdb2p01:oaacpwasp01:olicdlanp01:olsncwasp01:olsncdb2p01
/nim/mksysb      -vers=2:3,sec=sys:krb5p:krb5i:krb5:dh,root=ottwaspsp:ottland1:ottutil:ottwas1:ottfircoqa:oaexpswpp01:ottvio1:oaexpviop01:oaexpviop02:ottdb1:oaexpfffp01:oadejlandt01:oaexpnimp01:oaexpaix06:ottapps:oaexpsaap01:oablcsaap01:oadejsaap01:oadejmqmdt01:oablclanp01:oadejlanp01:oahedwasp01:oablcsaat1:oadejmqmp01:oamcbappp01:oaacpwasp01
/opera/logiciels -vers=3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=olicdlanp01:olsncwasp01:olsncdb2p01:olexpwpsr01
/nim/lppsource   -vers=2:3,sec=sys:krb5p:krb5i:krb5:dh,rw,root=ottland1:oaexpnimp01

When i try to recreate the SPOT after unexporting the FS and re-export them, the still occurs. Anyone has an idea for me?

I'm still new AIX installation Smilie

Regards,
Trivium012
 

10 More Discussions You Might Find Interesting

1. AIX

Unable to create a group

Hi, I'm trying to create a new group on an AIX 5.2.0.0. server but am getting the following error: root:/root $ mkgroup debt 3004-698 Error committing changes to "debt" : Value is invalid. I've change the group name to no affect. Does anyone have any ideas what could be causing this? ... (0 Replies)
Discussion started by: m223464
0 Replies

2. Solaris

unable to create flar

Hello friend, Now i'm doing JDS3.1 in v440 servers.while checking the lustatus command getiing out like this lustatus Boot Environment Is Active Active Can Copy Name Complete Now On Reboot Delete Status -------------------------- --------... (0 Replies)
Discussion started by: rjay.com
0 Replies

3. UNIX for Dummies Questions & Answers

Unable to create alias

I am using Solaris 9 machine. I am unable to create any aliases. I gave the following command: alias ls='ls -ltr' It did nt give any errors. But next time, I use ls, it is working simply as ls but not like ls -ltr. I am not having admin permissions. Is it the reason. (3 Replies)
Discussion started by: mumashankar
3 Replies

4. UNIX for Dummies Questions & Answers

Unable to create a bootable tape

Good morning, I have no unix training. My daily backup failed with the following error. ' Cannot create /tmp/tape.bootimage because it already exists. I am using smit to run a rootvg and SAPvg backup. What should I do? (1 Reply)
Discussion started by: ubyankees
1 Replies

5. HP-UX

Need help. Unable to create threads after a certain number

Hi, I have a process which creates pthreads to generate some reports. After creating the reports these threads return null. But after 1024 threads, the process is not able to create any threads further.,and at max 5 threads are existing simultaneously and are returning the control back after... (2 Replies)
Discussion started by: Krsh
2 Replies

6. Solaris

Unable to create folder as a user

Hi All, I am trying to create a folder in /export/home/user1 directory as a user1 but I am getting the error message as -bash-3.00$ mkdir abc mkdir: Failed to make directory "abc"; Permission denied Also I tried creating the folder but it fails too -bash-3.00$ touch abc touch: cannot... (2 Replies)
Discussion started by: Manjunath K V
2 Replies

7. Red Hat

unable to open / create any file in vi

Hi, I am unable to create/open any file in vi editor for normal user, though using root I am able to create/open any file, using redhat 5.5, example vi test it showing nothing after entering command (9 Replies)
Discussion started by: manoj.solaris
9 Replies

8. AIX

Unable to Create spot from mksysb

Hello All, Kindly need help in my problem i.e. I get this error when i create spot from mksysb. #0042-001 nim: processing error encountered on "master": 0042-001 m_mkspot: processing error encountered on "master": 0042-175 c_mkspot: An unexpected result was returned by the... (2 Replies)
Discussion started by: emerann
2 Replies

9. Forum Support Area for Unregistered Users & Account Problems

Unable to create new thread

Hi. I registered, but when trying to post, I get ... "Sorry, you do not have enough Bits to post a new thread" Google & Forum search showed some hits, but no solution. Please advide. Thanks! (1 Reply)
Discussion started by: gehe
1 Replies

10. Solaris

Unable to create a ftp user only

Hi all I am facing difficulties when using the useraddcommand. when running useradd -u 60006 -g 100 -d /opt/xxx/yyy/z -m -s /bin/false ftpuser It does create the user, but with a wrong home directory. It creates its home directory at /home/ftpuser Please can you help? (2 Replies)
Discussion started by: fretagi
2 Replies
All times are GMT -4. The time now is 03:10 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy