Sponsored Content
Operating Systems Solaris Host name in front of pkginfo output Post 302894122 by Don Cragun on Monday 24th of March 2014 04:50:31 AM
Old 03-24-2014
Try something like:
Code:
host=$(uname -n)
pkginfo -l | /usr/xpg4/bin/awk -v host="$host" '
/NAME:/ {
	gsub(/(^ *NAME: *)|( *$)/, "")
	printf("%s,\"%s\",", host, $0)
	next
}
/VERSION:/ {
	gsub(/(^ *VERSION: *)|( *$)/, "")
	printf("\"%s\",", $0)
	next
}
/BASEDIR:/ {
	gsub(/(^ *BASEDIR: *)|( *$)/, "")
	print
}'

Note that you can't have a comma in a field in a comma separated file unless the fields that contain commas in the data are quoted. This script quotes the NAME and VERSION fields since it seems doubtful that the hostname and BASEDIR fields will ever contain commas. (Or, if they do, it should be obvious how to add the quotes if they are needed for those fields.) For the input shown, you should get something like the following from the above script:
Code:
HostName,"Z shell (zsh)","11.10.0,REV=2005.01.08.05.16",/
HostName,"Tripwire Enterprise Agent","8.2.3",/usr/local/tripwire/te/agent
HostName,"SEA client support sunOS v5","2.4.1.3",/

 

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

format and pkginfo -l question

I have a Solaris 2.6 box flagging an "Error block: 308918" in the messages file when I execute a pkginfo -l. pkginfo with no flags returns no errors. I think I need to use format to mark this block and then restore the database used by pkginfo for backup. Any advice/input welcome. Thanks (4 Replies)
Discussion started by: 98_1LE
4 Replies

2. UNIX for Dummies Questions & Answers

Sending tar output to a remote host

Our group has recently inherited 15 servers that have not been maintained for over a year. My first action is to backup the units however there is not enough disk space on most of them to run tar. My supervisor said to look at piping the tar output to another machine, however I have been unable... (3 Replies)
Discussion started by: thumper
3 Replies

3. Solaris

difference between pkginfo and pkgchk command

can anyone explain me the difference between pkginfo and pkgchk command in solaris. Both are used to display the package details, then what is the difference between both. (5 Replies)
Discussion started by: rogerben
5 Replies

4. UNIX for Advanced & Expert Users

rpm and pkginfo question

Can the root hide some of the results of the above commands from a regular user? i.e. $>rpm and $>sudo rpm will give different results (1 Reply)
Discussion started by: noam128
1 Replies

5. Solaris

grep help with pkginfo

im looking for a way to eliminate the packages from SUN when i do a pkginfo. thought this would work, but no luck. pkginfo | grep what am i doing wrong? Thanks (2 Replies)
Discussion started by: jrich523
2 Replies

6. Shell Programming and Scripting

rsh to many hosts the ftp output to single host

Hi guys. i need some help, i need to create a script in tcsh that rsh into all my hosts that we have at our business, then cd to a directory (cd /apps/users) then grab a file from the users folder and ftp it back to my windows machine. can someone please help? Kind regards. Brian Behrens (2 Replies)
Discussion started by: brian112
2 Replies

7. Solaris

pkgadd, pkginfo, ssh not working

Got a feeling someone has been fiddling around or something has got corrupt but I'm getting the following errors now:- -bash-3.00# pkginfo ld.so.1: pkginfo: fatal: libssl.so.0.9.7: open failed: No such file or directory Killed -bash-3.00# and also ssh:- -bash-3.00# ssh ld.so.1: ssh:... (5 Replies)
Discussion started by: psychocandy
5 Replies

8. Solaris

Host name in front of ps output

hello All. I am working on something that should be really simply. It turns out that its not. I am trying to produce output to list the hostname along with all the current running programs. the script im using is: for PS in `ps -Ao "user,args" | cut -d' ' -f1,2` do echo "`uname -n`, $PS"... (5 Replies)
Discussion started by: busi386
5 Replies

9. UNIX for Dummies Questions & Answers

How to get/print host string only from tnsping output?

Hello All, I am using Linux OS. My idea is get the host name when we do tnsping in oracle. output of : tnsping DOELO01 TNS Ping Utility for Linux: Version 11.2.0.3.0 - Production on 15-OCT-2015 20:20:05 Copyright (c) 1997, 2011, Oracle. All rights reserved. Used parameter files:... (2 Replies)
Discussion started by: Ariean
2 Replies

10. UNIX for Beginners Questions & Answers

Output top line for each unique host

Hi All, Please can you help with the output whole line for each host (column 3) and the top line of column 9 - the lastest only What is being outputted 243272484 3 nbmedln1p03 LDN_TEST_UX_JM 1488198368 0000000007 1 INC_1MTH 0 ********** 243272492 3 nbmedln1p03 LDN_TEST_UX_JM... (10 Replies)
Discussion started by: Junes
10 Replies
packagetoc(4)							   File Formats 						     packagetoc(4)

NAME
packagetoc - package table of contents description file DESCRIPTION
The package table of contents file, .packagetoc, is an ASCII file containing all of the information necessary for installing a product release distributed in package form. It centralizes and summarizes all of the relevant information about each package in the product. This allows the install software to quickly read one file to obtain all of the relevant information about each package instead of having to examine each package at run time to obtain this information. The .packagetoc file resides in the top-level directory containing the prod- uct. If a .packagetoc file exists for a product, there must also be a .order file. Each entry in the .packagetoc file is a line that establishes the value of a parameter in the following form: PARAM=value A line starting with a pound-sign, ``#'', is considered a comment and is ignored. Parameters are grouped by package. The start of a package description is defined by a line of the form: PKG=value There is no order implied or assumed for specifying the parameters for a package with the exception of the PKG parameter, which must appear first. Only one occurrence of a parameter is permitted per package. The parameters recognized are described below. Those marked with an asterisk are mandatory. PKG* The package identifier, for example, SUNWaccu. The maximum length of the identifier is nine characters. All the characters must be alphanumeric. The first character must be alphabetic. install, new, and all are reserved iden- tifiers. PKGDIR* The name of the directory containing the package. This directory is relative to the directory containing the prod- uct. NAME* The full name of the package. VENDOR The name of the package's vendor. VERSION The version of the package. PRODNAME The name of the product to which this package belongs. PRODVERS The version of the product to which this package belongs. SUNW_PKGTYPE The package type. Valid values are: root indicates that the package will be installed in the / file system. The root packages are the only packages installed during dataless client installations. The root packages are spooled during a server installa- tion to allow the later installation of diskless clients. usr indicates that the package will be installed in the /usr file system. kvm indicates that the package will be installed in the /usr/platform file system. ow indicates a package that is part of the bundled OpenWindows product release. If no SUNW_PKGTYPE macro is present, the package is assumed to be of type usr. ARCH* The architecture(s) supported by the package. This macro is taken from the package's pkginfo(4) file and is sub- ject to the same length and formatting constraints. The install program currently assumes that exactly one architecture token is specified for a package. For example, ARCH=sparc.sun4u is acceptable, but ARCH=sparc.sun4u, sparc.sun4m is not. DESC A detailed textual description of the package. BASEDIR* The default installation base directory of the package. SUNW_PDEPEND A dependency specification for a prerequisite package. Each prerequisite dependency must appear as a separate macro. See depend(4) for more information on dependencies and instance specifications. SUNW_IDEPEND A dependency specification for an incompatible package. Each incompatible dependency should appear as a separate macro. See depend(4) for more information on dependencies and instance specifications. SUNW_RDEPEND A dependency specification for a reversed package dependency. Each reverse dependency should appear as a separate macro. See depend(4) for more information on dependencies and instance specifications. CATEGORY The category of the package. SUNW_LOC Indicates that this package contains localizations for other packages. Such localization packages are treated as special case packages. Each package which has a SUNW_LOC macro must have a corresponding SUNW_PKGLIST macro. The value specified by this macro should be a valid locale. SUNW_PKGLIST A comma separated list of package identifiers. Currently this macro is used to indicate which packages are local- ized by a localization package. ROOTSIZE* The space used by the package in the / file system. USRSIZE* The space used by the package in the /usr subtree of the file system. VARSIZE* The space used by the package in the /var subtree of the file system. OPTSIZE* The space used by the package in the /opt subtree of the file system. EXPORTSIZE* The space used by the package in the /export subtree of the file system. USROWNSIZE* The space used by the package in the /usr/openwin subtree of the file system. SPOOLEDSIZE* The space used by the spooled version of this package. This is used during the setup of a server by the initial system installation programs. All sizes are specified in bytes. Default disk partitions and file system sizes are derived from the values provided: accuracy is impor- tant. EXAMPLES
Example 1: A Sample .packagetoc File The following is an example package entry in a .packagetoc file. #ident "@(#)packagetoc.4 1.2 92/04/28" PKG=SUNWaccr PKGDIR=SUNWaccr NAME=System Accounting, (Root) VENDOR=Sun Microsystems, Inc. VERSION=8.1 PRODNAME=SunOS PRODVERS=5.0beta2 SUNW_PKGTYPE=root ARCH=sparc DESC=System Accounting, (Root) BASEDIR=/ CATEGORY=system ROOTSIZE=11264 VARSIZE= 15360 OPTSIZE=0 EXPORTSIZE=0 USRSIZE=0 USROWNSIZE=0 SEE ALSO
cdtoc(4), clustertoc(4), depend(4), order(4), pkginfo(4), pkgmap(4) NOTES
The parameters NAME, VENDOR, VERSION, PRODNAME, PRODVERS, SUNW_PKGTYPE, SUNW_LOC, SUNW_PKGLIST, ARCH, DESC, BASEDIR, and CATEGORY are assumed to have been taken directly from the package's pkginfo(4) file. The length and formatting restrictions placed on the values for these parameters are identical to those for the corresponding entries in the pkginfo(4) file. The value specified for the parameter PKGDIR should not exceed 255 characters. The value specified for the parameters ROOTSIZE, VARSIZE, OPTSIZE, EXPORTSIZE, USRSIZE and USROWNSIZE must be a single integer value. The values can be derived from the package's pkgmap file by counting all space consumed by any files installed in the applicable file system. The space includes that used for directory entries and any UFS overhead that exists because of the way the files are represented (directory allocation scheme; direct, indirect, double indirect blocks; fragments; etc.) The following kinds of entries in the pkgmap(4) file should be included in the space derivation: f regular file c character special file b block special file p pipe l hard link s symbolic link x, d directory i packaging installation script or information file (copyright, depend, postinstall, postremove) SunOS 5.10 19 Nov 2002 packagetoc(4)
All times are GMT -4. The time now is 04:43 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy