Sponsored Content
Operating Systems AIX Creating NIM SPOT using an existing mksysb from cliet Post 302875463 by ibmtech on Tuesday 19th of November 2013 02:42:51 PM
Old 11-19-2013
Ok,
In order to do that you have to run the below on NIM
Code:
smitty nim_mkres --> select option mksysb
                                            Define a Resource

Type or select values in entry fields.
Press Enter AFTER making all desired changes.

                                                        [Entry Fields]
* Resource Name                                      [test-mksysb]
* Resource Type                                       mksysb
* Server of Resource                                 [master]                                         +
* Location of Resource                               [YOUR-LOCATION]                                   /
  NFS Client Security Method                         []                                               +
  NFS Version Access                                 []                                               +
  Comments                                           []

  Source for Replication                             []                                               +
                  -OR-
  System Backup Image Creation Options:
    CREATE system backup image?                       no                                              +
    NIM CLIENT to backup                             []                                               +
    PREVIEW only?                                     no                                              +
    IGNORE space requirements?                        no                                              +
    EXPAND /tmp if needed?                            no                                              +
    Create MAP files?                                 no                                              +
    Backup extended attributes?                       yes                                             +
    Number of BLOCKS to write in a single output     []                                                #
     (leave blank to use system default)
    Use local EXCLUDE file?                           no                                              +
     (specify no to include all files in backup)
                  -OR-
    EXCLUDE_FILES resource                           []                                               +
     (leave blank to include all files in backup)
    Backup encrypted files?                           yes                                             +
    Backup DMAPI filesystem files?                    yes                                             +
  Disable software packing of backup?                 no                                              +
  Use exclude_packing.rootvg file?                    no                                              +

Here Resource name is of your choice, reading your article I used test-mksysb. Server of Resource is "master" (NIM itself), now provide the location of actual mksysb.
This should be done within a minute.

Since you have define the mksysb as a resource, now you can use that to create a spot.
Creating a SPOT from existing mksysb.
Code:
smitty nim_mkres  --> select spot
                                           Define a Resource

Type or select values in entry fields.
Press Enter AFTER making all desired changes.

                                                        [Entry Fields]
* Resource Name                                      [spot-test]
* Resource Type                                       spot
* Server of Resource                                 [master]                                         +
  Source of Install Images                           [test-mksysb]                                      +
* Location of Resource                               [/export/spot]                                    /
  NFS Client Security Method                         []                                               +
  NFS Version Access                                 []                                               +
  Expand file systems if space needed?                yes                                             +
  Comments                                           []

  installp Flags
  PREVIEW only? (install operation will NOT occur)    no                                              +
  COMMIT software updates?                            no                                              +
  SAVE replaced files?                                yes                                             +
  AUTOMATICALLY install requisite software?           yes                                             +
  OVERWRITE same or newer versions?                   no                                              +
  VERIFY install and check file sizes?                no                                              +

Here I have used resource name as 'spot-test' (you can use anything), Server of resource is Master again. Source of install Image (here you select the mksysb you just created as resource- and it should be visible when you hit F4). You can specify a location for that spot.

This will take a few minutes to complete.

Follow the above procedure, and you will have a mksysb and spot.
use smitty nim_bosinst to install it on the client.
This User Gave Thanks to ibmtech For This Post:
 

10 More Discussions You Might Find Interesting

1. AIX

NIM mksysb recovery

I have multiple LPARS on p650 with mix of AIX5.2 and AIX5.1 with different rml level My understanding is creating mksysb nim on NIM server is for new installation of LPARS Then; How do I do mksysb backup on existing lpars for recovery purpose or how do I do all mksysb to a NFS mounted Filesystem... (1 Reply)
Discussion started by: melindaj
1 Replies

2. AIX

NIM client mksysb restore

Can a NIM client mksysb restore be performed via NIM (smitty nim) without the NIM client machine having the NIM server's IP and hostname in its /etc/hosts file? (10 Replies)
Discussion started by: kah00na
10 Replies

3. AIX

how to create a package from mksysb via nim ?

Hello, I need to install "bos.adt.libm 5.3.0.0" on a server (AIX5.3 power 5). How to install it from a nim mksysb of an another partition ? Thank you (3 Replies)
Discussion started by: astjen
3 Replies

4. AIX

AIX 5L nim mksysb command

Hi All, Please excuse the possibly naive question but I'm trying to clone/install a new AIX 5.3 LPAR on a p570 from a mksysb image file using nim. Has anyone done this before and if so, what would the exact command look like? Does it even remotely resemble something like nim -o... (1 Reply)
Discussion started by: combustables
1 Replies

5. AIX

mksysb restoration using NIM

Hi, I just want to ask whether anyone has experience on restoring mksysb backup in NIM. We have taken the mksysb backup and the SPOT has been configured on NIM also. I just want to know the checkpoints before doing this. Is there any checkpoints we need to do? Do we need to unmirrorvg? This... (12 Replies)
Discussion started by: depam
12 Replies

6. AIX

mksysb using NIM

I am implementing mksysb backups using NIM. I am using nimsh as client communication and mksysb backup are working fine, but this requires remote logon to be enabled for root. Any thoughts on how can I implement mksysb backups using NIM without enabling remote logon for "root" ? (1 Reply)
Discussion started by: mk8570
1 Replies

7. AIX

Error with new NIM SPOT

I have added our DR to NIM server and tried to create bosinstall image with smitty nim_bosinst command. But ended up with below error. warning: 0042-229 m_bos_inst: When installing a system using a mksysb as the source for the installation, the level of the SPOT used for the ... (3 Replies)
Discussion started by: newaix
3 Replies

8. AIX

NIM SPOT query

Dear Admins, The SPOT defined in NIM is for aix 5.3 TL 7 . Some of the NIM clients are upgraded to TL 10 . Now the SPOT level is older than the mksysb level. This will cause problem during restoration of any NIM clients. Now i want to upgrade SPOT level to TL 10 and redefine the resources... (3 Replies)
Discussion started by: newaix
3 Replies

9. AIX

Unable to Create spot from mksysb

Hello All, Kindly need help in my problem i.e. I get this error when i create spot from mksysb. #0042-001 nim: processing error encountered on "master": 0042-001 m_mkspot: processing error encountered on "master": 0042-175 c_mkspot: An unexpected result was returned by the... (2 Replies)
Discussion started by: emerann
2 Replies

10. AIX

mksysb, lpp_source and SPOT version matching

Hi all, I'm trying to understand the requirements for AIX version matching between a SPOT, LPP_SOURCE and my mksysb images. I have a NIM server installed, and I've used it to install new LPARs both from the LPP_SOURCE and from mksysb files. These were based off 7100-00-01. Recently I created... (1 Reply)
Discussion started by: SamuraiMark
1 Replies
All times are GMT -4. The time now is 07:17 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy