Sponsored Content
Full Discussion: AIX memory issue
Operating Systems AIX AIX memory issue Post 302635593 by learnbash on Saturday 5th of May 2012 11:53:25 AM
Old 05-05-2012
@bakunin

Please check the below output.

Code:
bash-3.2# oslevel -g
6.1.0.0

bash-3.2# vmo -o
vmo: A flag requires a parameter: o
Usage:  vmo -h [tunable] | {[-F] -L [tunable]} | {[-F] -x [tunable]}
        vmo [-p|-r] (-a [-F] | {-o tunable})
        vmo [-p|-r] [-y] (-D | ({-d tunable} {-o tunable=value}))

bash-3.2# schedo -o
schedo: A flag requires a parameter: o
Usage:  schedo -h [tunable] | {[-F] -L [tunable]} | {[-F] -x [tunable]}
        schedo [-p|-r] (-a [-F] | {-o tunable})
        schedo [-p|-r] [-y] (-D | ({-d tunable} {-o tunable=value}))

bash-3.2# ioo -i
ioo: Not a recognized flag: i
Usage:  ioo -h [tunable] | {[-F] -L [tunable]} | {[-F] -x [tunable]}
        ioo [-p|-r] (-a [-F] | {-o tunable})
        ioo [-p|-r] [-y] (-D | ({-d tunable} {-o tunable=value}))

bash-3.2# vmstat 1

System configuration: lcpu=8 mem=30720MB

kthr    memory              page              faults        cpu    
----- ----------- ------------------------ ------------ -----------
 r  b   avm   fre  re  pi  po  fr   sr  cy  in   sy  cs us sy id wa
13  0 2170427 40491   0   0   0   0    0   0  10 4514 4905  3  1 96  0
 8  0 2170427 40491   0   0   0   0    0   0   3 4355 5100  3  1 96  0
20  0 2170428 40490   0   0   0   0    0   0   4 4573 5072  3  1 96  0
 6  0 2170428 40490   0   0   0   0    0   0   1 4131 4717  3  1 96  0
25  0 2170428 40490   0   0   0   0    0   0  16 3941 4397  2  1 96  0
 7  0 2170428 40490   0   0   0   0    0   0  18 4141 4693  3  1 96  0
27  0 2170428 40490   0   0   0   0    0   0   1 4353 4821  3  1 96  0
30  0 2170428 40490   0   0   0   0    0   0   1 3978 4633  2  1 96  0
 3  0 2170772 40146   0   0   0   0    0   0  45 4338 4965  7  1 91  0
 8  0 2170772 40146   0   0   0   0    0   0   4 3963 4570  3  1 96  0
22  0 2170779 40137   0   0   0   0    0   0   7 74295 4828  8  4 88  0
 2  0 2170780 40136   0   0   0   0    0   0  10 3869 4701  3  1 96  0
 2  0 2171860 39056   0   0   0   0    0   0   5 5076 4807  6  2 92  0


bash-3.2# iostat 5 | grep -v '0.0'

System configuration: lcpu=8 drives=6 paths=5 vdisks=5

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn
hdisk0           0.2       2.4       0.6          0        12

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn
hdisk2           0.2       3.2       0.2          0        16
hdisk3           0.2       3.2       0.2          0        16
hdisk4           0.2       3.2       0.2          0        16

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn
hdisk0           4.8      59.8      13.8          0       300
hdisk2           0.4      28.7       6.0          0       144

tty:      tin         tout    avg-cpu: % user % sys % idle % iowait

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn


bash-3.2# svmon -G
               size       inuse        free         pin     virtual   mmode
memory      7864320     7824082       40238      701299     2170675     Ded
pg space    4718592        8760

               work        pers        clnt       other
pin          461763           0           0      239536
in use      2170675           0     5653407

PageSize   PoolSize       inuse        pgsp         pin     virtual
s    4 KB         -     6673266        8760      323731     1019859
m   64 KB         -       71926           0       23598       71926


bash-3.2# vmstat -v
              7864320 memory pages
              7602176 lruable pages
                46384 free pages
                    1 memory pools
               701202 pinned pages
                 80.0 maxpin percentage
                  3.0 minperm percentage
                 90.0 maxperm percentage
                 73.8 numperm percentage
              5616515 file pages
                  0.0 compressed percentage
                    0 compressed pages
                 73.8 numclient percentage
                 90.0 maxclient percentage
              5616515 client pages
                    0 remote pageouts scheduled
                   66 pending disk I/Os blocked with no pbuf
                    0 paging space I/Os blocked with no psbuf
                 2484 filesystem I/Os blocked with no fsbuf
                  313 client filesystem I/Os blocked with no fsbuf
                10368 external pager filesystem I/Os blocked with no fsbuf
                 28.0 percentage of memory used for computational pages


Last edited by Scrutinizer; 05-05-2012 at 01:00 PM.. Reason: code tags instead of quote tags..
 

10 More Discussions You Might Find Interesting

1. Windows & DOS: Issues & Discussions

Memory Issue

Hi There, I have upgraded the DELL poweredge 2600 server memory from 2GB to 4GB. However, the memory only showed at 2GB of utilization. How to make sure that the server is full utilize of 4GB of memory. Is there the Virtual memory need to be reconfigure as this server is run on windows 2000 and... (2 Replies)
Discussion started by: vestro
2 Replies

2. Linux

Memory issue while diff !!!

Hi All Any idea? why am I having this memory issue? perforce@ixca-pforce-bak:/home/p4-demo-root$ diff checkpoint_offline ../p4-demo-root2/checkpoint.1150 diff: memory exhausted Thanks a lot C Saha (0 Replies)
Discussion started by: csaha
0 Replies

3. AIX

Shared memory issue

Hi friends.. Help to solve this issue... Is there any parameter setting to control or limit the size of the shared memory a process can attach for the below specified environment? The man pages says it can attach upto segments of size 2GB. But when our process (which also connects to... (0 Replies)
Discussion started by: sdspawankumar
0 Replies

4. Solaris

Locked memory issue

One of our project has exceeded its assigned max-memory-locked by 3 times .. The said project is using around 9 gigs as described by rss parameter in prstat -J .. and the max-project-memory parameter has been defined as 3gigs .. is it normal or we are monitoring the project memory usage in wrong... (2 Replies)
Discussion started by: fugitive
2 Replies

5. AIX

Memory consumption issue in AIX box

Hi, monitor memory usage on AIX machine on any day of the week from 3:00 PM ET to 5:00 PM ET - Povide min and max memory consumption. Determine if all of the available memory is visible to the operating system. If it is not, determine the amount of memory which may be allocated to the... (3 Replies)
Discussion started by: Rookie_newbie
3 Replies

6. SuSE

Memory utilization issue

I have parallels container running on Suse. From top command, I am not able to see, what is eating up so big amount of memory. top - 07:44:24 up 172 days, 18:52, 1 user, load average: 0.01, 0.02, 0.00 Tasks: 44 total, 1 running, 43 sleeping, 0 stopped, 0 zombie Cpu(s): 0.0%us, ... (1 Reply)
Discussion started by: solaris_1977
1 Replies

7. AIX

Memory issue

I have a server with 300Gb allocated to it. Some times I observed in topas Comp% 73 and Non comp 35% and client is also 35% and my paging is showing 92%. If my physical memory utilized only 70% then why paging is so high. And what is relation between Comp, noncomp and client? If the memory... (1 Reply)
Discussion started by: powerAIX
1 Replies

8. Red Hat

Memory Issue

I could not find what is consuming the memory, generated DSET reports and NO hardware wise memory issue. 64 GB RAM on a server yet all I could see is a very limited memory available. I am not sure if I am reading this correct or not. I have used free -t -m and cat /proc/meminfo (results below)... (3 Replies)
Discussion started by: rsheikh01
3 Replies

9. Linux

Swap memory issue

Hi, In our production box i can see the Swap space using the below command free total used free shared buffers cached Mem: 65963232 41041084 24922148 0 877160 35936292 -/+ buffers/cache: 4227632 61735600 Swap: 4192880 ... (6 Replies)
Discussion started by: ratheeshjulk
6 Replies

10. Shell Programming and Scripting

Out of memory issue in perl

I am getting a out of memory issue while executing the perl program. Per version : /opt/acc_perl/lib/site_perl/5.14.2 Read in 54973 total records Read in 54973 table records from table. Out of memory! so the job get failed due to out of memory. need to get rid of the out of memory... (3 Replies)
Discussion started by: ramkumar15
3 Replies
All times are GMT -4. The time now is 08:21 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy