Sponsored Content
Operating Systems AIX Adding Storage to a System File. Post 302494803 by Scott on Tuesday 8th of February 2011 12:06:48 PM
Old 02-08-2011
I presume you mean "file system" (your subject line says "system file")?

1. Yes. You need to know which volume groups these logical volumes belong to (looking at the names, I would guess qa2vg).
Code:
lslv sapdata5qa
lslv ... etc for each

Run lsvg <volume group name>. Perhaps the space you need is already available.
Code:
lsvg $(lsvg) | grep -E "VOLUME|FREE"

2. Use chfs to add space to a filesystem
Code:
chfs -a size=+X ...
chfs -a size=X

where +X is to increase by an amount (like +1G, +100M, etc. and =X is to increase it to X (like =1G, 100M, etc.). Read the man page for chfs.

3. Have the disks been added? Did you run cfgmgr, then have a look with lspv. You should change the healthcheck interval to 60 using chdev. Extend the volume group(s) with the new disk(s). Read man extendvg. You may need to run chlv -x to increase the maximum LV's for the logical volumes. If chfs fails because of that, it will tell you what the value should be. Are the logical volumes striped (lslv will show this.)?

4. df -g should be sufficient.
 
mkdevmaps(1M)                                             System Administration Commands                                             mkdevmaps(1M)

NAME
mkdevmaps - make device_maps entries SYNOPSIS
/usr/sbin/mkdevmaps DESCRIPTION
The mkdevmaps command writes to standard out a set of device_maps(4) entries describing the system's frame buffer, audio, and removable media devices. The mkdevmaps command is used by the init.d(4) scripts to create or update the /etc/security/device_maps file. Entries are generated based on the device special files found in /dev. For the different categories of devices, the mkdevmaps command checks for the following files under /dev: audio /dev/audio, /dev/audioctl, /dev/sound/... tape /dev/rst*, /dev/nrst*, /dev/rmt/... floppy /dev/diskette, /dev/fd*, /dev/rdiskette, /dev/rfd* removable disk /dev/dsk/c0t?d0s?, /dev/rdsk/c0t?d0s? frame buffer /dev/fb ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
allocate(1), bsmconv(1M), attributes(5) NOTES
mkdevmaps might not be supported in a future release of the Solaris operating system. SunOS 5.10 8 Oct 2003 mkdevmaps(1M)
All times are GMT -4. The time now is 04:39 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy