Sponsored Content
Homework and Emergencies Emergency UNIX and Linux Support AIX : Create LV with poor man stripe Post 302417557 by zxmaus on Friday 30th of April 2010 03:17:12 AM
Old 04-30-2010
Hi,

why would you even possibly want a non-relocatable VG ? I don't think you can change it ...

Code:
mklv -y'<name_of_lv>' -t'jfs2' -x'<max_pp_in_lv>' rootvg <size_of_lv_in_pp>

where <max_pp_in_lv> is the size you want the lv to maximum grow to and <size_of_lv_in_pp> is the size you want it to be now. You can later extend a filesystem residing in this lv just with chfs up to the size of max without first growing the lv. It would be automatically spread (poor man striped) across all disks CURRENTLY in your volumegroup. If you later add more disks to your vg, than this lv would remain spread across the disks you have now as long as you don't run a reorg command - any newly created lv's would be spread across the new amount of disks.

If you want afterwards to create a filesystem within this created lv than you would do it i.e. like this (I assume an inline log, that you want it auto mounted after a system boot and rbrw mounted in my sample):

Code:
crfs -v jfs2 -d'<name_of_lv>' -m'<mountpoint>' -p'rw' -A yes -a options='rbrw' -a logname='INLINE'

This filesystem would have the size <size_of_lv_in_pp> from the mklv command.

Hope this helps
kind regards
zxmaus
This User Gave Thanks to zxmaus For This Post:
 

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

How to install Man Pages on aix

How can I install the man pages on ibm unix aix 4.3? (1 Reply)
Discussion started by: GKL
1 Replies

2. UNIX for Dummies Questions & Answers

how do you create a man page?

i've never done this before. i created a script that I placed in /usr/bin, but want to create a man page for it. i'm clueless thanks (3 Replies)
Discussion started by: theDirtiest
3 Replies

3. UNIX for Dummies Questions & Answers

MSR magnetic stripe card reader

Hi all I am working on MSR110 ...Can anyone plz tell me how to use the configuration commands with magnetic reader???. Please help me out as i have to develop API in C on linux platform.MSR110 is not responding to the configuration commands. Please help... Regards Mahima (0 Replies)
Discussion started by: mahima_er
0 Replies

4. AIX

man pages in AIX

Hi all. A friend of mine just recently gave me an old RISC 6000 machine to learn on for my AIX certification. I installed AIX 4.3.3 and everything seems to work fine, except there are no man pages. Is there a way to generate man pages on this machine? Thanks alot in advance. (5 Replies)
Discussion started by: dlynch912
5 Replies

5. UNIX for Dummies Questions & Answers

please suggest computer languages to create man-machine interface for Linux applicati

I am new to program development on Linux. I wonder what computer languages are easy to grasp to create man - machine interactive interface software, which can accept inputs (parameters) from usrers, and present (display) the calculation results to users. Before, I have heared about Perl,... (10 Replies)
Discussion started by: cy163
10 Replies

6. UNIX for Advanced & Expert Users

Resizing veritas mirror-stripe volume

Hi, Is there are any special preocedure for extending veritas mirror-stripe volume? In my case , volume lay out looks as below v test - ENABLED ACTIVE 419430400 SELECT - fsgen pl test-01 test ENABLED ACTIVE 419454720 STRIPE 3/128 RW sd... (0 Replies)
Discussion started by: 2k7.vipin
0 Replies

7. Linux

Raid 0 stripe size

I have a PERC 5/i card. Im using with it 3 15k rpm HDD's (model: SEAGATE Savvio 15K ST936751SS). Im going to install debian on this array.. and im looking for performance... So what would be the stripe size that i should set this raid 0 into to give me the best performance? Thanks (22 Replies)
Discussion started by: supermiguel
22 Replies

8. AIX

AIX striped LV - lslv stripe width has wrong value

Hello all. I have a volume group with 8 PV's, and a logical volume striped across these 8 volumes. However, an lslv is showing: STRIPE WIDTH: 9 STRIPE SIZE: 64k There's really only eight disks, so how can the stripe width be 9? ODM also showed this: # odmget CuAt |... (4 Replies)
Discussion started by: Scott
4 Replies

9. AIX

Case insensitive search in AIX man ?

Hello, Linux man command search is case insensitive by default, but not AIX man. How do I serch case insensitive while using AIX manual pages ? thanks Vilius (7 Replies)
Discussion started by: vilius
7 Replies

10. Solaris

solaris volume manager- stripe?

Hello Admins.. I am going through solaris volume manager guide for RAID-0 concatenation and stripes, I do not understand the concept of stripe from following example of concatenation. There is an eample for concatenation: # metainit d25 1 1 c0t1d0s2 d25: Concat/Stripe is setup the... (5 Replies)
Discussion started by: snchaudhari2
5 Replies
USERMOUNT(1)						      General Commands Manual						      USERMOUNT(1)

NAME
usermount - A graphical tool to mount, unmount and format filesystems. SYNOPSIS
usermount [ options ] userformat [ options ] device DESCRIPTION
usermount is a graphical tool to allow users to easily manage removable media, such as floppy disks or zip disks. When the tool starts up, it scans /etc/fstab for all filesystems that have been configured to allow users to mount and unmount them. The filesystem can be mounted or unmounted by pressing the toggle button labeled Mount. Also, if the user has the appropriate permissions for the device, the Format button will be active. This allows the user to format disks using fdformat and create a new filesystem of the type listed (using mkfs with the appropriate option). Naturally, the user will be prompted for confirmation before actually destroying data on the device. Note that if a device is already mounted, the format button is inactive for all entries that share the same device. When run as root, usermount displays all of the entries in /etc/fstab rather than just the ones with the user option. Invoking userformat device allows formatting device, as if by selecting device in the userformat window, and by clicking the Format button. OPTIONS
This program has no command line options of it's own, but it does take the standard X program options like -display and such. See the X(1) man page for some of the common options. FILES
/etc/fstab The system file describing the mountable filesystems. SEE ALSO
mount(8), fdformat(8), mkfs(8), fstab(5) X(1) BUGS
Mount entries with a filesystem type of iso9660 are outright considered CD-ROMs and the format button is always disabled. Mount entries for swap files or partitions are also ignored. A nice feature might be to allow root to turn swap on and off for swap parti- tions. AUTHOR
Otto Hammersmith <otto@redhat.com> Red Hat March 13 2007 USERMOUNT(1)
All times are GMT -4. The time now is 04:04 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy