Sponsored Content
Full Discussion: Sysdump and unmirroring
Operating Systems AIX Sysdump and unmirroring Post 302226441 by Locki on Tuesday 19th of August 2008 04:15:10 AM
Old 08-19-2008
you can do it in few ksh commands. Let's suppose :
  • your sysdumpdev has been created with the right LV type (sysdump)
  • your rootvg is on the two disks hdisk0 and hdisk1
  • you have verified the settings for your sysdump device with the command : sysdumpdev -l, and found something like that :
primary /dev/mysysdumplv
secondary /dev/null
...

otherwise you should issue the following command :
sysdumpdev -P -s /dev/null
  • you verified that your sysdump device was actually on the first disk, the following command :
lslv -m mysysdumplv | sed 1,2d | awk '{ print $3}' | uniq
should return only "hdisk0"
  • you verified that for each lv, each copy was on only one disk (when growing FS, if you just issued uncontrolled "chfs" commands on FS built upon mirrored LV, it may happened that copies are mixed between both disks !)
then you can do the following :

LVS=$( lsvg -l rootvg | sed 1,2d | awk '{ if ($2 != "sysdump") print $1; }' )
for lv in $LVS; do
echo "removing $lv copy from hdisk1" # not to be in front of a desperatly black screen while everything is proceeding
rmlvcopy $lv 1 hdisk1
done
lspv -l hdisk1 # to be sure there's nothing left on it
reducevg rootvg hdisk1
# don't forget to modify the bootlist
bootlist -m normal -o hdisk0
bosboot -ad hdisk0

and it should do it ! you should have a whole drive just to do an alternate disk install of your mksysb with patches.

Last edited by Locki; 08-19-2008 at 05:36 AM..
 

3 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Can I reduce sysdump?

Hi, I have a server which is running out of space on the rootvg. When trying to find some spare space I discovered there are 2 sysdump logical volumes, each of 5GB, yet if I get an estimate of the dump size it's only 0.5 GB. $ lsvg -l rootvg|grep sysdump hd71 sysdump 20 ... (1 Reply)
Discussion started by: m223464
1 Replies

2. AIX

AIX unmirroring while mirroring in background

Hi, by mistake I ran unmirror while mirroring was running in the back ground. anyhow the unmirror operation failed with the following 0516-076 lreducelv: Cannot remove last good copy of stale partition. Resynchronize the partitions with syncvg and try again. 0516-922 rmlvcopy:... (0 Replies)
Discussion started by: ithinksgreen
0 Replies

3. AIX

Sysdump on local disk

Hello Team, Our p740 systems are booting up from SAN. We would like to configure the local disk(which is not part of rootvg) as a primary dump device. I have assigned the same too. But in the errpt throwing the below error. Please help me on this. ... (1 Reply)
Discussion started by: gowthamakanthan
1 Replies
vxdestroy_lvmroot(1M)													     vxdestroy_lvmroot(1M)

NAME
vxdestroy_lvmroot - remove LVM root disk and associated LVM volume group SYNOPSIS
vxdestroy_lvmroot [-v] [-b] lvm_root_disk DESCRIPTION
The vxdestroy_lvmroot command tears down and removes the LVM volume group associated with the specified physical disk. This is done by removing the volumes in the volume group and then removing the volume group. OPTIONS
-b Invokes the setboot command to change the primary boot disk to the VxVM root disk from which the system was booted (if the pri- mary boot disk is not already set to this disk). The alternate boot device remains unchanged. If the -v option is also speci- fied, the settings of the primary and alternate boot devices are displayed. -v Outputs verbose messages including a timestamp that indicates major operations being performed. ARGUMENTS
lvm_root_disk Specifies the device name of the LVM root disk that is to be destroyed, along with its entire volume group. EXAMPLES
This example shows the vxdestroy_lvmroot command invoked in its simpliest form: /etc/vx/bin/vxdestroy_lvmroot c5t1d0 # /etc/vx/bin/vxdestroy_lvmroot -v -b c3t0d0 Are you sure about destroying c3t0d0 (imported on VG /dev/vg02) ? YES vxdestroy_lvmroot 06:02: Tearing down /dev/vg02 on device c3t0d0 vxdestroy_lvmroot 06:02: Unmounting and removing any volumes associated with /dev/vg02 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol1 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol2 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol3 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol4 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol5 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol6 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol7 vxdestroy_lvmroot 06:02: removing logical volume /dev/vg02/lvol8 vxdestroy_lvmroot 06:02: Removing Volume Group /dev/vg02 vxdestroy_lvmroot 06:02: Removing device files in /dev/vg02 vxdestroy_lvmroot 06:02: Removing LVM Physical Volume c3t0d0 vxdestroy_lvmroot 06:02: Removing LVM Physical Volume c1t1d3 vxdestroy_lvmroot 06:02: Removing LVM Physical Volume c1t1d4 vxdestroy_lvmroot 06:02: Removing LVM Physical Volume c1t1d5 vxdestroy_lvmroot 06:03: Current setboot values: vxdestroy_lvmroot 06:03: Primary: 0/0/6/0/0.0.0 vxdestroy_lvmroot 06:03: Alternate: 0/0/1/0/0.1.0 vxdestroy_lvmroot 06:03: Making disk c0t1d0 (0/0/1/0/0.1.0) the primary boot disk vxdestroy_lvmroot 06:03: Removal of device c3t0d0, volume group /dev/vg02 was successful SEE ALSO
cpio(1), dd(1), fsck(1M), setboot(1M) vxbootsetup(1M) vxcp_lvmroot(1M) vxres_lvmroot(1M) VxVM 5.0.31.1 24 Mar 2008 vxdestroy_lvmroot(1M)
All times are GMT -4. The time now is 09:56 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy