Sponsored Content
Full Discussion: Resource Manager in AIX
Operating Systems AIX Resource Manager in AIX Post 302210271 by bakunin on Monday 30th of June 2008 01:56:28 PM
Old 06-30-2008
I am not sure what you mean by "resource manager". In case you mean the "systems resource controller", "SRC": It is a facility to start/stop/restart system processes, which are usually called "daemons". For instance, the inetd is such a daemon/system resource, the lpd is one, etc.

AIX calls the services these daemons provide "subsystems" and puts them together in groups. Issue "lssrc -a" to list all the available subsystems, the group they belong to and their status.

Use "stopsrc" to stop such a system and "startsrc" to start one. There is also "refresh" which will restart a subsystem (usually in case one changed its configuration), but not all susbsystems can do a refresh - in this case you will have to "stopsrc" it, than "startsrc" it again.

A single subsystem can be started/stopped/refreshed with the parameter "-s":

Code:
startsrc -s sshd

will start the sshd, the secure shell daemon. You can also use the group relationship to start/stop/refresh a whole group of subsystems together with the "-g" parameter:

Code:
stopsrc -g nfs

will stop all the subsystems belonging to the "nfs" group and would be the same as issuing

Code:
stopsrc -s rpc.statd
stopsrc -s rpc.lockd
stopsrc -s biod

You can find the SRC itself running as a process by searching for "srcmstr" in the process list:

Code:
# ps -fe | grep src
    root  204928       1   0   Jan 07      -  0:00 /usr/sbin/srcmstr

You might want to get further information about the system resource controller here.

I hope this helps.

bakunin
 

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

resource manaement

Hi all I would like to know which other tools i can use besides top & sar to track the system resources i heard of somthing that sounds like acamdmin or acsadm... Thanks for your help (1 Reply)
Discussion started by: yelalouf
1 Replies

2. Linux

Resource management

Hi all, we have a big problem, we are running an IA-64 linux system, with 8 CPUs and some GB of RAM, for user usage. The user are compiling and testing programs on this system, and this caused some problems. Sometimes, a user program used the hole memory, blocks the other users, and also... (1 Reply)
Discussion started by: malcom
1 Replies

3. Solaris

resource worries

When I run the prstat -a command I get the following output for user oracle. NPROC USERNAME SIZE RSS MEMORY TIME CPU 118 oracle 70G 30G 100% 4:38:03 52% The reading under the "MEMORY" heading is 100%. What does this mean? I hope it doesn't mean user oracle is using... (2 Replies)
Discussion started by: soliberus
2 Replies

4. AIX

AIX and HP Network Node Manager

We are using hp's network node manager and would like to monitor quite a few of our aix boxes. It appears that nnm does not have AIX mibs by default. Does anyone know where i can find mibs for aix to load into nnm? Thanks (0 Replies)
Discussion started by: zuessh
0 Replies

5. AIX

Aix terminal download manager

Is there such thing like wget? Because I have telnet (no ssh) on a AIX machine, but I can't transfer a rpm file which I'd like to install. How can I do that? How can I transfer a file on the machine? (11 Replies)
Discussion started by: aixn00b
11 Replies

6. Solaris

RAID manager or veritas volume manager

Can somebody kindly help me to determine which one i should choose to better manipulate OS volume. RAID manager or veritas volume manager? Any critical differences between those two? Thanks in advance. (5 Replies)
Discussion started by: beginningDBA
5 Replies

7. Solaris

need some help in resource pool creation

i have server carry more than 50 zone i want to create 2 resource pool assign 40 zone to resource pool number 1 assign 10 zone to resource pool number 2 how can i do that (1 Reply)
Discussion started by: coxmanchester
1 Replies

8. AIX

Monitoring AIX with System Center Operation Manager 2007 R2

I can get my AIX servers to show up in SCOM but I'm struggling with running personal scripts and have the result of these scripts show up in SCOM. I'm currently using BigBrother and I've written some scripts for BB. I would like to convert these scripts to something that can be used in SCOM. ... (0 Replies)
Discussion started by: petervg
0 Replies

9. Solaris

Resource Capping Help!

Hi guys. Quick question for some hopefully ;-) When using resource capping (for CPU in this case). If a container is restricted to use a single CPU/core, are the other containers intelligent enough to know that they have fewer CPU's available to them? My question relates to a T2000 which... (7 Replies)
Discussion started by: boneyard
7 Replies

10. AIX

Regarding AIX volume manager & replacing a disk

First a little background: I'm working with an AIX 6.1 TL05 running two mirrored SAS disks (rootvg) and four SSDs (appvg) All four SSDs belong to appvg and are setup to mirror as follows: hdisk4 --> hdisk6 (containing application fs) hdisk5 --> hdisk7 (containing database fs) A few days... (1 Reply)
Discussion started by: Michael Mullig
1 Replies
captoinfo(1)						      General Commands Manual						      captoinfo(1)

NAME
captoinfo - convert a termcap description into a terminfo description SYNOPSIS
captoinfo [-vn width] [-V] [-1] [-w width] file . . . DESCRIPTION
captoinfo looks in file for termcap descriptions. For each one found, an equivalent terminfo description is written to standard output. Termcap tc capabilities are translated directly to terminfo use capabilities. If no file is given, then the environment variable TERMCAP is used for the filename or entry. If TERMCAP is a full pathname to a file, only the terminal whose name is specified in the environment variable TERM is extracted from that file. If the environment variable TERM- CAP is not set, then the file /usr/share/terminfo is read. -v print out tracing information on standard error as the program runs. -V print out the version of the program in use on standard error and exit. -1 cause the fields to print out one to a line. Otherwise, the fields will be printed several to a line to a maximum width of 60 charac- ters. -w change the output to width characters. FILES
/usr/share/terminfo Compiled terminal description database. TRANSLATIONS FROM NONSTANDARD CAPABILITIES
Some obsolete nonstandard capabilities will automatically be translated into standard (SVr4/XSI Curses) terminfo capabilities by captoinfo. Whenever one of these automatic translations is done, the program will issue an notification to stderr, inviting the user to check that it has not mistakenly translated a completely unknown and random capability and/or syntax error. XENIX termcap also used to have a set of extension capabilities for forms drawing, designed to take advantage of the IBM PC high-half graphics. They were as follows: If the single-line capabilities occur in an entry, they will automatically be composed into an acsc string. The double-line capabilities and GG are discarded with a warning message. IBM's AIX has a terminfo facility descended from SVr1 terminfo but incompatible with the SVr4 format. The following AIX extensions are automatically translated: Additionally, the AIX box1 capability will be automatically translated to an acsc string. Hewlett-Packard's terminfo library supports two nonstandard terminfo capabilities meml (memory lock) and memu (memory unlock). These will be discarded with a warning message. NOTES
This utility is actually a link to tic(1), running in -I mode. You can use other tic options such as -f and -x. The trace option is not identical to SVr4's. Under SVr4, instead of following the -v with a trace level n, you repeat it n times. SEE ALSO
infocmp(1), ncurses(3NCURSES), terminfo(5) This describes ncurses version 5.7 (patch 20100109). AUTHOR
Eric S. Raymond <esr@snark.thyrsus.com> captoinfo(1)
All times are GMT -4. The time now is 05:01 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy