Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

bp_copyout(9f) [opensolaris man page]

bp_copyout(9F)						   Kernel Functions for Drivers 					    bp_copyout(9F)

NAME
bp_copyout - copy from a driver buffer into a buf(9S) SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> int bp_copyout(void *driverbuf, struct buf *bp, offset_t offset, size_t size); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure to copy to. driverbuf Driver buffer to copy from. offset Offset into bp where to start copying. size Size of copy. DESCRIPTION
The bp_copyout() function copies size bytes starting from the driver buffer driverbuf to offset bytes into the memory associated with bp. The offset only applies to bp. RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages. CONTEXT
The bp_copyout() function can be called from user or kernel context only. SEE ALSO
bp_copyin(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S) SunOS 5.11 16 Oct 2007 bp_copyout(9F)

Check Out this Related Man Page

bp_mapin(9F)						   Kernel Functions for Drivers 					      bp_mapin(9F)

NAME
bp_mapin - allocate virtual address space SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> void bp_mapin(struct buf *bp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
bp Pointer to the buffer header structure. DESCRIPTION
bp_mapin() is used to map virtual address space to a page list maintained by the buffer header during a paged- I/O request. bp_mapin() allocates system virtual address space, maps that space to the page list, and returns the starting address of the space in the bp->b_un.b_addr field of the buf(9S) structure. Virtual address space is then deallocated using the bp_mapout(9F) function. If a null page list is encountered, bp_mapin() returns without allocating space and no mapping is performed. CONTEXT
bp_mapin() can be called from user and kernel contexts. SEE ALSO
bp_mapout(9F), buf(9S) Writing Device Drivers SunOS 5.11 13 Sep 1992 bp_mapin(9F)
Man Page

2 More Discussions You Might Find Interesting

1. AIX

Can not copy file not enough space on LV

Hello, Please can someone help. I have created a lv called lv00 in datavg it has 8 PP's in use and each PP is 256MB I have 537 Free PP's Every time I copy my mksysb file to this new lv it gives me an error: 0653-447 Requested a write of ..... but wrote only ... errpt tells me... (2 Replies)
Discussion started by: pobman
2 Replies

2. Solaris

More > 1 TB single file cant copy

good evening, hi, I have problem for copy file, size more > 1 TB, just only for single file. error said, capacity not enough, even my storage I set to 4 TB, file always reject during finish copy. but, if I copy with multiple file/separate file, total calculation file is 2 TB, always success.... (10 Replies)
Discussion started by: katumping
10 Replies