Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kstat_intr(9s) [opensolaris man page]

kstat_intr(9S)						    Data Structures for Drivers 					    kstat_intr(9S)

NAME
kstat_intr - structure for interrupt kstats SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
Interrupt statistics are kept in the kstat_intr structure. When kstat_create(9F) creates an interrupt kstat, the ks_data field is a pointer to one of these structures. The macro KSTAT_INTR_PTR() is provided to retrieve this field. It looks like this: #define KSTAT_INTR_PTR(kptr) ((kstat_intr_t *)(kptr)->ks_data) An interrupt is a hard interrupt (sourced from the hardware device itself), a soft interrupt (induced by the system through the use of some system interrupt source), a watchdog interrupt (induced by a periodic timer call), spurious (an interrupt entry point was entered but there was no interrupt to service), or multiple service (an interrupt was detected and serviced just prior to returning from any of the other types). Drivers generally report only claimed hard interrupts and soft interrupts from their handlers, but measurement of the spurious class of interrupts is useful for auto-vectored devices in order to pinpoint any interrupt latency problems in a particular system configuration. Devices that have more than one interrupt of the same type should use multiple structures. STRUCTURE MEMBERS
ulong_t intrs[KSTAT_NUM_INTRS]; /* interrupt counters */ The only member exposed to drivers is the intrs member. This field is an array of counters. The driver must use the appropriate counter in the array based on the type of interrupt condition. The following indexes are supported: KSTAT_INTR_HARD Hard interrupt KSTAT_INTR_SOFT Soft interrupt KSTAT_INTR_WATCHDOG Watchdog interrupt KSTAT_INTR_SPURIOUS Spurious interrupt KSTAT_INTR_MULTSVC Multiple service interrupt SEE ALSO
kstat(9S) Writing Device Drivers SunOS 5.11 4 Apr 1994 kstat_intr(9S)

Check Out this Related Man Page

ddi_intr_get_hilevel_pri(9F)				   Kernel Functions for Drivers 			      ddi_intr_get_hilevel_pri(9F)

NAME
ddi_intr_get_hilevel_pri - get minimum priority level for a high-level interrupt SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_get_hilevel_pri(void); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
Upon a successful return, the ddi_intr_get_hilevel_pri() function returns the minimum priority level for a high-level interrupt. The return priority value can be used to compare to other priority values, such as those returned from ddi_intr_get_pri(9F), to determine if a given interrupt priority is a high-level interrupt. High-level interrupts must be handled without using system services that manipulate thread or process states, because such interrupts are not blocked by the scheduler. In addition, high-level interrupt handlers must take care to do a minimum of work because they cannot be preempted. A typical high-level interrupt handler puts data into a circular buffer and schedule a soft interrupt by calling ddi_intr_trigger_soft- int(). The circular buffer can be protected by using a mutex that is properly initialized for the interrupt handler. The ddi_intr_get_hilevel_pri() function can be used before calling ddi_intr_add_handler() to help determine which type of interrupt handler can be used. Most device drivers are designed with the knowledge that supported devices always generate low level interrupts. On some machines, however, interrupts are high-level above the scheduler level and on other machines they are not. Devices such as those those using SBus interrupts or VME bus level 6 or 7 interrupts must use the ddi_intr_get_hilevel_pri() function to test the type of interrupt handler that can be used. RETURN VALUES
The ddi_intr_get_hilevel_pri() function returns the priority value for a high-level interrupt. CONTEXT
The ddi_intr_get_hilevel_pri() function can be called from either user or kernel non-interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ddi_intr_add_handler(9F), ddi_intr_alloc(9F), ddi_intr_enable(9F), ddi_intr_get_pri(9F), ddi_intr_trigger_softint(9F), mutex(9F) Writing Device Drivers SunOS 5.11 07 Apr 2005 ddi_intr_get_hilevel_pri(9F)
Man Page