Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kstat(9s) [opensolaris man page]

kstat(9S)						    Data Structures for Drivers 						 kstat(9S)

NAME
kstat - kernel statistics structure SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
Each kernel statistic (kstat) exported by device drivers consists of a header section and a data section. The kstat structure is the header portion of the statistic. A driver receives a pointer to a kstat structure from a successful call to kstat_create(9F). Drivers should never allocate a kstat struc- ture in any other manner. After allocation, the driver should perform any further initialization needed before calling kstat_install(9F) to actually export the kstat. STRUCTURE MEMBERS
void *ks_data; /* kstat type-specif. data */ ulong_t ks_ndata; /* # of type-specif. data records */ ulong_t ks_data_size; /* total size of kstat data section */ int (*ks_update)(struct kstat *, int); void *ks_private; /* arbitrary provider-private data */ void *ks_lock; /* protects kstat's data */ The members of the kstat structure available to examine or set by a driver are as follows: ks_data Points to the data portion of the kstat. Either allocated by kstat_create(9F) for the drivers use, or by the driver if it is using virtual kstats. ks_ndata The number of data records in this kstat. Set by the ks_update(9E) routine. ks_data_size The amount of data pointed to by ks_data. Set by the ks_update(9E) routine. ks_update Pointer to a routine that dynamically updates kstat. This is useful for drivers where the underlying device keeps cheap hardware statistics, but where extraction is expensive. Instead of constantly keeping the kstat data section up to date, the driver can supply a ks_update(9E) function that updates the kstat data section on demand. To take advantage of this feature, set the ks_update field before calling kstat_install(9F). ks_private Is a private field for the driver's use. Often used in ks_update(9E). ks_lock Is a pointer to a mutex that protects this kstat. kstat data sections are optionally protected by the per-kstat ks_lock. If ks_lock is non-NULL, kstat clients (such as /dev/kstat) will acquire this lock for all of their operations on that kstat. It is up to the kstat provider to decide whether guaranteeing consistent data to kstat clients is sufficiently important to justify the locking cost. Note, however, that most statistic updates already occur under one of the provider's mutexes. If the provider sets ks_lock to point to that mutex, then kstat data locking is free. ks_lock is really of type (kmutex_t*) and is declared as (void*) in the kstat header. That way, users do not have to be exposed to all of the kernel's lock-related data structures. SEE ALSO
kstat_create(9F) Writing Device Drivers SunOS 5.11 4 Apr 1994 kstat(9S)

Check Out this Related Man Page

kstat_create(9F)					   Kernel Functions for Drivers 					  kstat_create(9F)

NAME
kstat_create - create and initialize a new kstat SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> kstat_t *kstat_create(char *module, int instance, char *name, char *class, uchar_t type, ulong_t ndata, uchar_t ks_flag); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
module The name of the provider's module (such as "sd", "esp", ...). The "core" kernel uses the name "unix". instance The provider's instance number, as from ddi_get_instance(9F). Modules which do not have a meaningful instance number should use 0. name A pointer to a string that uniquely identifies this structure. Only KSTAT_STRLEN - 1 characters are significant. class The general class that this kstat belongs to. The following classes are currently in use: disk, tape, net, controller, vm, kvm, hat, streams, kstat, and misc. type The type of kstat to allocate. Valid types are: "small and bold">KSTAT_TYPE_NAMED Allows more than one data record per kstat. KSTAT_TYPE_INTR Interrupt; only one data record per kstat. KSTAT_TYPE_IO I/O; only one data record per kstat ndata The number of type-specific data records to allocate. flag A bit-field of various flags for this kstat. flag is some combination of: KSTAT_FLAG_VIRTUAL Tells kstat_create() not to allocate memory for the kstat data section; instead, the driver will set the ks_data field to point to the data it wishes to export. This provides a convenient way to export existing data structures. KSTAT_FLAG_WRITABLE Makes the kstat data section writable by root. KSTAT_FLAG_PERSISTENT Indicates that this kstat is to be persistent over time. For persistent kstats, kstat_delete(9F) simply marks the kstat as dormant; a subsequent kstat_create() reactivates the kstat. This feature is provided so that statistics are not lost across driver close/open (such as raw disk I/O on a disk with no mounted partitions.) Note: Persistent kstats cannot be virtual, since ks_data points to garbage as soon as the driver goes away. DESCRIPTION
kstat_create() is used in conjunction with kstat_install(9F) to allocate and initialize a kstat(9S) structure. The method is generally as follows: kstat_create() allocates and performs necessary system initialization of a kstat(9S) structure. kstat_create() allocates memory for the entire kstat (header plus data), initializes all header fields, initializes the data section to all zeroes, assigns a unique kstat ID (KID), and puts the kstat onto the system's kstat chain. The returned kstat is marked invalid because the provider (caller) has not yet had a chance to initialize the data section. After a successful call to kstat_create() the driver must perform any necessary initialization of the data section (such as setting the name fields in a kstat of type KSTAT_TYPE_NAMED). Virtual kstats must have the ks_data field set at this time. The provider may also set the ks_update, ks_private, and ks_lock fields if necessary. Once the kstat is completely initialized, kstat_install(9F) is used to make the kstat accessible to the outside world. RETURN VALUES
If successful, kstat_create() returns a pointer to the allocated kstat. NULL is returned upon failure. CONTEXT
kstat_create() can be called from user or kernel context. EXAMPLES
Example 1: Allocating and Initializing a kstat Structure pkstat_t *ksp; ksp = kstat_create(module, instance, name, class, type, ndata, flags); if (ksp) { /* ... provider initialization, if necessary */ kstat_install(ksp); } SEE ALSO
kstat(3KSTAT), ddi_get_instance(9F), kstat_delete(9F), kstat_install(9F), kstat_named_init(9F), kstat(9S), kstat_named(9S) Writing Device Drivers SunOS 5.10 10 Sep 1994 kstat_create(9F)
Man Page