Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_phylookup(9f) [opensolaris man page]

net_phylookup(9F)					   Kernel Functions for Drivers 					 net_phylookup(9F)

NAME
net_phylookup - determine if a network interface name exists for a network protocol SYNOPSIS
#include <sys/neti.h> phy_if_t net_phylookup(const net_data_t net, const char *name); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). name name of the network interface to find. DESCRIPTION
The net_phylookup() function attempts to resolve the interface name passed in with the network protocol. When called successfully, the value returned represents a network interface that exists, at the time of the call, within the scope of the network interface. This value is only guaranteed to be unique for a name within the scope of the network protocol. RETURN VALUES
The net_phylookup() function returns -1 if it is not supported by the network protocol, and 0 if the named network interface does not exist (or is otherwise unknown). Otherwise, it returns a value greater than 0 representing a network interface that currently exists within the scope of this network protocol. CONTEXT
The net_phylookup() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_getifname(9F), net_phygetnext(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_phylookup(9F)

Check Out this Related Man Page

net_phygetnext(9F)					   Kernel Functions for Drivers 					net_phygetnext(9F)

NAME
net_phygetnext - search through the current list of network interfaces SYNOPSIS
#include <sys/neti.h> phy_if_t net_phygetnext(const net_data_t net, const phy_if_t ifp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to this function or net_phylookup(9F). DESCRIPTION
The net_phygetnext() function searches through all of the network interfaces that a network protocol "owns". To start searching through all of the interfaces owned by a protocol, a value of 0 should be passed through as the value of ifp. When 0 is returned by this function, the last of the interfaces owned by this protocol has been reached. When called successfully, the value returned represents a network interface that exists, at the time of the call, within the scope of the network interface. This value is only guaranteed to be unique for a name within the scope of the network protocol. EXAMPLES
net_data_t net; phy_if_t ifp; char buffer[32]; net = net_protocol_lookup("inet"); if (net != NULL) { for (ifp = net_phygetnext(net, 0); ifp != 0; ifp = net_phygetnext(net, ifp)) { /* Do something with ifp */ if (net_getifname(net, ifp, buffer, sizeof(buffer) >= 0) printf("Interface %s0, buffer); } } RETURN VALUES
The net_phygetnext() function returns -1 if it is not supported by the network protocol or 0 if an attempt to go beyond the last network interface is made. Otherwise, it returns a value representing a network interface. CONTEXT
The net_phygetnext() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phylookup(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_phygetnext(9F)
Man Page