Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

prof(5) [opensolaris man page]

prof(5) 						Standards, Environments, and Macros						   prof(5)

NAME
prof - profile within a function SYNOPSIS
#define MARK #include <prof.h> void MARK(name); DESCRIPTION
MARK introduces a mark called name that is treated the same as a function entry point. Execution of the mark adds to a counter for that mark, and program-counter time spent is accounted to the immediately preceding mark or to the function if there are no preceding marks within the active function. name may be any combination of letters, numbers, or underscores. Each name in a single compilation must be unique, but may be the same as any ordinary program symbol. For marks to be effective, the symbol MARK must be defined before the header prof.h is included, either by a preprocessor directive as in the synopsis, or by a command line argument: cc -p -DMARK work.c If MARK is not defined, the MARK(name) statements may be left in the source files containing them and are ignored. prof -g must be used to get information on all labels. EXAMPLES
In this example, marks can be used to determine how much time is spent in each loop. Unless this example is compiled with MARK defined on the command line, the marks are ignored. #include <prof.h> work( ) { int i, j; . . . MARK(loop1); for (i = 0; i < 2000; i++) { . . . } MARK(loop2); for (j = 0; j < 2000; j++) { . . . } } SEE ALSO
profil(2), monitor(3C) SunOS 5.11 3 Jul 1990 prof(5)
Man Page

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

How To Sort Array of Hashes ??

Some one plz help me how to sort an array of hashes ..... for e.g i have an array as @AoH = ( { ques => 10, marks => 32, }, { ques => 32, marks => 22, }, { ques => 2, marks => 41, }, ); now i want to sort this array with increasing value of "ques" ..... plz... (3 Replies)
Discussion started by: coolguyshail
3 Replies

2. Programming

Gettting statistics/profile of c program in linux

HI, In unix we can get profile on a c program like this :: cc -g -p -o cpp_sw_gsmconverter_shailesh5 cpp_sw_gsmconverter_shailesh5.c prof cpp_sw_gsmconverter_shailesh5 In the same manner how can I collect statistics in linux using gcc command. Thanks in advance. (1 Reply)
Discussion started by: chprvkmr
1 Replies

3. Programming

How to the prof/gprof tool

Hello everyone I want to use the standard Unix prof/gprof tool for my application but I cannot get through the compilation part. I have add the -xpg option in my makefile as specified in the cc man page but the linker gives me the following error: ***************************************... (3 Replies)
Discussion started by: amatsaka
3 Replies

4. UNIX for Dummies Questions & Answers

how to share printer installed on windows 2000 with SCO OpenServer 5.0.5

i have wipro netpower server with p4 and 256 ram. i want share dot matrix printer installed on windows 2000 prof. with sco openserver 5.0.5. plz help me to comeout from this trouble. (0 Replies)
Discussion started by: raj_shivage
0 Replies

5. Shell Programming and Scripting

Add text before lines in command output

Hi2all, I have following command in IBM HMC console: lssyscfg -r prof -m Server-9117-MMA-SN655D350 -F lpar_name,min_mem,desired_mem --header which gives me the following output: lpar_name,min_mem,desired_mem lpar1,1024,2048 lpar2,1024,2048 lpar3,2048,4096 What I want is to add in... (3 Replies)
Discussion started by: UsRb
3 Replies

6. SCO

new york best restaurants

(0 Replies)
Discussion started by: Markbenson
0 Replies

7. Shell Programming and Scripting

sed: how to replace regex with a ' (quote) mark

I've got a text file which has " marks where it there should be ' marks. I tried to do it with sed, but it won't allow me to escape the ' mark. Here's what I tried to do: sed 's/"/\\'/g' file.txt How can this be done? Thanks (3 Replies)
Discussion started by: CraigMoore
3 Replies

8. Homework & Coursework Questions

Can anybody help me with coursework

This is the coursework, in Technical University Sofia, Bulgaria prof. Koshmarov, sorry but the link to the course is broken. And this is the condition: 1. If the value of x is 5, and you have been set a new value as such x="expr $x + 10", What would be the value of x? What... (1 Reply)
Discussion started by: astralito
1 Replies

9. Homework & Coursework Questions

Unix commands Help

I am struggling with one of my assignment questions, not sure how to go about coding it question is 2. The fille ~eliwp/marks is a colon separated list of students and their marks. Write a script to process this file printing out the id's of the students that have failed the module.... (2 Replies)
Discussion started by: tina_2010
2 Replies

10. Post Here to Contact Site Administrators and Moderators

Homework rules !

Why do you ask about prof info at homeworks forum..... do you contact to prof and tell him that this student asked for our help? I asked that because some of them are very strickt and conseder that as cheating (4 Replies)
Discussion started by: fwrlfo
4 Replies