Visit The New, Modern Unix Linux Community


install C compiler without make


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers install C compiler without make
# 1  
install C compiler without make

Hi all,

I dont have much knowledge about linux, but want to learn.

I have installed Plop linux(PLoP - Home) on USB Flashdrive. I want to install gcc compiler to it. The installation of C compiler ask for make command, which is not found in the distribution. When I tried to install gnu make, it give the message that no C compiler found.
So how to install any one of them without having the other?

Please help me
Thanks in advance
# 2  
Quote from the PLoP homepage
Quote:
PLoP Linux is not for beginners. Use it at your own risk.
I assume you tried to install both make and gcc from source. Since both are coded in C, they will require an already installed C compiler. Since a rescue disk probably has no package management (which isn't really required as you seldom need to make changes) you're pretty much out of luck here. Your only option would be to unpack the distribution, compile gcc linked against the libraries there, and pack it again.
If you're new to Linux, I'd suggest starting with [Ku,Xu,U]buntu or Mint, or, if you don't want to install anything, Knoppix, since it will let you create a file on a existing drive to use for user data.
# 3  
"Your only option would be to unpack the distribution, compile gcc linked against the libraries there, and pack it again."

Is it like compiling the gcc on a different linux system with C compiler available, and then copy the object files to Plop linux?

Please explain this to me in little more detail.

Thanks a lot for your reply
# 4  
Not quite. You'd have to unpack the distribution, compile gcc while making sure that the linker doesn't search in it's default location(s) (usually /usr/lib), but in those of the distribution, while at the same time making sure that the paths for said libraries do not derivate from the running distribution. Also, it's advisable to compile gcc on a system running the same Kernel version as the distribution and is not optimized for an other architecture.
More information can be found on the Linux from Scratch homepage [0][1][2]

Besides, why do you want to use PLoP? As stated on the homepage, it's not really intended for new users but as a rescue disk. Other Live distributions are much more user-friendly, and most even come with a complete development chain.

[0] 5.5.*GCC-4.3.2 - Pass 1
[1] 5.12.*GCC-4.3.2 - Pass 2
[2] 6.14.*GCC-4.3.2

Edit: Quick question: did you even look at the homepage for PLoP? There's a whole entry on adding new software
# 5  
Thanks for all the info you have given, especially Linux from Scratch.

I found that Plop linux is very small and also support NTFS( read only). But I wanted to add NTFS-3g driver to it adding write support, for which I needed C compiler. No special reason for choosing Plop.

Anyway, now as per your intructions, will try out the things.

Once again, Thanks a lot
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #789
Difficulty: Medium
Steve Wozniak was employed at Sun Microsystems before he founded Apple Computers.
True or False?

10 More Discussions You Might Find Interesting

1. Fedora

Make check install and make all install

hi dear i want to know what is different between make check install and make all install? thanks in advane fereshte (3 Replies)
Discussion started by: komijani
3 Replies

2. OS X (Apple)

How should I install 'make' compiler ?

I need too install GDB in order to debug a program. I need to install GDB through the UNIX command 'make install'. I downloaded a full directory of hundreds of files allowing to get a gdb executable but need a compilation before ... The problem is UNIX can't find 'make' command. I work under... (5 Replies)
Discussion started by: shub22
5 Replies

3. Red Hat

Install cobol compiler

Hi I dont have a cobol compiler in my redhhat linux box, and so I want to install it. When i try the below command sudo apt-get install open-cobol it tells "apt-get : command not found". I tried to find apt-get under my root, could not find it anywhere. Should we install apt-get also?... (4 Replies)
Discussion started by: unx_freak
4 Replies

4. UNIX for Dummies Questions & Answers

Difference between configure/make/make install.

Hi, While installation of apache on linux, we perform the below tasks. 1) Untar 2) configure 3) make 4) make install. I wanted to understand the difference and working of configure/make/make install. Can any one help me understanding this? Thanks in advance. (1 Reply)
Discussion started by: praveen_b744
1 Replies

5. AIX

install two different compiler version

Hi all. I have a simple question. There's a way to install under AIX system (5.3) two different compiler version, i.e. ibm xlf fortran 11 and 12? Seems that smitty doesn't allows user to change the default installation path; it only allows you to save the replaced files of the superseded... (1 Reply)
Discussion started by: poldo000
1 Replies

6. Solaris

Gani Network Driver Won't Install - make: Fatal error: Don't know how to make targ...

I attached a README file that I will refer to. I successfully completed everything in the README file until step 4. # pwd /gani/gani-2.4.4 # ls COPYING Makefile.macros gem.c Makefile Makefile.sparc_gcc gem.h Makefile.amd64_gcc ... (1 Reply)
Discussion started by: Bradj47
1 Replies

7. Solaris

C compiler and make command

Hey Guys.... I installed Solaris 10 (10/08) on _X86 platform, I need install any software of load balance. I find the pen-0.18.0-sol10-x86-local software. I cant finish the install process , i dont find the make command, I think this command is associated to the C compiler process. But... (2 Replies)
Discussion started by: aggadtech08
2 Replies

8. Linux

Error in issuing a make and make install

Hi, Recently I install a package and try to do a make and make install. However, in the make it gives me below error:- make:Nothing to be done for 'install-exec-am' make:Nothing to be done for 'install-data-am' Can anyone please explain to me what does this mean? I have been trying... (1 Reply)
Discussion started by: ahjiefreak
1 Replies

9. Solaris

Can`t install gcc compiler

Hi, Installed the gcc compiler off the Solaris 9 Companion CD a while back , but needed to delete it due to disk space issues. Now that I have sorted out our root disk space I can`t reinstall the compiler. If I select all the packages off the Development/Languages menu , the install list... (3 Replies)
Discussion started by: markdr011
3 Replies

10. HP-UX

acc compiler install question

Hello, New to the board. Experienced solaris admin, unexperienced HP admin. I'm trying to install the acc compiler package B3913DB off of the HP-UX 11.0 application software CD. I have the cd mounted on another system, and nfs mounted as /mnt on the HP-UX box. I don't have a whole lot... (3 Replies)
Discussion started by: tb0ne
3 Replies

Featured Tech Videos