Visit Our UNIX and Linux User Community


So, like, I signed on with a new hosting company...


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers So, like, I signed on with a new hosting company...
# 1  
Old 07-29-2007
So, like, I signed on with a new hosting company...

... and there was absolutely nothing installed except fedora and ssh. I used yum to install vsftp and httpd, both start and ps shows they're running, and yet I can't connect with either of them. Where on earth or in redhat do I begin looking to unravel this one? I've overseen a server before but they were always set up and working as a web server when I began. This is a value package so I don't expect much support from the host company - tho what they did for their set up fee I'm not sure. Anyway, I'm semi-competant but by no means an expert, so all guidance is welcome here.

I set up one user and can connect as root and as that user using ssh, and transfer files using the ssh file transfer interface (I assume scp will work too).

While I'm here, how does one go about changing the name of a server? I mean, when I log in, the prompt is user@ip address> Can that be changed or altered to have the name instead of the ip?

Oh, is it better to install httpd first and then things like perl and php, or the other way around, or does it matter?

Thanks for your insights.
# 2  
Old 07-29-2007
Perhaps checking your SELINUX or asking them about ports and such?

Do you have a full un-restricted through put on the correct IP?

and as for changing the hostname

"hostname [new-host-name]"

on the command line should fix that Smilie

by the way, what is the hosting company your with? (PM me if you want to avoid slander!)


also if you

"YUM INSTALL php5" then it will install PHP aswell as all the dependencies (such as HTTPD and other such too Smilie

("YUM INSTALL php-mysql" for the PHP-Mysql Connectors Smilie

thanks

Last edited by boarderstu; 07-29-2007 at 08:25 AM..
# 3  
Old 07-29-2007
> Do you have a full un-restricted through put on the correct IP?

supposed to.


> Perhaps checking your SELINUX or asking them about ports and such?

I don't know selinux. If I can't sort this out I'll have to ask about ports.



> "hostname [new-host-name]"

Thanks.


> what is the hosting company your with?

pm sent.


> "YUM INSTALL php5"

'nothing to do' - I guess it installed with httpd

> "YUM INSTALL php-mysql"

done. It even installed the perl-dbi.



Thanks for the input but aside from the note about selinux I still can't get through.



[ edit ]

yum reports libselinux.i386 is installed... but it is disabled in the config file and is not running.

Last edited by Bobby; 07-29-2007 at 10:46 AM.. Reason: updated selinux info
# 4  
Old 07-29-2007
After exhausting every avenue I could think of I contacted tech support and it was indeed a problem with the ports. Fixed now. Thanks boarderstu for the feedback. You've alerted me to things I never knew about and given me plenty to look into.
 

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Changing hosting company for one domain, how to deal with DNS?

Hello, Our organization is planning to move one domain from Dreamhost to Hubspot. Lets say, it is gem.xyxyxyxyx.com. Please note, website is not being migrated from one server to another, it is just hosting company. Here is from our internal DNS master server - # cat... (6 Replies)
Discussion started by: solaris_1977
6 Replies

2. Shell Programming and Scripting

Help with output 32bit signed integer

How do I store a number as a 32-bit little-endian Signed Integer? (2 Replies)
Discussion started by: Stuperfied
2 Replies

3. Emergency UNIX and Linux Support

Self signed ca-bundle.crt expired

Hi, I have an issue with openssl. Basically I have a ca certificate which has expired and I have regenerated a new ca.cert from the ca.key file and I have concatenated the output of the new ca.crt file and ca-bundle.crt to a new ca-bundle.crt. Have restarted apache, however I still get the... (1 Reply)
Discussion started by: maverick_here
1 Replies

4. OS X (Apple)

Unsigned to signed, error?...

Hi guys... Macbook Pro, 13", circa August 2012, OSX 10.7.5, default bash terminal. I require the capability to convert +32767 to -32768 into signed hex words... The example piece code below works perfectly except... #/bin/bash # sign.sh # Unsign to sign... while true do # I have used... (2 Replies)
Discussion started by: wisecracker
2 Replies

5. UNIX for Dummies Questions & Answers

MilesWeb.com shared hosting or unlimited hosting plans?

I want to host a website in India, after all my research I have found MilesWeb.com, I am planning to go for their shared plan http://www.milesweb.com/cpanel-hosting.php I have test their contact options and response time, they are really available 24/7. I have checked few other providers, they... (1 Reply)
Discussion started by: Guruguy
1 Replies

6. Programming

Signed and unsigned intergers

when a date type is considered signed and unsigned is that simple referring to - for signed and positive numbers for unsigned? Further if that is the case would mutiplying and dividing ect where 2 signed numbers, like (-2)*(-2) = 4 result in a unsigned. (3 Replies)
Discussion started by: Fingerz
3 Replies

7. Emergency UNIX and Linux Support

AIX 6.1 Self-Signed Cert Creation Issue

Hi, I'm trying to get a self-signed cert created on AIX 6.1, and it's not cooperating. I run the following command: gsk7cmd -cert -create -db /bin/A_CACertsOnly.kdb -pw blahblah -label testing -dn cn=machinename -expire 1000 -ca true...and get this response: The function is not supported for... (3 Replies)
Discussion started by: tekster2
3 Replies

8. UNIX for Advanced & Expert Users

Live User Signed Into All tty's 1-6

Why is my Live user signed into tty1 - 6? A few details explaining the only changes I've made: I downloaded Linux Mint 12. Burned, booted, and installed to hard drive. Performed updates. Downloaded Remastersys from repos. Remastered with updates (so I don't have to download them any... (3 Replies)
Discussion started by: bambuntu
3 Replies

9. Programming

[ASM] Adding SIGNED numbers?

Hi guys, I want to add a list of SIGNED numbers... but I don't know how to tell the computer to ADD THEM as signed, let me explain further: when adding 200 + (-100) , it becomes 100, but in asm the computer always add them as unsigned, so I always get the 300. Do I have to add them in a... (4 Replies)
Discussion started by: lamachejo
4 Replies

10. UNIX for Advanced & Expert Users

"Signed Linux" - Only executing signed programs

Hey folks, not sure whether this or the security board is the right forum. If I failed, please move :) So here's the problem: I need to build a Linux environment in which only "signed" processes are allowed to run. When I say signed I don't mean a VeriSign signature like you know it from... (5 Replies)
Discussion started by: disaster
5 Replies

Featured Tech Videos