Visit Our UNIX and Linux User Community


Qmail is working. Can't log into Pop3 server


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Qmail is working. Can't log into Pop3 server
# 1  
Old 12-29-2006
Qmail is working. Can't log into Pop3 server

I have installed Qmail via Lifewithqmail instructions. Qmail is working fine. The user directories are getting mail. I am using the qmail pop serve with checkpassword. When I check my mail with outlook I get a message saying the user has no $home/Maildir. Everything seems to be working. I just can't log in from the outside

This is on a Redhat ES3 server.

I can telnet to the mail server from my pc
+OK <4426.1167443997@my.mail.com>
user sdunn
+OK
pass studboy1
-ERR authorization failed
I also tried sdunn@my.mail.com and got the same results.

I telneted to localhost and here is what happened
[root@mail bdallas]# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
+OK <5341.1167444889@my.mail.com>
user sdunn
+OK
pass studboy1
-ERR this user has no $HOME/Maildir
Connection closed by foreign host.


when I run the checkpassword test it works:
[root@mail qmail-pop3d]# /var/qmail/bin/qmail-popup hello /bin/checkpassword pwd
+OK <4571.1167444213@hello>
user sdunn
+OK
pass studboy1
/home/sdunn
[root@mail qmail-pop3d]#

C:\Documents and Settings\Administrator>
Here is my qmailctl stat

[root@mail qmail-pop3d]# qmailctl stat
/service/qmail-send: up (pid 2716) 1947 seconds
/service/qmail-send/log: up (pid 2717) 1947 seconds
/service/qmail-smtpd: up (pid 2720) 1947 seconds
/service/qmail-smtpd/log: up (pid 2715) 1947 seconds
/service/qmail-pop3d: up (pid 3300) 1422 seconds
/service/qmail-pop3d/log: up (pid 3301) 1422 seconds
messages in queue: 96
messages in queue but not yet preprocessed: 0

Here is my qmail-pop3d/run file:
#!/bin/sh
exec /usr/local/bin/softlimit -m 2000000 \
/usr/local/bin/tcpserver -v -R -H -l 0 0 110 /var/qmail/bin/qmail-popup \
my.mail.com /bin/checkpassword /var/qmail/bin/qmail-pop3d Maildir 2>&1

I have been at this for about 9 hours now so any help will be greatly appreciated. If you need any more info just let me know.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #265
Difficulty: Easy
Alan Turing was prosecuted by the UK in 1952 for homosexual acts.
True or False?

10 More Discussions You Might Find Interesting

1. Ubuntu

Ubuntu Server in VM - DHCP Server not working

Hello. Doing my first steps in Linux and while trying to configure a DHCP server in Linux i encountered some problems: TOPOLOGY: - Laptop with Windows 8.1 - VM Player 12 with Linux installed (Ubuntu Server 14.04) - ICS-DHCP-SERVER installed and running - Another LAPTOP conected to a... (1 Reply)
Discussion started by: Portuguevos
1 Replies

2. Red Hat

Mail server using POP3

Hi, I am trying to set up a mail server on Redhat9. I have read about POP3 and have decided to use that. However, I am unable to configure the files properly. Can anyone tell me how to configure POP3? (0 Replies)
Discussion started by: shakshakshuk
0 Replies

3. Red Hat

Qmail

hi all, i want to install Qmail but i don't from where can i get the package , and also if one know source that can explain qmail kindly tell me about it (3 Replies)
Discussion started by: linux_land
3 Replies

4. IP Networking

Pop3

Opensuse Postfix ispconfig I would like to limit pop3 connections to three areas. 1. local, like 192. something 2. top domain for my Internet connection, like 204. something. 3. top domain for one other, like 270. something. What would be the easiest/best way to do this?... (1 Reply)
Discussion started by: KillerDog
1 Replies

5. Solaris

Qmail - possible?

Hi guys, Could you please advice me as im a new guy into Solaris ...is it possible to have qmail up and running on Solaris 10 and do you know where i can find some documentation on downloading and configuring - qmail? thank you guys vladi, (2 Replies)
Discussion started by: saveka
2 Replies

6. Red Hat

Pop3 server problem

hi frnds Unable to connect to POP server mit.com. Error sending password: -ERR Bad login i m getting this problem in Ximain .I m using Redhat Enterprise 3. mit (1 Reply)
Discussion started by: naik_mit
1 Replies

7. Linux

pop3

Hi Can anybody help me for configuring pop3 mail account i linux i m using linux enterprise 3. (1 Reply)
Discussion started by: naik_mit
1 Replies

8. UNIX for Dummies Questions & Answers

QMail Help

My company is running qmail on our Unix server. I would like to run a MySQL script whenever an email was sent to a specific email address. I don't want to have to check every email that comes in, so I was thinking that the script would run when the message arrives at the specific mailbox. Is there... (0 Replies)
Discussion started by: perryl7
0 Replies

9. UNIX for Advanced & Expert Users

pop3

hello dear friends I configured my dns in solaris 8 X86 pc and my sendmail, but i only can send email. i don't can receive email...... i saw inetd.conf and don't have the line of pop3. how can i add the line?and what the command? Thanks friends (8 Replies)
Discussion started by: themask
8 Replies

10. UNIX for Dummies Questions & Answers

QMail

Where I can find information about QMail with OpenBSD??? (1 Reply)
Discussion started by: vieiramail
1 Replies

Featured Tech Videos