Login or Register to Ask a Question and Join Our Community

fsck on a mounted file system?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers fsck on a mounted file system?
# 1  
Old 11-16-2005
fsck on a mounted file system?

I have a Solaris 7 box. We got a strange error in the syslog, which read as follows:
Nov 15 11:50:16 server-01 unix: NOTICE: free inode /mount1/8025691 had size 0x20d

I consulted with a fellow sysadmin, and he suggested running "fsck -N" on the filesystem in question without unmounting it. So I did, and got a bunch of errors that read as follows:

LINK COUNT FILE I=5363232  OWNER=nobody MODE=0
SIZE=0 MTIME=Nov 16 08:53 2005  COUNT 0 SHOULD BE -1

UNREF FILE  I=12544363  OWNER=nobody MODE=100600
SIZE=1891 MTIME=Nov 16 08:52 2005 

these are just examples. Should I worry about these? I'm thinking that mounted file system with active processes would always be "dirty". But I'm not sure that I'm even supposed to run fsck on a mounted file system, even with -N option. Is -N option save or am I doing some kind of a damage?

Last edited by Yogesh Sawant; 04-10-2011 at 11:09 AM.. Reason: added code tags
# 2  
Old 11-16-2005
If fsck changes nothing, it can do no damage. Normally I use -n to prohibit fsck from changing stuff, but the Solaris man page says -N works too. So it is not dangerous. How useful it is on a mounted filesystem varies. It depends on how busy the filesystem is. I would do a "sync" first (although I think that fsck does its own sync).

Your original message would bother me enough to unmount the filesystem and then do an fsck on it. When I suspect trouble, even with an unmounted filesystem, I do a -n first. Too many times I have run an interactive fsck and been stuck typing y a few hundred times. With -n, I can gauge how many and how severe the errors are. Then I can decide if my next step is fsck, fsck -y, or newfs.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

Fsck -n on mounted FS - how unreliable ?

greetings all, we had SAN bobbles recently and so I ran fsck against all local FS on all systems. our domino servers present a moving set of alleged corruption, both JFS and JFS2 FS. Am I playing whack-a-mole with special effects (i.e. false positives) produced by vigorous filesystem... (9 Replies)
Discussion started by: maraixadm
9 Replies

2. Red Hat

File system mounted or not

Hi, I know something about file system that its a directory to hold files. My query is how to identify file system is mounted or not .Can you give me some examples? OS --- Linux 2.6 (7 Replies)
Discussion started by: Maddy123
7 Replies

3. Solaris

Not able to run fsck on root file system

I am trying to root disk mirroring on SunFire V210 Server. There are two disks on this server c1t0d0 and c1t1d0 . I completed all the steps and I updated the vfstab file too. After I have updated the vfstab file I run df -h command but could not see the changes i made in vfstab. Suddenly the server... (1 Reply)
Discussion started by: newbi8321
1 Replies

4. UNIX for Dummies Questions & Answers

Run fsck on root file system

If i run fsck on one filesystem and fsck need to repair some things then this partition must be unmounted correct ? So running fsck on root file system isn't possible within same OS ? correct ? What is the best way to do that, live cd ? BR, Jurif (5 Replies)
Discussion started by: jurif
5 Replies

5. SCO

file system not getting mounted in read write mode after system power failure

After System power get failed File system is not getting mounted in read- write mode (1 Reply)
Discussion started by: gtkpmbpl
1 Replies

6. Solaris

FSCK root file system (/dev/vx/dsk/bootdg/rootvol)

Hi, I need to fsck the root file system on my Solaris 9 server. It is a UFS file system but it is under Veritas control. I want to know which fsck I need to use to check the file system. The default Solaris fsck (/usr/sbin/fsck) or the Veritas (/lib/fs/vxfs/sparcv9/fsck) fsck? I take it I... (3 Replies)
Discussion started by: gwhelan
3 Replies

7. Solaris

How to find which file system was not mounted ?

Hello all, can someone help on how can i check if all file system were mounted during reboot? I know that we have first to look on /etc/vfstab; the containing of this one should be mounted during boot of system, and after with : df -k we can see if mentioned file system on vfstab were... (3 Replies)
Discussion started by: vitchi
3 Replies

8. HP-UX

fsck! How to run Full File System Check

Dear all I am new for HP-UX. I have HP rp2470 running HP-UX 10.x When i run fsck in a root, the output is as below: #:root> fsck fsck: /dev/vg00/rlvol1: mounted file system continue (y/n)? y ** /dev/vg00/rlvol1 ** Last Mounted on /stand ** Phase 1 - Check Blocks and Sizes ** Phase... (3 Replies)
Discussion started by: hungevntelecom
3 Replies

9. UNIX for Dummies Questions & Answers

how many directory can be mounted on one file system

I have a question and seek help. How many directory can be mounted on one file system on UNIX with solaris 9? For example, I have one file system as /dev/dsk/cieit0a6. I have created one directory as /u01/app/oracle and mounted this directory to cieit06. It works. Then I create another directory as... (4 Replies)
Discussion started by: duke0001
4 Replies

10. UNIX for Dummies Questions & Answers

File System Check (fsck)

I am having a problem with fsck. I am new to UNIX but was placed in a position where I must learn it. Anyway, one of the instructions that I have been given is to use 'fsck -f -y' when I am having trouble with the filesystem. The problem is that I am getting an error message that says the -f... (1 Reply)
Discussion started by: mawalton
1 Replies
Login or Register to Ask a Question

Featured Tech Videos