crontab not running script


 
Thread Tools Search this Thread
# 1  
Data crontab not running script

Hi All,
I am having the below script to be run from crontab, it it doesnt run.
Code:
1 * * * * /home/cobr_ext/test.sh  > /home/cobr_ext/temp.txt

when i run i manally it runs without any issues.

Could please help me as to why doesnt it run the script.Smilie

Last edited by Franklin52; 10-24-2012 at 04:54 AM.. Reason: Please use code tags for data and code samples
# 2  
With "it doesnt run" you mean, it starts but does not work as expected, I suppose? This is a common problem, most likely shell variables are not defined, as they are in your login shell environment. Cron starts commands with a minimal environment and does not include files like .profile, .bash_profile, .kshrc, .bash_rc, etc.
# 3  
Could you please let me know how your running manually and permission of the test.sh .
# 4  
below is the content of the script:
Code:
#!/usr/bin/ksh
chmod 777 /home/cobr_ext/*.*

and i have given full 777 permission for script.

Code:
./test.sh --> i run the script using this.

Now the problem, it is running the script sometimes.
I login as su - username and manually change the file permission in the dir as we receive the files with 640 permission and i want the script to change the file permission to 777 and have scheduled it using crontab.
but the crontab is not executing the shell script for some reason.
I have checked the /var/log and tmp.txt for any outptus errors and it doesnt have any.

Please help.

Last edited by Scott; 10-24-2012 at 07:53 AM.. Reason: Code tags
# 5  
Quote:
Originally Posted by abhi_123
below is the content of the script:
#!/usr/bin/ksh
chmod 777 /home/cobr_ext/*.*


Please help.
You dont need a script for this, just enter this in your crontab file.
# 6  
2 things:
1) Is it in root cronfile?
2) you execute your script like:
Code:
./test.sh -->

but from where?
As already mentionned cron is quite stupid and knows nothing about your environment...
I will not repeat myself XXX time since there are so many threads already about this kind of issue, unless you can show us you have something else and in which case you will awaken the ape's curiosity hidden in each of us (I hope... me anyway...)
# 7  
hergp was most probably spot on in his first posting: you are falling for Cron Problem Number One. Follow the link for the solution.

I hope this helps.

bakunin
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #465
Difficulty: Medium
A 2017 security audit of three NTP implementations, conducted on behalf of the Linux Foundation's Core Infrastructure Initiative, suggested that both NTP was less secure than Chrony.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

CRONTAB - one python script is not running

Hi! I'm using a RaspberryPi with standard Raspbian. Currently I'm working on some sort of weather station. For now I have three python scripts - one which is updating txt files for website - update1m.py ( it will not be necessary in few next days so I'll delete it) , second one for updating... (4 Replies)
Discussion started by: bartocham
4 Replies

2. Solaris

Script problem when running on crontab

Hi guys! I created a backup script that works fine when I run manually, but when I put a crontab job to execute it the result are not the expected. (not a time problem). Here is my script: bash-3.00# cat /bk_tool/backup2.sh #!/usr/bin/csh clear set DIR_HOST='SCP08' ... (3 Replies)
Discussion started by: andredemartini
3 Replies

3. UNIX for Advanced & Expert Users

Particular script not running through crontab

Hi, I have created the below script, set -x # Set the Path of Environment file ENV_FILE_DIR=/opt/app/p1trp1c1/sybase/ecdwqdm/xrbid/QDM_Prod/bin LOG_DIR=/opt/app/p1trp1c1/sybase/ecdwqdm/xrbid/QDM_Prod/log export ENV_FILE_DIR export LOG_DIR # Set Audit Environment . ${ENV_FILE_DIR}/QDM.env... (8 Replies)
Discussion started by: yohasini
8 Replies

4. Shell Programming and Scripting

Crontab not running a script

Hi, I posted this in the Solaris forum but I think this one would be more appropriate. I created a script starting with the following lines: #!/usr/bin/ksh flag=n export flag typeset -i quant=0 (...) When running it I'm getting the following 2 errors: /tmp/tstscript/testfail.ksh:... (9 Replies)
Discussion started by: Cvg
9 Replies

5. Shell Programming and Scripting

Running SQLPLUS Script in CRONTAB

Hi, Can someone please help me here with this one. This is my script: # more tosh.sh #!/usr/bin/ksh clear . /home/oracle/.profile echo "Good morning, world." export ORACLE_HOME=/u01/app/oracle/product/9.0.1 export PATH=$ORACLE_HOME/bin:/usr/local/bin export ORACLE_SID=xxxx ... (11 Replies)
Discussion started by: santoshpayal
11 Replies

6. Shell Programming and Scripting

Problem with crontab running a script

I am trying to use the CRON utility in Fedora 11 & CentOS... I intend to run a script which pops up a warning message every hour and i made the following entry using "CRONTAB -e " * * * * * sh /bin/myscript.sh But this does not seem to be running. Another thing to note is that,... (4 Replies)
Discussion started by: Vabiosis
4 Replies

7. Red Hat

Problems with script running with crontab

Hi, I'm trying the backup a few information commands of my Check Point FW (it's on a SPLAT linux machine). This is the script I wrote: #!/bin/bash cd /var/tmp/ file1=netstat_`/bin/date +%d%m%y`.txt file2=ifconfig_`/bin/date +%d%m%y`.txt file3=cpstatos_`/bin/date +%d%m%y`.txt... (2 Replies)
Discussion started by: nirsh
2 Replies

8. UNIX for Dummies Questions & Answers

Getting error when running script through crontab

Hi all, I wrote small script for Solaris and when I am running it through command prompt its ok, but when I trying to run it using crontab, i am getting error like: ld.so.1: dbloader: fatal: libACE.so: open failed: No such file or directory /tmp/file.sh: line 5: 8304 Killed ... (4 Replies)
Discussion started by: nypreH
4 Replies

9. Shell Programming and Scripting

issue with running script with crontab

I am facing a strange issue while running a script(eg A) from the crontab entry the script calls one more script(eg B) within it now when i run the script A manually(with nohup) it also executes the script B (embedded inside it) as expected. but when i run the script A from the crontab entry... (7 Replies)
Discussion started by: mad_man12
7 Replies

10. UNIX for Dummies Questions & Answers

A command in a script not running in Crontab.

Hi, I made this script for TRU Unix 5.1 OS based Node. When the script was run manually all the commands were running properly. But when it was run from Crontab, one command is not running. This command is not running when the script is running from Crontab: #... (2 Replies)
Discussion started by: mystition
2 Replies

Featured Tech Videos