xls2csv.py won't print to outfile


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers xls2csv.py won't print to outfile
# 1  
xls2csv.py won't print to outfile

Hi,

I'm trying to use pyExcelerator's module "xls2csv" converter in ubuntu.

The following works great, except the standard out is in the terminal.
Code:
sudo python xls2csv.py test.xls

I want the csv delimited output to be redirected to a file. When I enter....
Code:
sudo python xls2csv.py test.xls > outfile

it complains and states "bash: outfile: Permission denied".

This is a unix issue right? Why won't it let me print to an outfile?

Thanks!
# 2  
It means what it says: You don't have permission to create 'outfile' in the current directory.

sudo won't help you here since it tries to create the file before running the program.
# 3  
My interpretation of what you're saying is run it in another directory? and why would it try to create the file before running the program?

---------- Post updated at 11:53 AM ---------- Previous update was at 11:50 AM ----------

Got it working! thanks
# 4  
It tries to create the file before running it because that's how redirection works. You can't change what file stdout goes to for a different program once it's already running, but it's easy to do so in advance. So the shell makes a copy of itself, redirects, and replaces the copy with the program you wanted it to run.
This User Gave Thanks to Corona688 For This Post:
# 5  
xls2csv remotely on server doesn't work

Hi Corona688,

I moved the python tar to the server and installed it, but I'm getting an error. It seems that xls2cvs works locally, but I can't get it to work remotely.

Code:
ionadmin@ionT01:/results/analysis/output/Home/TuesdayJuly31_064/plugin_out/variantCaller_out/IonXpress_001$ python /home/ionadmin/tools/pyexcelerator-0.6.4.1/tools/xls2csv.py variants.xls > variants.csv
extracting data from variants.xls
Traceback (most recent call last):
  File "/home/ionadmin/tools/pyexcelerator-0.6.4.1/tools/xls2csv.py", line 17, in <module>
    for sheet_name, values in parse_xls(arg, 'cp1251'): # parse_xls(arg) -- default encoding
  File "/usr/local/lib/python2.6/dist-packages/pyExcelerator/ImportXLS.py", line 327, in parse_xls
    ole_streams = CompoundDoc.Reader(filename).STREAMS
  File "/usr/local/lib/python2.6/dist-packages/pyExcelerator/CompoundDoc.py", line 63, in __init__
    self.__build_header()
  File "/usr/local/lib/python2.6/dist-packages/pyExcelerator/CompoundDoc.py", line 105, in __build_header
    raise Exception, 'Not an OLE file.'
Exception: Not an OLE file.

My local computer is the latest Ubuntu LTS, but the server is Ubuntu 10.04.2 LTS. Do you think the server is missing dependencies that my local computer has?

EDIT! I am getting the same error both locally and remotely. I tested it on a fresh file in both places.

Last edited by jdilts; 08-01-2012 at 02:49 PM.. Reason: same error both local and remote
# 6  
Take a close look at that XLS file. Maybe it's corrupted, or from a version of excel new enough to use the new incompatible format.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #836
Difficulty: Medium
SOAP is a data serialization specification.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Bash script won't run because hardware won't produce display

Can anyone offer any advice on how to modify the script below to work on a new system we have, that has no graphics capability? We admin the system through a serial RAS device. I've tried running the below script through the RAS and through an ssh -X session. It failed with something like "GTK... (3 Replies)
Discussion started by: yelirt5
3 Replies

2. UNIX for Beginners Questions & Answers

INTO OUTFILE Error 2

Good day, I am trying to run the following command but it does not seem to work. # mysql -pPassword asteriskcdrdb -s -b -e "select 'Account ID','Destination','Operator','Provider','Date','BillSec','Rate id','Cost' UNION select accountcode,dst,'PBX',route_name,date_format(calldate,'%Y/%c/%e... (8 Replies)
Discussion started by: esgaroth32
8 Replies

3. Shell Programming and Scripting

Error while Converting Excel to CSV using xls2csv

I am using xls2csv to convert a xls file into a regular .csv file. However, while using the command as xls2csv fromfile.xls > tofile.csv I am getting the following error. fromfile.xls is not OLE file or Error I also tried to specify the comma as delimiter but did not help... xls2csv -c\,... (7 Replies)
Discussion started by: dhruuv369
7 Replies

4. Shell Programming and Scripting

Variable won't print out - awk

done. (1 Reply)
Discussion started by: myaa02
1 Replies

5. UNIX for Dummies Questions & Answers

Outfile

Hi guys! So I have a program that allows the user to enter a file, change some characters (for example, a changes to t, etc.) and then save the new file under a new name. However, I need to press carriage return twice for the program to end. I was just wondering if anyone knew of a way for the... (2 Replies)
Discussion started by: PerlNutt
2 Replies

6. Slackware

Printer won't print but 1 page

OS: Slackwar 13.37 Printer: hpDeskjet 1000 j110 Printer Drivers/Software: HPLIP 3.11.3a (min was 3.10.9) and Cups The printer will print the first of n-pages but from page 2 on it prints the page (or part of it) backs up and starts again down about 0.8 lines and does this repeatedly till the... (2 Replies)
Discussion started by: slak0
2 Replies

7. Shell Programming and Scripting

print to more than one outfile AWK

I'd like to do an if / else if condition and print to different files. Something like: awk '{ if ($1 == "yes") print $2, $4 < infile > outfile1 ; else if ($1 == "No") print $2, $4 < infile > outfile2 }' Obviously I don't know the syntax. Thanks so much. (5 Replies)
Discussion started by: dcfargo
5 Replies

8. UNIX for Dummies Questions & Answers

How to outfile contant as an input for a command

I`m having output file which contain following no which changes every time i run script.The number given below are there in file and i have to fatch them from file. 12 15 56 158 365 165 598 568 265 256 258 now i want to use above number from output to input as $j r=`/omp/bin/ICIC... (1 Reply)
Discussion started by: nitin_aaa27
1 Replies

9. AIX

won't mount /usr...won't boot fully

Hello: NOOB here. I attempted to use smit mkcd. Failed on first attempt, not enough space. 2nd attempt tried to place iso on /usr, not enough space there. Cleanup ran for about 5 minutes after aborting. Now AIX won't boot. LCD display on 7029-6E3 says: 0517 MOUNT /USR. Attempted to boot from CD... (11 Replies)
Discussion started by: bbird
11 Replies

10. Shell Programming and Scripting

Setting outfile with (brackets)

I have a file that comes in as 20081002_invoices.txt and needs to go out as invoices(20081002).xls When ran this file should have three seperate fields as follows: column1 column2 column3 data1 data2 data3 when i run the script it produces the invoices(20081002).xls but moves... (1 Reply)
Discussion started by: Pablo_beezo
1 Replies

Featured Tech Videos