Can't open VirtualBox from Tera Term X11 error


 
Thread Tools Search this Thread
# 15  
Why would you want VirtualBox to connect its graphical interface to the telnet server of the wrong machine? Smilie

Let me explain how SSH port forwarding works.

You tell SSH to forward a port on the remote host to a port on your local host.

When you connect to the remote server with SSH, the SSH server opens an extra port on the local host itself, waiting for you to connect to it.

When you connect to it, the SSH server forwards this back to the client, your client connects to whatever you told it to earlier.

So in effect, it creates a new port on the remote host, which connects it directly to X11 on your machine.

If you don't know what port number your X11 server is, you'll have to find out and forward it, since ordinary X11 forwarding doesn't seem to be working.
# 16  
From wireshark
Code:
Internet Protocol Version 4, Src: 144.243.90.235 (144.243.90.235), Dst: 144.243.35.2 (144.243.35.2)Transmission Control Protocol, Src Port: telnet (23), Dst Port: 54025 (54025), Seq: 799, Ack: 166, Len: 1

So I tried
Code:
# DISPLAY="144.243.35.2:54025" ./VirtualBox
Failed to open the X11 display!
#

I have to be missing something in the setup of TeraTerm and Reflection X. I have Xming running in the background, is there a setting I missed?

---------- Post updated at 09:22 AM ---------- Previous update was at 08:31 AM ----------

So I have setup the display and am know getting a new error, I have Xming running
Code:
 DISPLAY=144.243.35.2:0.0
# export DISPLAY
# echo $DISPLAY
144.243.35.2:0.0
# cd /opt/V*
# VirtualBox
Xlib: connection to "144.243.35.2:0.0" refused by server
Xlib: No protocol specified

Failed to open the X11 display!
# cd /
# cd /usr/bin
# firefox
Xlib: connection to "144.243.35.2:0.0" refused by server
Xlib: No protocol specified

Error: cannot open display: 144.243.35.2:0.0


Last edited by Scrutinizer; 04-02-2012 at 09:38 AM.. Reason: Code tags....
# 17  
It could easily be being blocked by a firewall, which is the reason we were trying to forward ssh all along...

For that matter, is your xming even configured to allow non-local connections? Do you know what port you have Xming running on? 0.0 could easily be wrong if you don't know for a fact it is right...
# 18  
0.0 is working for my coworker, he is also using telnet. He has been here for a while thought and is not sure how he configured it. I have defiantly gotten further in the setup. There was a problem connecting that was coming from SEP. That has been resolved and I was able to us Reflection to get a GUI desktop of the Solaris server, but it is slow. I also want to learn the command line ways.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Error term undefined

i keep getting this error when i ssh using my id - any idea (2 Replies)
Discussion started by: tariq_m
2 Replies

2. UNIX for Advanced & Expert Users

Issue with rm command in a tera byte file system

We have a production file system which has 6+ million files with more than 1 tera byte in size. When trying to delete selective files through a weekly script files are not deleted. Please advise with ideas. (5 Replies)
Discussion started by: kppublicmail
5 Replies

3. Virtualization and Cloud Computing

Error in virtualbox while instaling guest additions

Failed to open the CD/DVD image /usr/lib/virtualbox/additions/VBoxGuestAdditions.iso. Could not get the storage format of the medium '/usr/lib/virtualbox/additions/VBoxGuestAdditions.iso' (VERR_NOT_SUPPORTED). Result Code: VBOX_E_IPRT_ERROR (0x80BB0005) Component: Medium Interface: IMedium... (9 Replies)
Discussion started by: upvan111
9 Replies

4. Solaris

X11 and "Cannot Open Display" errors

Greetings Forumers! I'm posting a solution to an Issue I ran into this week: Getting applications to display on another through X11 and SSH. I have run into this issue many years ago and finally found my notes. Some of you may already know the answer to this issue but it took me a while to... (1 Reply)
Discussion started by: bluescreen
1 Replies

5. OS X (Apple)

Permission Denied Error with X11

Hello, I am using Tiger 10.4.11 I am trying out the GIMP, so I installed the X11 package from "Optional Installs" on the cd. Whenever I open X11, I get an error: xterm: could not exec /dev/null: Permission denied I have chmodded /dev/null to 777, as well as the /tmp directory. I deleted... (2 Replies)
Discussion started by: Ricardo-san
2 Replies

6. Solaris

Tera Terminal Emulator

Hello Expert! :b: Question for you guys, Can anyone tell me how to use terminal emulator on Windows XP to view Solaris config? I have no idea on Solaris and the only thing I could do is to boot it up. Honestly, I have given a tasked to delete all the files and some necessary memory information... (2 Replies)
Discussion started by: katsloko
2 Replies

7. Solaris

ssh X11 tunnelling error

Hello freinds. Recently installed solaris 10 on a "sun ultra 10" with all the included features in the 5 CD set except sendmail support which i never needed. I am trying to ssh into the servers at my school which I can very easily do using linux. It seems that there is something wrong with the... (2 Replies)
Discussion started by: aijazbaig1
2 Replies

8. Shell Programming and Scripting

Search term and output term in desired field

Hi All, I have an input_file below and i would like to use Perl to search for the term "aaa" and output the 3rd term in the same row as "aaa".For Example, i want to search for the term "ddd" and would want the code to ouput the 3rd term in the same row which is "fff". Can somebody help ? ... (28 Replies)
Discussion started by: Raynon
28 Replies

9. Programming

Create a Term & Run chars on this Term

hi floks ! i'd like to know how can i transmete a character or a string from my source code to a term and make it interpret or un by the shell wich is running in my term. I'd like to create a Term from my code (and get its file descriptor) and then transmete each char typed on the keyboard to... (1 Reply)
Discussion started by: the_tical
1 Replies

Featured Tech Videos