Visit Our UNIX and Linux User Community

this cshell script does not work ??

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers this cshell script does not work ??
# 1  
Old 02-10-2012
this cshell script does not work ??

Hi I am trying to put the following commands that i have to type manually at the cshell prompt into a cshell script startup.csh which is copied below

xhost +
rsh ba08lo01
module load incisiv/102/10.20.035

When i run the script with source command as follows

$ source startup.csh

I get the following messages on the cshell

ba08ut01:12:0 #this is the output of first command
access control disabled,clients can connect from any host #output of 2nd command
Last Login Sat, Feb 11, 04:01:22 from ba08ut01 #output of last command

I am wondering why lines 3 and 4 are not getting executed in the startup.csh script. If i type these commands on the command prompt, i see them executing and the messages they print out to the screen.

Is there some thing wrong with the syntax?

Please correct me.

Do i have to modify it a lot in case i want to convert it to bash script.

Thanks a lot for your attention

Hats off to Corona688 for his earlier help.

Last edited by kaaliakahn; 02-10-2012 at 08:13 PM..
# 2  
Old 02-10-2012
What's the value of $DISPLAY ?
The 'rsh' command may be eating the lines below it.
# 3  
Old 02-10-2012
i get the following when i do echo $DISPLAY

Note i have written this in the original post as well. Please see if you get a chance

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Assigning any number to the variable in cshell script

Hello Guys, I would like to ask you for a favor. Could you please help me how can I assign any number as the parameter to a, from stdin (-c), in the following command line by using the 'switch' in a script? awk '$8>a {print "File name:" $5,$8}' I would also appreciate if you can share any... (1 Reply)
Discussion started by: Padavan
1 Replies

2. Shell Programming and Scripting

My script work on Linux but not work in sunos.

My script work on Linux but not work in sun os. my script. logFiles="sentLog1.log sentLog2.log" intial_time="0 0" logLocation="/usr/local/tomcat/logs/" sleepTime=600 failMessage=":: $(tput bold)Log not update$(tput rmso) = " successMessage="OK" arr=($logFiles)... (7 Replies)
Discussion started by: ooilinlove
7 Replies

3. UNIX for Advanced & Expert Users

Unable to call a script from another script in cshell

Hi, I am unable to call one script from another script in c shell on windows SUA environment. Please find below code , File1 āTmp.csh: #!/bin/csh setenv PATH "${PATH}:.:$TOP/bin:$TOP/RMBIN/bin:$GP_SUA/:$INTERIX_ROOT" echo "hi1" . /tmp1.csh File2ātmp1.csh ... (6 Replies)
Discussion started by: gthangav
6 Replies

4. Shell Programming and Scripting

cshell script problem

Hi ,I have this simple code,why is not working thanks #!/bin/csh set res=find ./ -name "*.bash" | wc -l $res > result.txt (16 Replies)
Discussion started by: lio123
16 Replies

5. Shell Programming and Scripting

Script cShell - help!!

Hello everyone! i'm new in this forum and I'm here because I have a huge problem with a csh script. Here the problem: I have to write a script that check the system status, more precisely I have to check if there are processes with TIME > 3 hours and if such processes exists I must send a mail... (3 Replies)
Discussion started by: TheBeefEater
3 Replies

6. UNIX for Dummies Questions & Answers

Regarding Decimals in Cshell

Hello... I am new to unix and I am wondering if in a C-shell script , Are we supposed to use only whole numbers........ for example..if a program needs to calculate the average of some numbers........ @ avg = (($1 +$2 + $3)/3)) is returning a whole number.........How can a decimal be achieved... (1 Reply)
Discussion started by: ravindra22
1 Replies

7. Shell Programming and Scripting

Modify Perl script to work with txt - Permissions script

Hi I have this code, and i want work with a ls -shalR output in .txt What i need read to do this?? Where start? #!/usr/bin/perl # Allrights- A perl tool for making backups of file permissions # Copyright (C) 2005 Norbert Klein <> # This program is free... (1 Reply)
Discussion started by: joangopan
1 Replies

8. UNIX for Dummies Questions & Answers

Script doesn't work, but commands inside work

Howdie everyone... I have a shell script Inside this file, it only has two commands as below: rm -f ../../reportToday/temp/* rm -f ../../report/* My problem is that when i execute this script, nothing happened. Files remained unremoved. I don't see any error message as it... (2 Replies)
Discussion started by: cheongww
2 Replies

9. Shell Programming and Scripting

How to make a cshell (csh) script interactive

Experts, I tried to make my cshell script interactive by asking the user for password and trying to read the input using the "read" command. I have been unsuccessful so far. Do you have any idea ? Thanks Jim (2 Replies)
Discussion started by: jimmynath
2 Replies

10. Shell Programming and Scripting

help with cshell script to read 1 or more lex files

taskes one or more .l files and compiles them #!/usr/bin/csh #while loop to carry on asking user to enter the files while $number!=0 echo "enter file name" #check to see if file ends with .l #if file ends with .l compile lexx.yy.c file for each file this is how i think it needs... (1 Reply)
Discussion started by: homerj546
1 Replies

Featured Tech Videos