Visit Our UNIX and Linux User Community


print queue behavior on HP-UX


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers print queue behavior on HP-UX
# 1  
Old 08-18-2004
print queue behavior on HP-UX

We have a 3rd party print queue installed on HP-UX 11.11 that interfaces with a binary. Basically we use the lp command to send reports to the print queue, which then interfaces with a binary to capture those reports into a reporting warehouse.

The problem lies in the way that HP uses a link to the request path instead of actually using the path. So when the binary gets the filename it gets it as something like

Quote:
/var/spool/lp/request/vista/dA0016machine
on Solaris it is represented as the real path to the file name.

Is there anything I can do to remedy the filename change? Is there somewhere I can find out more about what variables the print queue sends to the interface in /etc/lp/interfaces?

uname -a:
HP-UX machine B.11.11 U 9000/800 2909917675 unlimited-user license
Thanks.
# 2  
Old 08-18-2004
If you're having difficulty with a third party package, why not complain to the third party? But to find out what parameters are passed, just slip a few lines of code into the interface script to log them and then print something.
# 3  
Old 08-18-2004
Third party doesnt support that method on HP-UX because of that problem, but I figured there's gotta be a way (there's ALWAYS a way).

Thanks for the suggestion. I'll see what I can do.
# 4  
Old 08-18-2004
Hmmm...why is this a problem? The link is just a symlink to the real file. Open it and you have your file. Or "ls -l" it to get the real file name. But in a case like "ps -ef | lp", it will be the real file name.

How can that third party supply a binary to an OS that they don't support?
# 5  
Old 08-18-2004
Maybe I should provide a bit more background. The binary generally works on HP-UX. However there is one option that does not work because it relies on filenames, since the filename is not represented correctly (perhaps because of the way they wrote the interface).
They won't do anything about this. They just won't support that specific feature of the binary.
I think that if the interface file is tweaked, then it will work fine. Our company relies heavily on this feature, so I'm willing to play with the interface and see what I can do.
# 6  
Old 08-19-2004
I always use symbolic links to solve these types of problems.
# 7  
Old 08-24-2004
Progress...I was not able to ls -l to get the symlink because this is not a physical printer so HP just copies the file to the request directory.

I figured out a way to get the original filename and location, but then ran into a problem because lp couldnt read the file (ACL). I added lp to the correct ACL group and was able to read the file if I did a su - lp.

However, when using the interface, I was not able to read the file. I had to manually put a newgrp command in the interface script.

So it works now. But any ideas why lp could not get the groups straight within the interface script?
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #30
Difficulty: Medium
Microsoft was founded in 1971.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Print queue problems

I am using AIX 5. Just swapped over an HP printer. The old printer was on a JetDirect box. The new printer connects directly to the network. Using the same IP address to print to, so the only alteration I made was to edit the etc/qconfig file to alter the port setting from 9103 to 9100. I can... (2 Replies)
Discussion started by: charding
2 Replies

2. UNIX for Advanced & Expert Users

[Solved] remove all print jobs from a print queue

Hello, Sometimes i need to clear all the jobs of a print queue and it is really annoying to cancel one by one. Is there a way to cancel all print jobs for a specific print queue with a single command instead of cancelling them one by one? My AIX system is 5.3 Thank you for your attention (2 Replies)
Discussion started by: omonoiatis9
2 Replies

3. Shell Programming and Scripting

awk print behavior weird

Hi Experts I am facing a weird issue while using print statement in awk. I have a text file with 3 fields shown below: # cat f1 234,abc,1000 235,efg,2000 236,jih,3000 # When I print the third column alone, I dont face any issue as shown below: # awk '{print $3 }' FS=, f1 1000 2000... (5 Replies)
Discussion started by: guruprasadpr
5 Replies

4. AIX

Print queue restriction

Hi, I'm at AIX 5.3, I have a print queue named chqprinter, I want to allow access to print only 2 users to that print queue, jobs printed by all other users to above queue should be deleted. Any idea how to achieve that? ---------- Post updated at 10:33 AM ---------- Previous update was at... (5 Replies)
Discussion started by: tayyabq8
5 Replies

5. Shell Programming and Scripting

Print Queue Montior

I am very new to scripting could use some assistance polishing up my script. I have had issues with a print queue going down and needing some TLC to get it going again, however currently I have to wait for a user to complain about the issue. I have written a little script to monitor the print queue... (0 Replies)
Discussion started by: tdiYUZER
0 Replies

6. HP-UX

Print queue not getting flushed

Hi All, I am new to HP-UX and new to administration world. I have a problem with two HP Laser Jet M5035MFP printers which are connected to HP-UX host machines. Problem is that whenver we print a job, the job gets printed very fine but the queue is not cleared. This makes the further jobs on the... (2 Replies)
Discussion started by: akashgulati
2 Replies

7. Solaris

Print to ps2pdf print queue

I am trying to create a printer queue, on a SunOS 5.7 system, that outputs a pdf file. There is an application running on the system that has a print button, which sends print files to the default printer. If I disable the printer, I am able to manually capture the files in /var/spool/lp/tmp and... (2 Replies)
Discussion started by: Sean_69
2 Replies

8. UNIX for Dummies Questions & Answers

Print to a ps2pdf print queue.

I am trying to create a printer queue, on a SunOS 5.7 system, that outputs a pdf file. There is an application running on the system that has a print button, which sends print files to the default printer. If I disable the printer, I am able to manually capture the files in /var/spool/lp/tmp and... (1 Reply)
Discussion started by: Sean_69
1 Replies

9. AIX

AIX 5 print queue

I have setup a printer and queue using SMIT and I have set the default tray to 4. What I am trying to find out is if there is a way to set the next tray it trys to use if tray 4 is empty to tray 3, then tray 2, then tray 1. (0 Replies)
Discussion started by: chefsride
0 Replies

10. UNIX for Dummies Questions & Answers

Problem with print queue

I have a problem with a print queue that keeps going down on me every couple of days. When it happens I run an 'enable' and all is fine for a few more days. Can anyone can tell me where to start looking to debug this problem as i am new to UNIX Thanx (1 Reply)
Discussion started by: carell
1 Replies

Featured Tech Videos