Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Admintool
# 1  
Old 04-27-2004
Data Admintool

I am new to unix....How do I enable XWindows... Or for that matter, use Admintool. .....Pls. help.


PS. I am running Solaris 8.
# 2  
Old 04-27-2004
to use admintool you need to be part of the root or sysadmin group.

if you have the xserver running on your desktop then you can just execute the command admintool and it will start.

if your xclient/xserver is not running then you need to start the dt services. (/etc/rc2.d/S99dtlogin).

this is all assumeing though that you have installed all the required packages to enable the server to display graphix.

i would like to add thought for posterity sake admintool is dumbed down ALOT and you will have much more control/options avaliable useing the commandline utilities that the interface provides.

Last edited by Optimus_P; 04-27-2004 at 05:04 PM..
# 3  
Old 04-28-2004
Admintool --tried your suggestion

I tried your suggestion....did not work. I get a message ' command not found'. (/etc/rc2.d/S99dtlogin)
# 4  
Old 04-28-2004
I agree, admintool is not really worthwhile unless you want to know some info for your cert test (if that is worthwhile).

As for enabling X. It may not even be installed on your server. When I build servers, its from the standpoint of less is more. Does a 'pkginfo' show the X11 packages? If dtlogin isn't already running, there is probably not going to be an rc link to the init script in rc2.d. Take a look at /etc/init.d/dtlogin.

It really sounds like you aren't making some basic troubleshooing efforts. Look to see if a script is there before trying to run it. Even more so, understand the implications of what it is you are starting before doing so.


Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

HP Printer without SMC, Admintool, or Jetadmin

Jetadmin fails saying that it is not a network printer despite the fact that it is and can be pinged from UNIX. I am administering this remotely (long remote, I can't go there soon) and can't run smc or admintool. Any help configuring this spooler would be appreciated. (1 Reply)
Discussion started by: TT Fan
1 Replies

2. UNIX for Advanced & Expert Users

Does admintool write to eeprom?

Hi: I was setting up a modem on an Ultra5 running 2.6. (yes I know, how quaint) There are 15 systems that are interlinked but not accessible to the outside world. This will end soon with new updated sun systems but until then the system needs to be accessed by the outside world. Hence the... (1 Reply)
Discussion started by: mndavies
1 Replies

3. Solaris


How can I solve this admintool Error: Can't open display: (4 Replies)
Discussion started by: iwbasts
4 Replies

4. Solaris

what happened to admintool?

what happened to admintool in Solaris10? (2 Replies)
Discussion started by: mndavies
2 Replies

5. Solaris

Admintool and rpc call

Hi all, I'm trying to launch admintool via an export DISPLAY. i get the message: Received communication service error 4: Remote procedure call timed out: program = 100087, version = 10 Just to say, i don't use nis/nisplus on my server... What to do? Thanx Jason (17 Replies)
Discussion started by: penguin-friend
17 Replies

6. UNIX for Advanced & Expert Users

Printer Error with Admintool

Hi I have a unix box [ Solaris 2.5.1 , sparc staion 5_10 ) I could successfully configure a LOCAL printer using lpadmin -p XX -v /dev/term/a But when I tried to do local printer configuration with admintool, ( as root user ) it throws up error. " add printer failed ". Also when I... (4 Replies)
Discussion started by: shibz
4 Replies

7. UNIX for Dummies Questions & Answers

admintool : error display..

hi, i did the following 1) which admintool /bin/admintool 2) admintool Error: Can't open display: how to set the display then? i am using netterm to telnet to my sun server. (6 Replies)
Discussion started by: yls177
6 Replies

8. UNIX for Dummies Questions & Answers

problem with admintool

hi, after i execute admintool, i got the below "Error, cant open display" what is wrong? thanks (5 Replies)
Discussion started by: yls177
5 Replies

9. UNIX for Dummies Questions & Answers

sun solstice, admintool, smc

hi, i tried these sun command on a sun0s 5.7 but get the "cant open display" message. please advise. i am using netterm to telnet. (5 Replies)
Discussion started by: yls177
5 Replies

10. UNIX for Dummies Questions & Answers


Hi, Does anyone here know where I can find out what commands admintool runs while adding a new user and setting up the account? Reason being is the script I am writting, I can add the user create the path. But it wont set the path for the user. The password well it wont add without... (1 Reply)
Discussion started by: merlin
1 Replies
Login or Register to Ask a Question

Featured Tech Videos