Unable to use the Sudo command. "0509-130 Symbol resolution failed for sudo because:"

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unable to use the Sudo command. "0509-130 Symbol resolution failed for sudo because:"
# 1  
Old 12-21-2009
Unable to use the Sudo command. "0509-130 Symbol resolution failed for sudo because:"

Hi! I'm very new to unix, so please keep that in mind with the level of language used if you choose to help Smilie Thanks!

When attempting to use sudo on and AIX machine with oslevel, I get the following error:

exec(): 0509-036 Cannot load program sudo because of the following errors:
0509-130 Symbol resolution failed for sudo because:
0509-136 Symbol __strtollmax (number 122) is not exported from
dependent module /usr/lib/libc.a(shr.o).
0509-192 Examine .loader section symbols with the
'dump -Tv' command.

I read something about fixing it by synching libraries. Is there another possible work around?

thanks a million for reading and perhaps even offering advice!

# 2  
Old 12-21-2009
I am more used to Solaris where I would use the ldd command to check that all the libraries are present and correct, the FAQ at:
2.27: Where can I find ldd for AIX?
says where ldd for AIX is available.

To use ldd(1) you would cd to where sudo lives and then run:
$ ldd ./sudo

This checks all the libraries are present, then run:
$ ldd -r ./sudo

This will check all the symbols are present, this will show you which libraries you require more up to date versions of.

To make a more up to date library files available to only sudo you can cheat and write a wrapper script that puts the directory where you have put the more up to date libraries first (not one of the normal library directories) in the LD_LIBRARY_PATH and then call sudo $@. This is a kludge in some folks opinions but it works!
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

"sudo su -" showing lot of information on OpenLDAP

Hello, I have configured new LDAP and new LDAP clients. When I do "sudo su -", it shows me lot of information, which is not required on screen. I am not sure, if any debug mode is enabled or from where it can be turned off. Please suggest, if it is know for you. -bash-3.2$ sudo su - sudo:... (8 Replies)
Discussion started by: solaris_1977
8 Replies

2. UNIX for Beginners Questions & Answers

I misused: "sudo rm -rf /*"

Hey Guys, I have literally shot my myself in the head... I tried to use "sudo rm -rf /*" in Terminal (OSX); Unfortunately, I forgot cd Desktop. After I realized it, I was like :eek: After that i tried exit; but rm was a background command, so this did not work either... I came to late for... (5 Replies)
Discussion started by: SuchtyTV
5 Replies

3. Shell Programming and Scripting

Explaining behaviour of sudo bash "$0" "$@";

I've found this script part on the stackoverflow: if ; then sudo bash "$0" "$@"; exit "$?"; fi I realized that sudo bash "$0" "$@"; is the only needed for me. But the strange thing happens when I move this line outside the IF statement: sudo bash "$0" "$@"; stops the... (9 Replies)
Discussion started by: boqsc
9 Replies

4. Shell Programming and Scripting

Expect: spawn id exp5 not open while executing "expect "$" { send "sudo su -\r" }"

Hi All, i am trying to ssh to a remote machine and execute certain command to remote machine through script. i am able to ssh but after its getting hung at the promt and after pressing ctrl +d i am gettin the out put as expect: spawn id exp5 not open while executing "expect "$" {... (3 Replies)
Discussion started by: Siddharth shivh
3 Replies

5. UNIX for Dummies Questions & Answers

Do I need to be "Sudo" user for file movement fr

Hi Experts Do I need to have "Sudo" privileges or user for file movement for file movement from one remote server to another or from local to remote server?:wall: (6 Replies)
Discussion started by: parpaa
6 Replies

6. UNIX for Dummies Questions & Answers

security problem with "sudo" for shutdown?

I am a UNIX user but not an admin. I am asking our admins to create a "sudo" command to allow shutting down our AIX workstations gracefully (without just pulling the plug). Is there a way to prevent the user from executing "shutdown" on another workstation or server on the network? (2 Replies)
Discussion started by: kg6iia
2 Replies

7. HP-UX

How to set up "sudo su -" to root with no need to type password?

Tittle has it.... Thanks friends... (2 Replies)
Discussion started by: 300zxmuro
2 Replies

8. Shell Programming and Scripting

sudo dd if=/dev/sdb1 of="disk-image"

sudo dd if=/dev/sdb1 of="disk-image" can anyone explain roughly to me is it this code do some recovery from /dev/sdb then output it to "disk-image" ? But then how can i access the "disk-image"? it cannot be read , and it told me its a binary file... (2 Replies)
Discussion started by: obanajunichiro
2 Replies

9. UNIX for Dummies Questions & Answers

changing password with sudo user " permission denied"

HI All, I am using solaris i created a user adam and updated his permissions in vi sudoers file as follows adam ALL=(ALL) NOPASSWORD: ALL ........... when i create user by logging as sudo user . $ sudo useradd -d /home/kalyan -m -s /bin/sh kalyan sudo: not found ... (6 Replies)
Discussion started by: kalyankalyan
6 Replies

10. UNIX for Dummies Questions & Answers

Possible to give non root user sudo to "crontab -l"

Does anyone know if this is possible? I want to give some users access to root's crontab but only with a read privilege. Is this possible to do or can only root or people with full root sudo view root's cron? (4 Replies)
Discussion started by: LordJezoX
4 Replies
Login or Register to Ask a Question

Featured Tech Videos