Visit Our UNIX and Linux User Community


Arabic characters in QNX4


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Arabic characters in QNX4
# 1  
Old 08-20-2009
Arabic characters in QNX4

I want to display Arabic characters in QNX4.
This work was been done by a colleague several years ago but he didn't document his work.
I installed fonts and I got this display (attached).
Please let me know how can correct as per the initial display were working in Arabic (attached).

Thanks in advance for urgent support.
 

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Regex to identify illegal characters in a perso-arabic database

I am working on Sindhi: a perso-Arabic script and since it shares the Unicode-block with over 400 other languages, quite often the database contains characters which are not wanted: illegal characters. I have identified the character set of Sindhi which is given below: For clarity's sake, each... (8 Replies)
Discussion started by: gimley
8 Replies

2. Shell Programming and Scripting

Writing a clustering concordance for a Perso-Arabic script

I am working on a database of a language using Arabic Script. One of the major issues is that the shape of the characters changes according to their initial, medial or final positioning. Another major issue is that of the clustering of vowels within the word: the clustering changes totally the... (9 Replies)
Discussion started by: gimley
9 Replies

3. Red Hat

Font chinese and arabic

At present we are using one application , in which they are loading some files. the files are some times a mix of chinese and arabic. Is there any way to encode these literals and do the loading. Rgds Rj ---------- Post updated at 04:54 AM ---------- Previous update was at 04:47 AM... (0 Replies)
Discussion started by: jegaraman
0 Replies

4. UNIX for Advanced & Expert Users

[ask]unicode utf-8 for arabic font

hlow all, i want to read arabic font in cli (cat, vi ,etc) in windows i can see the for why in linux i can't see that. this for the example وَمَنْ يَشْكُرْ فَإِنَّمَا يَشْكُرُ لِنَفْسِهِ what should i do ? i need your advice for read that font in cli...:confused: thx before (0 Replies)
Discussion started by: zvtral
0 Replies

5. Shell Programming and Scripting

Arabic encoding using Unix commands

I am using sed on Arabic file (utf-8 encoding) like bellow: sed 's/./& /g' file and all I get is: 1 ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? I tried change the LANG variable to LANG=en_US.UTF-8 but I still get the same "?" output. What is the... (1 Reply)
Discussion started by: Viernes
1 Replies

6. HP-UX

install arabic lang

hi how to install arabic language and set it as default in hpux. also there is any website provide vm for hpunix for testing. (2 Replies)
Discussion started by: drpix
2 Replies

7. Solaris

Arabic package in solaris

Hi, I have searched in all installation cds for arabic packages but couldn't find it. 1. Is there any other way to download arabic package? 2. Does we need to reboot the system after installing package? 3. I don't want to reboot the system so is there any service to restart to make the... (2 Replies)
Discussion started by: malikshahid85
2 Replies

8. Solaris

arabic setting in solaris

Hi, i have a file which show text on window like, insert into test values('اسيل للخدمات عبر الأثير'); but when i open this file in solaris it don't show like insert into test values(' '); i also want to see the line same as it is on windows kindly help me (3 Replies)
Discussion started by: malikshahid85
3 Replies

9. AIX

Generic Printer giving garbage fonts in Arabic

Generic Printer giving garbage fonts in Arabic ! Guy's I have confgured this printer in AIX 6.1 by the following steps ... Smitty Print Spooling AIX Print Spooling Add a Print Queue I Selected from the box this kind hpJetDirect Network Printer (HP JetDirect) then ... (7 Replies)
Discussion started by: ITHelper
7 Replies

10. Solaris

Problem in Sending Arabic message in Unix

I have developed an application in java which sends arabic as well as english messages(SMS). First I deployed the same on windows machine and it sends the messages in both the languages. Due to some performance issue thought of migrating to UNIX. On the unix testing machine, when i tested it out,... (5 Replies)
Discussion started by: jacobkuncheria
5 Replies
PERLQNX(1)						 Perl Programmers Reference Guide						PERLQNX(1)

NAME
README.qnx - Perl version 5 on QNX DESCRIPTION
As of perl5.7.2 all tests pass under: QNX 4.24G Watcom 10.6 with Beta/970211.wcc.update.tar.F socket3r.lib Nov21 1996. As of perl5.8.1 there is at least one test still failing. Some tests may complain under known circumstances. See below and hints/qnx.sh for more information. Under QNX 6.2.0 there are still a few tests which fail. See below and hints/qnx.sh for more information. Required Software for Compiling Perl on QNX4 As with many unix ports, this one depends on a few "standard" unix utilities which are not necessarily standard for QNX4. /bin/sh This is used heavily by Configure and then by perl itself. QNX4's version is fine, but Configure will choke on the 16-bit version, so if you are running QNX 4.22, link /bin/sh to /bin32/ksh ar This is the standard unix library builder. We use wlib. With Watcom 10.6, when wlib is linked as "ar", it behaves like ar and all is fine. Under 9.5, a cover is required. One is included in ../qnx nm This is used (optionally) by configure to list the contents of libraries. I will generate a cover function on the fly in the UU directory. cpp Configure and perl need a way to invoke a C preprocessor. I have created a simple cover for cc which does the right thing. Without this, Configure will create its own wrapper which works, but it doesn't handle some of the command line arguments that perl will throw at it. make You really need GNU make to compile this. GNU make ships by default with QNX 4.23, but you can get it from quics for earlier versions. Outstanding Issues with Perl on QNX4 There is no support for dynamically linked libraries in QNX4. If you wish to compile with the Socket extension, you need to have the TCP/IP toolkit, and you need to make sure that -lsocket locates the correct copy of socket3r.lib. Beware that the Watcom compiler ships with a stub version of socket3r.lib which has very little functionality. Also beware the order in which wlink searches directories for libraries. You may have /usr/lib/socket3r.lib pointing to the correct library, but wlink may pick up /usr/watcom/10.6/usr/lib/socket3r.lib instead. Make sure they both point to the correct library, that is, /usr/tcptk/current/usr/lib/socket3r.lib. The following tests may report errors under QNX4: dist/Cwd/Cwd.t will complain if `pwd` and cwd don't give the same results. cwd calls `fullpath -t`, so if you cd `fullpath -t` before running the test, it will pass. lib/File/Find/taint.t will complain if '.' is in your PATH. The PATH test is triggered because cwd calls `fullpath -t`. ext/IO/lib/IO/t/io_sock.t: Subtests 14 and 22 are skipped due to the fact that the functionality to read back the non-blocking status of a socket is not implemented in QNX's TCP/IP. This has been reported to QNX and it may work with later versions of TCP/IP. t/io/tell.t: Subtest 27 is failing. We are still investigating. QNX auxiliary files The files in the "qnx" directory are: qnx/ar A script that emulates the standard unix archive (aka library) utility. Under Watcom 10.6, ar is linked to wlib and provides the expected interface. With Watcom 9.5, a cover function is required. This one is fairly crude but has proved adequate for compiling perl. qnx/cpp A script that provides C preprocessing functionality. Configure can generate a similar cover, but it doesn't handle all the command- line options that perl throws at it. This might be reasonably placed in /usr/local/bin. Outstanding issues with perl under QNX6 The following tests are still failing for Perl 5.8.1 under QNX 6.2.0: op/sprintf.........................FAILED at test 91 lib/Benchmark......................FAILED at test 26 This is due to a bug in the C library's printf routine. printf("'%e'", 0. ) produces '0.000000e+0', but ANSI requires '0.000000e+00'. QNX has acknowledged the bug. AUTHOR
Norton T. Allen (allen@huarp.harvard.edu) perl v5.14.2 2011-09-26 PERLQNX(1)

Featured Tech Videos