Visit The New, Modern Unix Linux Community


Cronjob not running on Ubuntu 14.04


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Cronjob not running on Ubuntu 14.04
# 1  
Cronjob not running on Ubuntu 14.04

I have created a test cronjob using crontab -e that runs a script at /home/cmccabe/cron.sh. I am not sure the script doesn't run though I can call it in terminal. Thank you Smilie.


crontab -e (run script sat at 6:10pm)?
Code:
10 18 * * 6 /home/cmccabe/cron.sh

contents of cron.sh
Code:
#!/bin/bash
echo "Is it 6:10pm?"

I can see the service is running, but the cronjob does not execute.
Code:
pgrep cron
17707

# 2  
It probably is running.

Code:
#!/bin/bash
echo "Is it 6:10pm?" > /home/mcccabe/somefile.txt

Try that, also when there is output from a cronjob like yours did, that writes to stdout,
output went to email - the email account for you on your linux box.

Other important point: NONE of your environment variables are available to the job run under cron.

#!/bin/bash
source /home/mccabe/.profile # or where you have the process setup code
echo "Is it 6:10pm?" > /path/to/somefile.txt


There are loads of ways to do this, above is just a simple example....
This User Gave Thanks to jim mcnamara For This Post:
# 3  
While I'm at it: quick debug of a crontab entry:
Example:
it is Friday as 22:00pm exactly so set your job for 2 minutes in the future:
create your job with crontab like:
Code:
2 22 * * *  /home/cmccabe/test.sh

wait 3 minutes, check your expected output - email or whatever.
Remove the test cron entry. Wash, rinse, repeat until you have your code working AND you have it running as expected.

Also note the "6" you have in your original entry will be different in different locales. Some places the week starts with Monday, other days, Sunday. So I cannot tell what day you are looking at.

Also check out anacron - allows you to turn off the machine and have jobs run anyway, later at the first chance.
This User Gave Thanks to jim mcnamara For This Post:
# 4  
Thank you very much, I guess i thought it would write to stdout and I would see the terminal displayed. Thanks again Smilie.
# 5  
First i would check in that setup is does the script in question has an execute permission for, at least, user in which cron is set.

Also, script should echo the defined time with day Smilie
Code:
10 18 * * 6 echo "Is it 6:10pm, Saturday, since last number in crontab entry is 6"

This User Gave Thanks to Peasant For This Post:
# 6  
Thank you very much for the helpful tip Smilie, I appreciate it.

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #80
Difficulty: Easy
Many operating systems today, including Android, Chrome OS, Steam OS, and myriad embedded systems for devices, are based on Linux.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Execute Ubuntu 14.04 cronjob as non-root

I have created a cronjob that successfully executes and among other thing runs aria2c to download several files and save them to a folder. However, since it executes as sudo, the downloaded folder is saved with those permissions. Is there a way to execute the cronjob so that the downloaded folder... (4 Replies)
Discussion started by: cmccabe
4 Replies

2. UNIX for Dummies Questions & Answers

Facing issues while running a cronjob !

Hi, I am trying to run a cronjob. But while doing so I am getting the following error message :- can't open yourfile in /var/spool/cron/crontabs directory. No such file or directory How can I resolve this issue ? Please help. Thanks Please view this code tag video for... (14 Replies)
Discussion started by: acidburn_007
14 Replies

3. Shell Programming and Scripting

My Cronjob is not running

I created a script, size=`du -sm` size=`echo $size | sed 's/.$//'` size1='30720' if then { find /ask/tarballs -type f -name "*.tgz" -mtime +30 -exec ls -l {} \; find /ask/tarballs -type f -name "*.tgz" -mtime +30 -exec rm -f {} \; } else echo "Directory size doesnt exceed Threshold... (12 Replies)
Discussion started by: shaal89
12 Replies

4. UNIX for Dummies Questions & Answers

Script not running through Cronjob

Hi, I have a .ksh script which updates the database. The script is running fine manually but it is not running through cron.All the file permissions are fine. The script contents are as below: #!/usr/bin/ksh ddate=`date +%Y%m%d` echo $ddate nohup sqlplus crm/crm @db_state_sync.sql >>... (3 Replies)
Discussion started by: shivangi
3 Replies

5. Shell Programming and Scripting

How to execute cronjob running in a different machine?

Hi, I am developing 1 script in which I need to execute one cron job running in different server and my script is in different server. so can any one help me to execute the cronjob set in different server. Thanks in advance. (1 Reply)
Discussion started by: mridul10_crj
1 Replies

6. Shell Programming and Scripting

Cronjob not running

Hi, having problem running my cronjob, need the script to run every monday. And the error i'm getting is "No such file or directory", i've tried to change the env to /bin/bash and also /usr/bin/sh but both failed. Need help here. tq 0 0 * * 1 /bin/bash /home/omc/munir/raccli_rnc.sh Rgds... (3 Replies)
Discussion started by: adawiyah29
3 Replies

7. UNIX for Dummies Questions & Answers

how to cancel a cronjob if the cronjob still running

hi everyone I'm newbie in this forum hope I can get some help here :) I have a command in crontab that executed every 1 minute sometime this command need more than 1 minute to finish the problem is, the crontab execute this command although it's not finish processing yet and causing the system... (7 Replies)
Discussion started by: 2j4h
7 Replies

8. UNIX for Advanced & Expert Users

SYS CRONJOB just not running...

I'm trying to run "SAR -i 60" under #/var/spool/cron/crontabs/SYS 0,10,20,30,40,50 0-6 sh -c "/usr/lib/sa/sa1 60 10 &" 55 23 * 0-6 /usr/lib/sa/sa2 -i 900 -A machine is not running above cron job under "sys" at all. This suppose to run every minutes and all time in 24 hours. When day... (6 Replies)
Discussion started by: deal732
6 Replies

9. Shell Programming and Scripting

Running scripts through cronjob.

Hello everybody, I'm trying to run a shell script in crontab file. But anyhow it's not getting executed. Following is the command that I've used in crontab. 30 07 * * * . ./.cronprofile;/om/reports/reportscripts/jitu/prod/prd_pre_to_post.sh 35 11 * * * .... (3 Replies)
Discussion started by: jitu.jk
3 Replies

10. UNIX for Advanced & Expert Users

Cronjob is not running

hi, I have a shell script which has a sql plus code and unix if else condition. The file is located at root.I logged in as a root user and i have all permissions. I tried to set up a cron job so that the script need to run every minute.the script is running successfully without any problem. I... (2 Replies)
Discussion started by: sanei05
2 Replies

Featured Tech Videos