Unix/Linux Go Back    


UNIX for Advanced & Expert Users Expert-to-Expert. Learn advanced UNIX, UNIX commands, Linux, Operating Systems, System Administration, Programming, Shell, Shell Scripts, Solaris, Linux, HP-UX, AIX, OS X, BSD.

Need help installing Puppet and Ruby..

UNIX for Advanced & Expert Users


Closed    
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 05-01-2013   -   Original Discussion by samnyc
samnyc's Unix or Linux Image
samnyc samnyc is offline
Registered User
 
Join Date: Jan 2009
Last Activity: 2 February 2017, 11:53 PM EST
Posts: 234
Thanks: 69
Thanked 3 Times in 3 Posts
Need help installing Puppet and Ruby..

Hi,

I am working on RHEL 5.6 server, this is in private DMZ. No access to internet. I have downloaded the files I need to install the Puppet & Ruby. My goal is to install Puppet. I have downloaded....



Code:
mcollective-2.2.3-1.el5.noarch- SERVER.rpm        
mcollective-client-2.2.3-1.el5.noarch-CLIENT.rpm  
mcollective-common-2.2.3-1.el5.noarch.rpm

when I start the install. I get this error message.


Code:
 
 
rpm -ivh mcollective-common-2.2.3-1.el5.noarch.rpm
warning: mcollective-common-2.2.3-1.el5.noarch.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 4bd6ec30
error: Failed dependencies:
        ruby is needed by mcollective-common-2.2.3-1.el5.noarch
        ruby(abi) >= 1.8 is needed by mcollective-common-2.2.3-1.el5.noarch
        rubygem(stomp) is needed by mcollective-common-2.2.3-1.el5.noarch
        rubygems is needed by mcollective-common-2.2.3-1.el5.noarch

I did install ruby on this server. When I do ruby -v, I get this...


Code:
ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]


Please help.
Sponsored Links
    #2  
Old Unix and Linux 06-16-2013   -   Original Discussion by samnyc
Just Ice's Unix or Linux Image
Just Ice Just Ice is offline Forum Advisor  
Lights on, brain off.
 
Join Date: Mar 2005
Last Activity: 18 October 2016, 12:06 PM EDT
Location: Philadelphia metro
Posts: 961
Thanks: 3
Thanked 67 Times in 61 Posts
if this is still an issue ...

some packages require or expect pre-requisite packages to be in certain paths or be verifiable thru certain utilities (i.e., pkginfo, yum, etc.). i am thinking your issue is that your ruby package came from a different source as your puppet package so the puppet install could not find it during the pre-install checks. you either need to install a ruby package from the same source as the puppet package or you need to fix the path to ruby so puppet finds it. symlinks may help if you go through with the path fix.
Sponsored Links
    #3  
Old Unix and Linux 06-17-2013   -   Original Discussion by samnyc
glev2005's Unix or Linux Image
glev2005 glev2005 is offline
Registered User
 
Join Date: Oct 2008
Last Activity: 19 July 2014, 10:56 PM EDT
Posts: 276
Thanks: 20
Thanked 6 Times in 6 Posts
Puppet only supports some Ruby versions, see here https://ask.puppetlabs.com/question/...error-message/
Sponsored Links
Closed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Help installling puppet samnyc UNIX for Dummies Questions & Answers 2 02-12-2013 03:56 PM



All times are GMT -4. The time now is 04:04 PM.