Today (Saturday) We will make some minor tuning adjustments to MySQL.

You may experience 2 up to 10 seconds "glitch time" when we restart MySQL. We expect to make these adjustments around 1AM Eastern Daylight Saving Time (EDT) US.


Ubuntu 16.04 doesn't detect my second monitor


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Ubuntu 16.04 doesn't detect my second monitor

I have Ubuntu 16.04 (dual boot with Windows 10) and a HP Spectre x360 laptop.

I have recently bought a Dell Ultrasharp U2515H monitor, which I connect via a Dell docking station.

When I plug the docking station to my laptop on Windows, both monitors are detected and everything works fine.

The monitor connect to the docking station using a DP cable, and then a SuperSpeed USB 3.0 Type A to B Cable connects the docking station to my laptop.

When I try with Ubuntu, it seems that the second monitor is not detected even when I click "Detect Displays" - I just see my one built in monitor. I think I correctly downloaded the drivers for the Dell docking station, because the external mouse, keyboard and ethernet connection all seem to be working correctly.

Any help to get Ubuntu to detect my second monitor would be much appreciated. The results of lsusb are posted below:

Code:
Bus 002 Device 005: ID 17e9:436e DisplayLink
Bus 002 Device 004: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 003: ID 17e9:436e DisplayLink
Bus 002 Device 002: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 010: ID 04f3:2274 Elan Microelectronics Corp.
Bus 001 Device 005: ID 8087:0a2a Intel Corp.
Bus 001 Device 003: ID 1bcf:2c8c Sunplus Innovation Technology Inc.
Bus 001 Device 009: ID 413c:2110 Dell Computer Corp.
Bus 001 Device 008: ID 413c:301a Dell Computer Corp.
Bus 001 Device 006: ID 413c:1010 Dell Computer Corp.
Bus 001 Device 004: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 002: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



Moderator's Comments:
Mod Comment Please use CODE tags as required by forum rules!

Last edited by RudiC; 09-28-2016 at 02:37 PM.. Reason: Added CODE tags.
# 2  
lsusb is not going to list your monitor, or even your video card, only usb things hence lsusb. Try lspci.

What's your video chipset, and what video driver are you using?

Laptop hardware is the worst, everything is customized in a manner plug-and-play often can't detect. The manufacturer's official Windows drivers come pre-tweaked for it, anything else may take tweaking to be told what features the hardware has.
This User Gave Thanks to Corona688 For This Post:
# 3  
Wait, your docking station connects with USB? What docking station is this?

It's probably acting as a USB hub, hence recognizing the USB mice etc, but those 'Dell Computer Corp' devices aren't necessarily recognized.
This User Gave Thanks to Corona688 For This Post:
# 4  
The lspci output:

Code:
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
00:13.0 Non-VGA unclassified device: Intel Corporation Device 9d35 (rev 21)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Device 9d12 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)

---------- Post updated at 01:12 PM ---------- Previous update was at 01:10 PM ----------

The docking station is a Dell D3100 Docking Station.


Moderator's Comments:
Mod Comment Please use CODE tags as required by forum rules!

Last edited by RudiC; 09-28-2016 at 02:40 PM.. Reason: Added CODE tags.
# 6  
As I mentioned, I believe that I have already downloaded and installed the DisplayLink driver for Ubuntu. Perhaps the outputs that I showed say otherwise? I'm not sure how to test.
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
[KornShell]: Why getopts doesn't detect disabled switches in this script?
dariyoosh
Hi, My environement OS: Linux Fedora Core 17 X86_64 KSH version: sh (AT&T Research) 93u+ 2012-08-01 As I understand inside a Kornshell script, the getopts statement allows to collect information about the switches provided for the script (if any). Besides, it is possible to...... Shell Programming and Scripting
3
Shell Programming and Scripting
AIX doesn't detect TS3200 tape library
h@foorsa.biz
Hi all, I have a problem here root@host1 / # lsdev -Cc tape rmt0 Defined 07-00-02 IBM 3580 Ultrium Tape Drive (FCP) rmt1 Defined 07-00-02 IBM 3580 Ultrium Tape Drive (FCP) smc0 Defined 07-00-02 IBM 3573 Tape Medium Changer (FCP) root@host1 / # cfgmgr -l fcs2 Method error...... AIX
2
AIX
AIX doesn't detect smc1 media changer in ts3200 tape library
h@foorsa.biz
Hi all, I'm having a problem here my environment as follows. AIX 5.3 TL 10 running on a P6 p520 sever with 3 fibre channel cards and Tivoli Storage Manager TSM 5.4 and TS3200 Tape Library with 2 drives and 2 media changers. My problem as follows smc1 doesn't show up , I ran cfgmgr multiple...... AIX
6
AIX
Microphone doesn't work in Ubuntu 10.04
i2000s
When I try to speak to the microphone, there is no echo in the speaker. I test it again by dialing Skype, there is still no sound in my side while I can hear the other side. What can I do? Thanks in advance!... Ubuntu
4
Ubuntu
Why getopts doesn't detect correctly my switches?
dariyoosh
Dear all, I have created a KornShell script containing swiches with getopts (command line switches). Normally, my script should work like this: $ ./myscript.ksh -a 12 -b 4 -c 78 The switch a was selected with the argument 12 The switch b was selected with the argument 4 The switch c was...... Shell Programming and Scripting
3
Shell Programming and Scripting

Featured Tech Videos