Visit Our UNIX and Linux User Community


Installation of older version of rsyslog


 
Thread Tools Search this Thread
Operating Systems Linux Ubuntu Installation of older version of rsyslog
# 1  
Old 01-16-2013
Installation of older version of rsyslog

Hi,

I am trying to downgrade the version of rsyslog to the older version (i.e)
Quote:
1.19.12-1
and when i issue the below command to check the packages i dont see the required package (i.e)
Quote:
1.19.12-1
Quote:
sudo apt-cache showpkg rsyslog
Package: rsyslog
Versions:
4.2.0-2ubuntu8.1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid-updates_main_binary-i386_Packages) (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid-updates_main_binary-i386_Packages
MD5: d94b58ff2be5888c5b465281d17e5d27

4.2.0-2ubuntu8 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages
MD5: d94b58ff2be5888c5b465281d17e5d27


Reverse Depends:
rsyslog-relp,rsyslog 4.2.0-2ubuntu8.1
rsyslog-pgsql,rsyslog 4.2.0-2ubuntu8.1
rsyslog-mysql,rsyslog 4.2.0-2ubuntu8.1
rsyslog-gssapi,rsyslog 4.2.0-2ubuntu8.1
rsyslog-gnutls,rsyslog 4.2.0-2ubuntu8.1
request-tracker3.8,rsyslog
ldirectord,rsyslog
rsyslog-doc,rsyslog 2.0.1-2
rsyslog-doc,rsyslog 2.0.1-2
logcheck,rsyslog
initscripts,rsyslog 4.2.0-2ubuntu3~boot1
zoneminder,rsyslog
xwatch,rsyslog
snort-pgsql,rsyslog
snort-mysql,rsyslog
snort,rsyslog
rsyslog-relp,rsyslog 4.2.0-2ubuntu8
rsyslog-pgsql,rsyslog 4.2.0-2ubuntu8
rsyslog-mysql,rsyslog 4.2.0-2ubuntu8
rsyslog-gssapi,rsyslog 4.2.0-2ubuntu8
rsyslog-gnutls,rsyslog 4.2.0-2ubuntu8
request-tracker3.8,rsyslog
psad,rsyslog
ldirectord,rsyslog
heartbeat,rsyslog
fwlogwatch,rsyslog
auth2db,rsyslog
ufw,rsyslog
ubuntu-minimal,rsyslog
rsyslog-doc,rsyslog 2.0.1-2
rsyslog-doc,rsyslog 2.0.1-2
logcheck,rsyslog
initscripts,rsyslog 4.2.0-2ubuntu3~boot1
Dependencies:
4.2.0-2ubuntu8.1 - libc6 (2 2.4) zlib1g (2 1:1.1.4) upstart-job (0 (null)) lsb-base (2 3.2-14) adduser (0 (null)) ucf (2 0.8) rsyslog-mysql (16 (null)) rsyslog-pgsql (0 (null)) rsyslog-doc (0 (null)) rsyslog-gnutls (0 (null)) rsyslog-gssapi (0 (null)) rsyslog-relp (0 (null)) logrotate (0 (null)) linux-kernel-log-daemon (0 (null)) system-log-daemon (0 (null))
4.2.0-2ubuntu8 - libc6 (2 2.4) zlib1g (2 1:1.1.4) upstart-job (0 (null)) lsb-base (2 3.2-14) adduser (0 (null)) ucf (2 0.8) rsyslog-mysql (16 (null)) rsyslog-pgsql (0 (null)) rsyslog-doc (0 (null)) rsyslog-gnutls (0 (null)) rsyslog-gssapi (0 (null)) rsyslog-relp (0 (null)) logrotate (0 (null)) linux-kernel-log-daemon (0 (null)) system-log-daemon (0 (null))
Provides:
4.2.0-2ubuntu8.1 - system-log-daemon linux-kernel-log-daemon
4.2.0-2ubuntu8 - system-log-daemon linux-kernel-log-daemon
Reverse Provides:
and when i try to install it is complaining about package not found.

Quote:
apt-get install rsyslog=1.19.12-1
Please advise on how to install the required older version.

Below is the uname output

Quote:
uname -a
Linux myserver01 2.6.32-38-generic-pae #83-Ubuntu SMP Wed Jan 4 12:11:13 UTC 2012 i686 GNU/Linux
# 2  
Old 01-18-2013
Did you try apt-get remove on the existing version?

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

How to install older package version on Ubuntu 18.04?

Hello, I'm running Ubuntu 18.04 and I would like to install libboost-python version 1.46. Currently I have installed version 1.65: wakatana@local-machine:~$ dpkg -l | grep libboost-python ii libboost-python-dev 1.65.1.0ubuntu1 amd64 ... (1 Reply)
Discussion started by: wakatana
1 Replies

2. Solaris

Global zone has an older version of package: pkg://Solaris/system/library

I try to install php-56 in a zone, but I have the following problem: pkg install php-56 Creating Plan (Running solver): \ pkg install: No solution was found to satisfy constraints maintained incorporations: None Creation Plan: dependency error (s) in proposed packages: Not... (0 Replies)
Discussion started by: ymk369
0 Replies

3. Shell Programming and Scripting

Invalid Java installation: No version could be obtained

Hi , i am in mid of upgrading one of the java based application which requires higher version of java 1.8 from java 1.6, I have updated bash_profile and required environment variable correctly but still application unable to obtain the required version of java 1.8. here is my environment detail... (2 Replies)
Discussion started by: Riverstone
2 Replies

4. Debian

Which older version and variant ISO image should I use?

Which older version and variant of Debian Linux ISO image should I use? I attempted to install two versions of Debian Linux Operating System onto my older full tower computer. First version, V8.5.0, Amd64, xfce, 32Bit. Second version V7.11.0, i386, 32Bit. When trying to install... (1 Reply)
Discussion started by: Jefferyab6
1 Replies

5. Shell Programming and Scripting

Removing older version files

Hi, I have a direcory as mentioned below: /development/arun/cycdt/ unser the above i have directories /2013 /2012 /2011 ...... ..... /2000 I need to write a script which can delete the nth version of the directories. as in if n=10 then the script should arrange the directories in... (2 Replies)
Discussion started by: Arun Mishra
2 Replies

6. Shell Programming and Scripting

For loop in older version of ksh

When I am trying to use below code of for loop on older version of ksh it not working,and I just want to use only FOR loop ----------------- for i in (1..5) do echo $i done ----------------- please suggest.it really stoping me. FYI: i want to do this only by for loop (2 Replies)
Discussion started by: RahulJoshi
2 Replies

7. UNIX for Advanced & Expert Users

Why Samba is still pointing to old version after installation

Hallo, I am new to administer a Unix machine. Basically I have just upgrade the samba version from 2.2.8a up to 3.0.22 on Sol 9 SV210. the installation was successful. but then when I checked the version by using /usr/sfw/bin/smbstatus it was still showing 2.2.8a. I've restarted samba... (1 Reply)
Discussion started by: Luky
1 Replies

8. UNIX for Dummies Questions & Answers

.profile has been replaced and need to get the older version

Hi All, .profile has been replaced with a new one. I need to know the variables used in the older version of .profile. I have a session opened using the old .profile. Is there a way that I can get the exact file. I had some luck by using set command. But is there any way that I can get the... (5 Replies)
Discussion started by: shash
5 Replies

9. Shell Programming and Scripting

newer version of the parser installed,yet get the older one itlself,hows it possible?

Hi all, I downloaded a XML parser lib from blastwave.org... Its the "libxml2",but i am having trouble initializing it(or so it feels)...I kind of need it badly as the OSE version of the virtualbox 1.6.2 will not install unless i have one The version was 2.6.3... The min requirement from... (0 Replies)
Discussion started by: wrapster
0 Replies

10. UNIX for Advanced & Expert Users

Need older version of System Firmware for 7026-H80

Hi all, I have an H80 that I'm migrating to 5.3 and prior to doing so it needed the firmware upgraded. I don't have copies of the old firmware that was on it since I was not the one who installed it and there were no copies to be found on the server itself. I installed the latest version and... (4 Replies)
Discussion started by: howardle
4 Replies

Featured Tech Videos