HEXDUMP(9)						   BSD Kernel Developer's Manual						HEXDUMP(9)

NAME
hexdump -- dump a block of bytes to the console in hexadecimal form SYNOPSIS
#include <sys/systm.h> void hexdump(void *ptr, int length, const char *hdr, int flags); DESCRIPTION
The hexdump() function prints an array of bytes to the console in hexadecimal form, along with the ASCII representation of the bytes, if pos- sible. By default, each line of output will start with an offset count, followed by 16 hexadecimal values, followed by 16 ASCII characters. ptr Pointer to the array of bytes to print. It does not need to be NUL-terminated. length Number of bytes to print. hdr Pointer to a NUL-terminated character string that will be prepended to each line of output. A value of NULL implies that no header will be printed. flags Flags for controlling the formatting of the output. Bits 0-7 Integer value of the number of bytes to display on each line. A value of 0 implies that the default value of 16 will be used. Bits 8-15 Character ASCII value to use as the separator for the hexadecimal output. A value of 0 implies that the default value of 32 (ASCII space) will be used. HD_OMIT_COUNT Do not print the offset column at the beginning of each line. HD_OMIT_HEX Do not print the hexadecimal values on each line. HD_OMIT_CHARS Do not print the character values on each line. SEE ALSO
ascii(7) AUTHORS
This manual page was written by Scott Long. BSD
December 7, 2003 BSD