Visit Our UNIX and Linux User Community


How to get RPM Dependencies/libs

 
Thread Tools Search this Thread
Operating Systems Linux SuSE How to get RPM Dependencies/libs
# 1  
Old 02-17-2011
How to get RPM Dependencies/libs

Hi All,
I wanted to install an rpm package on two suse 10 systems. It installed successfully on one system but on the other it throws an error like

Code:
error: Failed dependencies:
        rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by linuxProj-1-1.noarch

Now this means that rpnm package has no error but the rpm in itself is lacking some libs. So can anyone tell me that how can I download and add these libs to the already installed rpm.

Note the difference between rpm and rpm package.
# 2  
Old 02-17-2011
It's not lacking libs, it's on a newer update state than the other system (note the "less than" requirement).
This User Gave Thanks to pludi For This Post:
# 3  
Old 02-17-2011
So can you tell me how to avoid this? Because I will be packaging rpm on one system and will be going to install it on many others. Being a package manager I dont know if my rpm is older than the others or not.
# 4  
Old 02-17-2011
I'm not quite sure (been a while), but the best bet would be to create the package on a system that has an older patch level than the others. That way you can avoid creating RPMs that depend on features that not all systems might have.

I usually did all my packaging in a VM that was deliberately left on the original release version of a distribution.
# 5  
Old 04-14-2011
try to setup the yum repo on ur suse box
then try read below pages for config yum on ur local
-http://liquidat.wordpress.com/2005/10/16/setting-up-yum-on-suse-linux-100-3/

Previous Thread | Next Thread
Test Your Knowledge in Computers #98
Difficulty: Easy
Unix was the first operating system that was written in a high-level programming language (C Language).
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Create shared libs on AIX (with certain libs which are statically linked)

I want to create a shared lib with certain libs statically linked to it. I can generate a fully shared lib as follows: gcc -maix64 -DHAVE_CONFIG_H -I. -I./src -DHAVE_OPENSSL -I/usr/include/openssl -I/usr/include -I/usr/include/apr-1 -D_LARGEFILE64_SOURCE -I/usr/java8_64/include -shared -o... (0 Replies)
Discussion started by: amandeepgautam
0 Replies

2. Red Hat

RPM failed dependencies

I'm trying to package the latest Oracle JDK (1.7.0_51) into an RPM. Packaging works fine but when i try to install via rpm -Uvh xxx.rpm, i get the following: #sudo rpm -ivh Sun_JDK7-1.7.0-51.x86_64.rpm error: Failed dependencies: libavcodec.so.52()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64... (3 Replies)
Discussion started by: asc123321
3 Replies

3. AIX

Rpm issue with autoconf-2.63-1.AIX6.1.noarch.rpm

dears i am trying to install the autoconf-2.63-1.aix6.1.noarch.rpm but its shows the below error message . P700_dev/svn/dependencies>rpm -i autoconf-2.63-1.aix6.1.noarch.rpm error: failed dependencies: m4 is needed by autoconf-2.63-1 P700_dev/svn/dependencies> (6 Replies)
Discussion started by: thecobra151
6 Replies

4. SuSE

RPM implicit dependencies

Hi, I'm having issues with implicit dependencies for my RPM package. This is the error I'm getting: error: Failed dependencies: libclntsh.so.11.1()(64bit) is needed by geomatica-10.4-0.x86_64 Our software has a dynamically loaded library which links to the Oracle's libclntsh.so.11.1... (2 Replies)
Discussion started by: pneveu
2 Replies

5. Shell Programming and Scripting

How to make RPM not write to RPM database if RPM fails to deploy?

How to make RPM not write to RPM database if RPM fails to deploy? IE I create an rpm spec file that contains the following if then exit 1 fi My rpm will fail at deployment, but if I do rpm -qa , I can see the rpm in the rpm db (3 Replies)
Discussion started by: 3junior
3 Replies

6. Red Hat

RPM dependencies fail

Hello, I am trying to install krb5-libs-1.4-4.pp-rh73.i386.rpm on my Red Hat 7.X server, however while installing/upgrading it fails due to dependencies. I checked for these dependencies and i already found them on the server. I wonder why it is giving these errors. I tried copying these... (1 Reply)
Discussion started by: sunny_a_j
1 Replies

7. Shell Programming and Scripting

Extract RPM name from path to .rpm file

It's the end of the day and I just can't get my head around this. I'm trying to extract just the name of the RPM from the path to a .rpm file. So from: /home/me/rpm/RPMS/i386/nagios-our-plugins-1.2-6.i386.rpmI need to extract 'nagios-our-plugins'. I can't get the awk syntax right: awk '{... (5 Replies)
Discussion started by: aussieos
5 Replies

8. Red Hat

RPM and dependencies OPENSSH

Hello Sorry, I am not to well versed in RHE and I am having some issues. I have doen a cursury look around and could not find an answer. I have 2 RHE4 servers. Both have old versions of OPENSSH along with , server, askpass, askpass-gnome, etc. I cannot upgrade to our new pkg release of... (8 Replies)
Discussion started by: mhenryj
8 Replies

9. Linux

Converting source rpm to binary rpm

Hi, I need to install an rpm file,but I only have '.src.rpm' version of it. I want to convert it to a binary rpm. so I tried this rpm --rebuild somethin.src.rpm But I am gettin '--rebuild:Invalid option' as output Is there another way to rebuild source rpm.? Thanks in... (2 Replies)
Discussion started by: eamani_sun
2 Replies

10. Linux

Failed dependencies of rpm / how does RPM check for ?

Hey, I've a problem installing a package. rpm -ivh brings the errors: libjvm.so is needed by libverify.so is needed by But I have installed the Java SDK like requested and the files are on the disk. But I have no idea how to find out, why rpm cann't find them. I have also... (2 Replies)
Discussion started by: mod
2 Replies

Featured Tech Videos