External Network Connectivity w/Oracle VM Server for SPARC & Solaris 11


 
Thread Tools Search this Thread
Operating Systems Solaris External Network Connectivity w/Oracle VM Server for SPARC & Solaris 11
# 1  
Old 07-18-2014
External Network Connectivity w/Oracle VM Server for SPARC & Solaris 11

Hello all, thanks for reading my question:

So I've been a Unix/Linux SysAdmin for a couple years, and I'm a bit over my head running solo, trying to set up LDoms using Oracle VM Server 3.1 for SPARC. I've been very careful, and things have gone well up until the point I try to access the new virtual machines from the regular network.

I found the section in the Oracle VM Server 3.1 for SPARC Administration Manual that talks about enabling external connectivity, however it's very vague, and provides no examples. (it won't let me post a link to it from here yet - sorry) I did my best to follow the instructions, but I'm having zero luck getting from the virtual machine to the rest of my network and vice versa.

Can anyone help with where I can find an example of getting this to work? I feel like I've looked everywhere. Everything I've tried isn't working. Here's what I have so far:

1) I have the physical machine (primary domain) connected just fine to my network, no issues connecting, etc. The primary physical NIC is setup on net0. It has an IP address.

2) I created an etherstub (stub0) exactly as mentioned in step 1 of the manual

3) I created a virtual switch (primary-stub-vsw0) on the etherstub (exactly as depicted in step 2)

4) I created a virtual NIC (vnic0) on the etherstub (exactly like step 3)

5) I configured vnic0 and gave it a private IP address not in use anywhere on my network (similar to step 4, but I used 192.168.3.2 for the IP)

ipadm shows the following:
Code:
NAME              CLASS/TYPE STATE        UNDER      ADDR
lo0               loopback   ok           --         --
   lo0/v4         static     ok           --         127.0.0.1/8
   lo0/v6         static     ok           --         ::1/128
net0              ip         ok           --         --
   net0/v4        static     ok           --         10.12.20.86/24
net1              ip         down         --         --
net2              ip         down         --         --
net3              ip         down         --         --
vnic0             ip         ok           --         --
   vnic0/v4       static     ok           --         192.168.3.2/24

dladm shows the following:
Code:
net1                phys      1500   up       --
net2                phys      1500   up       --
net3                phys      1500   up       --
net0                phys      1500   up       --
net5                phys      1500   up       --
stub0               etherstub 1500   unknown  --
vnic0               vnic      1500   up       stub0
ldoms-vsw1.vport0   vnic      1500   up       stub0

and the network sections of ldm list-bindings shows:
Code:
NAME             STATE      FLAGS   CONS    VCPU  MEMORY   UTIL  UPTIME
primary          active     -n-cv-  SP      2     8G       0.7%  31d 2h 22m
...
VSW
    NAME             MAC               NET-DEV   ID   DEVICE     LINKPROP   DEFAULT-VLAN-ID PVID VID                  MTU   MODE   INTER-VNET-LINK
    primary-stub-vsw0 00:14:4f:fb:c9:5b stub0     1    switch@1              1               1                         1500         on
        PEER                        MAC               PVID VID                  MTU   MAXBW      LINKPROP   INTERVNETLINK
        vnet0@test1                 00:14:4f:fa:c6:d1 1                         1500

------------------------------------------------------------------------------
NAME             STATE      FLAGS   CONS    VCPU  MEMORY   UTIL  UPTIME
test1            active     -n----  5000    8     8G       0.1%  7d 21h 10m
...
NETWORK
    NAME             SERVICE                     ID   DEVICE     MAC               MODE   PVID VID                  MTU   MAXBW      LINKPROP
    vnet0            primary-stub-vsw0@primary   1    network@1  00:14:4f:fa:c6:d1        1                         1500
        PEER                        MAC               MODE   PVID VID                  MTU   MAXBW      LINKPROP
        primary-stub-vsw0@primary   00:14:4f:fb:c9:5b        1                         1500

6) I turned on packet forwarding globally. Results of ipadm show-prop -p forwarding ip:
Code:
PROTO PROPERTY              PERM CURRENT      PERSISTENT   DEFAULT      POSSIBLE
ipv4  forwarding            rw   on           on           off          on,off
ipv6  forwarding            rw   off          --           off          on,off

7) I set up some NAT rules to forward all packets from the vnic0 to net0. Content of /etc/ipf/ipnat.conf:
Code:
map vnic0 192.168.3.0/24 -> 0/32 portmap tcp/udp auto
map vnic0 192.168.3.0/24 -> 0/32

...and output of ipnat -l:

Code:
List of active MAP/Redirect filters:
map net0 192.168.3.0/24 -> 0.0.0.0/32 portmap tcp/udp auto
map net0 192.168.3.0/24 -> 0.0.0.0/32

List of active sessions:

8) on my LDom (test1), I set up the NIC and gave it an IP address in the schema of our network. Output of ipadm on the LDom is as follows:
Code:
NAME              CLASS/TYPE STATE        UNDER      ADDR
lo0               loopback   ok           --         --
   lo0/v4         static     ok           --         127.0.0.1/8
   lo0/v6         static     ok           --         ::1/128
net0              ip         ok           --         --
   net0/v4        static     ok           --         10.10.20.178/24

dladm shows:
Code:
LINK                CLASS     MTU    STATE    OVER
net0                phys      1500   up       --

9) I setup a default route on the LDom with route -p add default 10.12.20.1
netstat -nr shows:
Code:
Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface
-------------------- -------------------- ----- ----- ---------- ---------
default              10.10.20.1           UG        2       3122
10.10.20.0           10.10.20.178         U         3         11 net0
127.0.0.1            127.0.0.1            UH        2         83 lo0

Routing Table: IPv6
  Destination/Mask            Gateway                   Flags Ref   Use    If
--------------------------- --------------------------- ----- --- ------- -----
::1                         ::1                         UH      2       0 lo0

...but despite all this, I can't go anywhere or do anything. I can't ping the primary domain from the LDOM, I can't ping the LDOM from the primary domain, etc.

Does anyone have any insight? I would greatly appreciate the assist. Been stuck at this spot for over a week now.

Thanks in advance!

-Lyxix

Last edited by Corona688; 08-12-2014 at 05:41 PM..
# 2  
Old 07-18-2014
Wow!! Firstly, thanks for providing comprehensive information; it's usually what's missing from complex issues on the forums. So 10 out of 10 for that.

The first thing that comes to mind is that Solaris 11 is a world away from Solaris 10 (and earlier) with regard to network setup. So are you sure that the documentation that you've been following is for Solaris 11?

I'll take time to study the information you've posted.

Meantime some reading:

http://www.alekz.net/archives/449


Post back any progress (or lack of).
# 3  
Old 07-21-2014
Definitely Solaris 11

hicksd8,

Thanks for the reply. The documentation from Oracle is very specific as to what steps apply to Sol11, and which apply to Sol10. I have definitely been following the Sol11 steps. My steps include the use of ipadm and dladm, which are exclusive to Sol11. Thanks for the suggestion, though. I hope you get a chance to study my issue and can provide some insight. I'm definitely stuck - no idea what else to try.

Thanks!

-Lyxix
# 4  
Old 07-21-2014
I've had a good look through you post but I admit that I am confused.

Your primary domain (physical machine) works fine you say.

How many VM's have you created?

Have you designed your virtual network interfaces to these VM's?

Can you please explain what the 3 subnets 10.12.20, 10.10.20 and 192.168.3 are?
# 5  
Old 07-21-2014
There's only 1 VM right now, I simply named it "test". I have to get the test working before I start virtualizing my old systems.

Steps 8 and 9 refer to the setting up of the virtual network on the "test" LDom.

10.12.20 and 10.10.20 are both subnets on our internal network. 192.168.3 is a subnet I used for the Virtual NIC on the primary domain because the manual said to use a private subnet that is not in use anywhere else on the network. That is not in use anywhere else on the network. I just picked the first IP (didn't want to use .1 because that would theoretically be for a router I imagine - my networking skills are limited).

Does that answer your questions? My guess is I don't understand something with the subnets or IP's or whatnot and that's the problem, but I have no idea what. If I didn't put it in my steps, I probably didn't do it.

Thanks again!

-Lyxix
# 6  
Old 08-12-2014
Still no luck...

Haven't made any progress, unfortunately. Does anybody have any ideas that can help out? I'm not sure why this is so difficult, but I'm not having any luck.

Thanks!
# 7  
Old 08-13-2014
Really sorry to hear that you're not making any progress.


A link to a Hands On Lab video which, if you have a spare machine, I suggest that you copy in it's entirety.
Hands on Lab - Oracle Solaris 11 Networking and Virtualization - YouTube
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Red Hat

Migrating Oracle on Solaris Sparc to Linux RHEL 7 VM

Hi Gurus, We are migrating Oracle from Solaris to RHEL 7 and looking for Solaris equivalent commands for Linux. we are using lot of korn shell scripts built on Solaris so, i am looking for equivalent commands which are using in Solaris.. Could you please help me here by proving any info ... (4 Replies)
Discussion started by: mssprince
4 Replies

2. Shell Programming and Scripting

Migrating Oracle on Solaris Sparc to Linux RHEL 7 VM

Hi Gurus, We are migrating Oracle from Solaris to RHEL 7 and looking for Solaris equivalent commands for Linux. we are using lot of korn shell scripts built on Solaris so, i am looking for equivalent commands which are using in Solaris.. Could you please help me here by proving any info... (1 Reply)
Discussion started by: mssprince
1 Replies

3. Shell Programming and Scripting

Help with shell script to check the tcp network connectivity between server

Hello, I have a requirement to check the tcp network connectivity between server it's running on and the list of host's and ports combination. i have written the below code but it doesn't work, but when i execute the nc command outside the script it works fine. please help me where i am... (8 Replies)
Discussion started by: sknovice
8 Replies

4. Solaris

What are Solaris 9 & 10 Sparc Editions worth?

My Sparc servers disappeared in my last move. I found my Sparc software in the basement yesterday, Solaris 9 9/04 Operating Environment, Java Enterprise System, Accessory Software, and License are all sealed, box is opened. Also have Solaris 10 but in opened sleeves with Sun Office for Sparc. ... (2 Replies)
Discussion started by: FatGeek
2 Replies

5. UNIX for Dummies Questions & Answers

External Network Adapter for Solaris 10

Hi All, I am new here - this is my first post. I have installed Solaris 10 5/09 on my Dell M6300. The install went well, but the Dell's onboard network card is the Broadcom BCM5756ME Gigabit Ethernet - and sadly no Solaris driver exists for it. The Solaris 10 install just jumped by the... (1 Reply)
Discussion started by: soulmerchant
1 Replies

6. Solaris

USB External Hard Drive for Solaris 10 Sparc

Hi- I would like to know if anyone has used any USB External Hard Drive, about 500/750GB or 1TB, with any of the Solaris 10 "SPARC" systems. Not on intel nor amd platform. I'm looking for the compatible drive and found a few listed on Sun solaris ready page, but I'd like to have inputs from... (3 Replies)
Discussion started by: agfa_109
3 Replies

7. Solaris

Solaris 10 install doesn't display Network Connectivity prompt page

I have two Dell x86 machines on which I am attempting to install Solaris 10 from CD. I am not doing a Jumpstart install. This is my first experience in installing Solaris (or any other OS). I am following the instructions at How to Quickly Install the Solaris 10 1/06 OS The first machine... (3 Replies)
Discussion started by: sarahsi
3 Replies

8. Solaris

[help]network error after reboot server v890 sparc

hi expert, i had reinstall the sun v890 server solaris 8 and also do mirroring, i had configure the network for the server (hostname.eri0,hosts,netmasks,nodename,etc) after i reboot get and error messages below : Setting default IPv4 interface for multicast: add net 224.0/4: gateway... (5 Replies)
Discussion started by: bucci
5 Replies

9. Solaris

How to check Oracle odbc connectivity in solaris ?

Hi, I have my application and database servers running on solaris. I need to check Db connectivity for a datasource in my Db server. Please guide me how to do it in solaris env. Aru (2 Replies)
Discussion started by: aarora_98
2 Replies
Login or Register to Ask a Question

Featured Tech Videos