Visit Our UNIX and Linux User Community


Zone hang issue


 
Thread Tools Search this Thread
Operating Systems Solaris Zone hang issue
# 1  
Old 04-28-2010
Zone hang issue

I have a solaris10 zone running an oracle db in it. The zone hangs after some time the db is started and i 'm unable to log into the zone after that so i have to halt and restart the zone along with db .. but after few hrs again it hangs. What would be the reason for it. I did svcs -xv and got following result which i do not think could be the issue of zone hang.

Code:
svc:/network/rpc/keyserv:default (RPC encryption key storage)
 State: maintenance since Wed Apr 28 00:06:42 2010
Reason: Start method exited with $SMF_EXIT_ERR_CONFIG.
   See: http://sun.com/msg/SMF-8000-KS
   See: man -M /usr/share/man -s 1M keyserv
   See: /var/svc/log/network-rpc-keyserv:default.log
Impact: 1 dependent service is not running:
        svc:/network/rpc/nisplus:default

# 2  
Old 04-28-2010
what is inside the log (/var/svc/log/network-rpc-keyserv:default.log) file?
# 3  
Old 04-28-2010
Code:
[ Aug  5 00:40:00 Executing start method ("/usr/sbin/keyserv") ]
[ Aug  5 00:40:00 Method "start" exited with status 0 ]
[ Sep 27 23:05:54 Executing start method ("/usr/sbin/keyserv") ]
[ Sep 27 23:05:54 Method "start" exited with status 0 ]
[ Nov 12 21:40:38 Executing start method ("/usr/sbin/keyserv") ]
[ Nov 12 21:40:38 Method "start" exited with status 0 ]
[ Dec 31 05:00:47 Executing start method ("/usr/sbin/keyserv") ]
[ Dec 31 05:00:47 Method "start" exited with status 0 ]

# 4  
Old 04-28-2010
thats all? where are the newer messages? there should be something from Wed Apr 28 00:06:42 2010...
# 5  
Old 04-28-2010
what says dmesg ?
# 6  
Old 04-28-2010
Quote:
Originally Posted by fugitive
I have a solaris10 zone running an oracle db in it. The zone hangs after some time the db is started and i 'm unable to log into the zone after that so i have to halt and restart the zone along with db.
How do you log in to the zone ?
How does it fails ?
What is the zone status ?
Are there processes still running in the zone ?
Is there some capping set in the zone configuration ?
# 7  
Old 04-28-2010
Asnwers to Jillagre's questions

Code:
How do you log in to the zone ?  zlogin, zlogin -C & ssh from putty
How does it fails ?    After few hrs i'm unable to connect to zone using any of the above methods

What is the zone status ?  The status remains running

Are there processes still running in the zone ?  The smon, pmon processes of the 
db continues to run 

Is there some capping set in the zone configuration:  There is no capping sent

DukeNuke2
Code:
[ Apr 27 21:26:10 Executing start method ("/usr/sbin/keyserv") ]
[ Apr 27 21:26:10 Method "start" exited with status 96 ]
[ Apr 28 00:04:52 Enabled. ]
[ Apr 28 00:05:05 Executing start method ("/usr/sbin/keyserv") ]
[ Apr 28 00:05:05 Method "start" exited with status 96 ]
[ Apr 28 00:06:42 Leaving maintenance because clear requested. ]
[ Apr 28 00:06:42 Enabled. ]
[ Apr 28 00:06:42 Executing start method ("/usr/sbin/keyserv") ]
[ Apr 28 00:06:42 Method "start" exited with status 96 ]


Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

How to solve hang issue in script?

i have one function block in the beginning of my script and there are some commands inside that function which will perform some operations. And i am invoking that function from my main script by passing some values. Sometimes it is hanging in the middle for some value. For example: For 1st... (3 Replies)
Discussion started by: thomasraj87
3 Replies

2. Solaris

Zone memory issue

We have a zone configured in our X4600 machine with memory capped to 16GB. Most of the time zone is running with high physical memory utilization. It seems from "top" command shows that the command "kernel" is locks 15GB phy. memory and not using swap memory. Whenever we restart the application... (2 Replies)
Discussion started by: rock123
2 Replies

3. Solaris

Zone failes to boot due to mount issue, dir exists in zone.

I have two physical servers, with zones that mount local storage. We were using "raw device" in the zonecfg to point to a metadevice on the global zone (it was not mounted in the global zone at any point). It failed to mount on every boot because the directory existed in the zone. I... (6 Replies)
Discussion started by: BG_JrAdmin
6 Replies

4. Programming

A system hang issue in porting an old fs to kernel 2.6.32.*

Hi, I ported a file system from Kernel version 2.6.18.* to 2.6.32.46 as VFS implementation has changed and prepare_write/commit_write are replaced by write_begin/write_end pairs. Implemented the feature by writing a wrapper for write_begin and write_end and calling original functions for... (0 Replies)
Discussion started by: Praveen_218
0 Replies

5. Solaris

Backup / Clone Solaris Zone Issue

Hi, I'd like to discuss the subject of backing up / cloning Solaris zone. I was trying to clone zone A to zone B (Solaris 10 11/06: Cloning a Non-Global Zone on the Same System (System Administration Guide: Oracle Solaris Containers-Resource Management and Oracle Solaris Zones)). The first test... (7 Replies)
Discussion started by: aixlover
7 Replies

6. Solaris

Zone network issue

Hi guys, I got a global zone with with two zones runnig. After a patch upgrade (July 2010) one of them stop to working fine: basically I can't ping it ( I mean I can ping from the other zone, but actually the ping pass across the global zone..) and I can't access it in ssh or telnet...(actually... (0 Replies)
Discussion started by: cecco16
0 Replies

7. Solaris

Solaris 10 11/06 Zone creation issue

Hi, I am new to zone creations in solaris 10. When I try to create a zone with "set ip-type=exclusive" it gives the usage. OS == Solaris 10 11/06 s10s_u3wos_10 SPARC Copyright 2006 Sun Microsystems, Inc. All Rights Reserved. Use is subject to license... (17 Replies)
Discussion started by: niman
17 Replies

8. Solaris

Solaris 10 CDE hang issue

Hi, I am facing some issues on Solaris 10 (SPARC 5.10 Generic_118833-36). The issue is when I try to connect/login through CDE it hangs (hangs at login screen). I tried connecting thourgh VNC client also but that also not helped. I had done no configuration change or modified any kernel... (2 Replies)
Discussion started by: kgupta
2 Replies

9. AIX

Port hang issue in AIX Version 5.3

On AIX platform we are having Weblogic 8.1 as the middleware for an application. The application is deployed in Weblogic on AIX platform and the server is having 2 dedicated listening ports for any incoming requests. Output for netstat -an command for the port 30001 is as follows:- tcp4... (7 Replies)
Discussion started by: subharai
7 Replies

10. Solaris

Zone issue

I had detached a zone earlier now when i try to install it it gives me following error zoneadm -z OEM1_wa_lab install Cannot install detached zone. Use attach or remove /zones/app/OEM1_wa_lab directory. could not verify zonepath /zones/app/OEM1_wa_lab because of the above errors. zoneadm:... (4 Replies)
Discussion started by: fugitive
4 Replies

Featured Tech Videos