SHell Scripting Help Needed


 
Thread Tools Search this Thread
Top Forums Shell Programming and Scripting SHell Scripting Help Needed
# 1  
Old 07-14-2006
SHell Scripting Help Needed

Dear All,

I have an input file like this
interface Serial10/0/7:11.1 point-to-point
description CLIENT:SA_INSTITUTO ANGLO MEXICANO Sitio Metepec 104452:0,165
bandwidth 64
ip vrf forwarding INSTITUTO-ANGLO

ip address 192.168.148.217 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 108
class Link_30-50-0-128
!


I can give the fields like this
interface Serial
description CLIENT:
ip address
class

And I want the repective values as,
10/0/7:11.1|SA_INSTITUTO ANGLO MEXICANO Sitio Metepec |192.168.148.217 |Link_30-50-0-128

Can anyone help me?
# 2  
Old 07-14-2006
Try something like...
Code:
$ cat file1
interface Serial
description CLIENT:
ip address
class

$ cat file2
interface Serial10/0/7:11.1 point-to-point
description CLIENT:SA_INSTITUTO ANGLO MEXICANO Sitio Metepec 104452:0,165
bandwidth 64
ip vrf forwarding INSTITUTO-ANGLO

ip address 192.168.148.217 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 108
class Link_30-50-0-128
!

$ awk 'NR==FNR{a[$0];next}{for(i in a)if(sub(i,"")){if(NF>1)$NF="";print}}' file1 file2|paste -s -d '|' > file3

$ cat file3
10/0/7:11.1 |SA_INSTITUTO ANGLO MEXICANO Sitio Metepec |192.168.148.217 | Link_30-50-0-128

# 3  
Old 07-17-2006
Thanks a lot

Hi,

Thanx a lot,As Iam new with awk,can u explain me the scripts.
And one more question,If we got a number of records,how can we segregate it by another line.

For Eg:
interface Serial10/0/2:1
description CLIENT:SEIEM_TOLUCA_CORP_1024K 101983:0,542
no ip address
no ip directed-broadcast
encapsulation frame-relay
no fair-queue
!
interface Serial10/0/2:1.1 point-to-point
description CLIENT:SEIEM_TOLUCA_CORP_1024K 101983:0,542
ip vrf forwarding SEIEM
ip address 192.168.158.77 255.255.255.252
no ip directed-broadcast
frame-relay interface-dlci 436
class Link_20-60-0-1024
!

10/0/2:1|SEIEM_TOLUCA_CORP_1024K|||
10/0/2:1.1|SEIEM_TOLUCA_CORP_1024K|192.168.158.77|Link_20-60-0-1024|
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

UNIX shell scripting - help needed

Can anyone please help me to create the output file based on the attached input files using ksh script. I have 2 input files 1) inputfile1.txt 2) inputfile2.txt The script should accept 2 parametes: 1. Inputfile2.txt with 1-10,000 values ( sample file contains only 4 records) 2. Script... (5 Replies)
Discussion started by: vinus
5 Replies

2. Shell Programming and Scripting

Help needed in Korn Shell scripting

#! /bin/ksh while read line do if ] ; then echo "no data" continue; fi echo "performing operation on $line" done < prg.txt (3 Replies)
Discussion started by: Juhi Kashyap
3 Replies

3. Shell Programming and Scripting

Shell Scripting needed for the below problem please solve ...

please solve my problem..... :( i have a sample input file as A A A A B B B B B C C C C C i want the output such that if the count of A or B or C is greater than 3 A (1 Reply)
Discussion started by: hemanthsaikumar
1 Replies

4. Shell Programming and Scripting

Help needed with Shell scripting

Hi All, I need to split a flatfile based on it's first character, I am using the following script awk '{print > "TEST_substr($0,1,1).txt"}' PROVIDER.txt It is returning files TEST_1 and TEST_2 But I am not getting the .txt file extension. I need the files like TEST_1.txt and ... (1 Reply)
Discussion started by: sam35
1 Replies

5. Shell Programming and Scripting

Help needed for shell scripting for oracle.

Hi, Please see contains both files created for automating the data from oracle through shell. 1)a_p.ksh #!/bin/ksh LOG=/home/A_P.log MESSAGE=/home/MESSAGE_A_P.txt mail_list=/home/AP_MAIL_LIST.txt data=/home/spooled_A_P.log echo "`date` Starting execution for A_P COUNT" > $LOG ... (2 Replies)
Discussion started by: fidelis
2 Replies

6. Shell Programming and Scripting

Help needed in shell scripting

" how to write a script to send an error in a log file to a particular E-Mail ID " Can anyone help me in this ? Regards (3 Replies)
Discussion started by: himvat
3 Replies

7. Shell Programming and Scripting

Help needed - ksh shell scripting

Hi all, i m new to Unix shell scripting(ksh) i have a requirement, can anyone help me out in this.. spec: i need to move all the files landing in "X" directory to "Y" directory automatically everyday at a particular time.. (5 Replies)
Discussion started by: subbu
5 Replies

8. Shell Programming and Scripting

Help needed - shell scripting

I have a file that has text in the format below ABC / Some text / ABC / Some text / ABC / Some text / ABC / Some text / ABC / Some text / How can I seperate the text between a pair of 'ABC' into seperate files ??? any information would be of great help. Thanks (8 Replies)
Discussion started by: garric
8 Replies

9. Shell Programming and Scripting

help needed in shell scripting......urgent

Dear friends, please help me to solve following problem. I'm running a frontend application from which i'll be invoking the shell script with arguments as given below -driver -w -p "ABC XYZ" -S -ds con -dn "abc xyz" i am getting $1=-driver $2=-w $3=-p $4="ABC $5=XYZ" $6=-S $7=-ds... (3 Replies)
Discussion started by: swamymns
3 Replies
Login or Register to Ask a Question