Query: binuptime
OS: osx
Section: 9
Links: osx man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
MICROUPTIME(9) BSD Kernel Developer's Manual MICROUPTIME(9) NAME
binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime, getnanouptime -- get the time elapsed since boot SYNOPSIS
#include <sys/time.h> void binuptime(struct bintime *bt); void getbinuptime(struct bintime *bt); void microuptime(struct timeval *tv); void getmicrouptime(struct timeval *tv); void nanouptime(struct timespec *ts); void getnanouptime(struct timespec *tsp); DESCRIPTION
The binuptime() and getbinuptime() functions store the time elapsed since boot as a struct bintime at the address specified by bt. The microuptime() and getmicrouptime() functions perform the same utility, but record the elapsed time as a struct timeval instead. Similarly the nanouptime() and getnanouptime() functions store the elapsed time as a struct timespec. The binuptime(), microuptime(), and nanouptime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbinuptime(), getmicrouptime(), and getnanouptime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbinuptime(), getmicrouptime(), and getnanouptime() functions is to enforce the user's preference for timer accuracy ver- sus execution time. SEE ALSO
bintime(9), getbintime(9), getmicrotime(9), getnanotime(9), microtime(9), nanotime(9), tvtohz(9) AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>. BSD
September 16, 2004 BSD
Related Man Pages |
---|
getbinuptime(9) - debian |
getmicrouptime(9) - debian |
microuptime(9) - debian |
nanouptime(9) - debian |
getbinuptime(9) - hpux |
Similar Topics in the Unix Linux Community |
---|
When is a _function_ not a _function_? |
Shopt -s histappend |
A dash to GOTO or a dash from GOTO, that is the question... |
Syntax error in subtraction in Bash |