Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

microtime(9) [osx man page]

MICROTIME(9)						   BSD Kernel Developer's Manual					      MICROTIME(9)

NAME
bintime, getbintime, microtime, getmicrotime, nanotime, getnanotime -- get the current time SYNOPSIS
#include <sys/time.h> void bintime(struct bintime *bt); void getbintime(struct bintime *bt); void microtime(struct timeval *tv); void getmicrotime(struct timeval *tv); void nanotime(struct timespec *ts); void getnanotime(struct timespec *tsp); DESCRIPTION
The bintime() and getbintime() functions store the system time as a struct bintime at the addresses specified by bt. The microtime() and getmicrotime() functions perform the same utility, but record the time as a struct timeval instead. Similarly the nanotime() and getnanotime() functions store the time as a struct timespec. The bintime(), microtime(), and nanotime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbintime(), getmicrotime(), and getnanotime() functions is to enforce the user's preference for timer accuracy versus execution time. SEE ALSO
binuptime(9), getbinuptime(9), getmicrouptime(9), getnanouptime(9), microuptime(9), nanouptime(9), tvtohz(9) HISTORY
The bintime functions first appeared in FreeBSD 5.0. The microtime and nanotime functions first appeared in FreeBSD 3.0 but have existed in other incarnations since 4.4BSD. AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>. BSD
September 16, 2004 BSD

Check Out this Related Man Page

MICROTIME(9)						   BSD Kernel Developer's Manual					      MICROTIME(9)

NAME
bintime, getbintime, microtime, getmicrotime, nanotime, getnanotime -- get the current time SYNOPSIS
#include <sys/time.h> void bintime(struct bintime *bt); void getbintime(struct bintime *bt); void microtime(struct timeval *tv); void getmicrotime(struct timeval *tv); void nanotime(struct timespec *ts); void getnanotime(struct timespec *tsp); DESCRIPTION
The bintime() and getbintime() functions store the system time as a struct bintime at the addresses specified by bt. The microtime() and getmicrotime() functions perform the same utility, but record the time as a struct timeval instead. Similarly the nanotime() and getnanotime() functions store the time as a struct timespec. The bintime(), microtime(), and nanotime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbintime(), getmicrotime(), and getnanotime() functions is to enforce the user's preference for timer accuracy versus execution time. SEE ALSO
binuptime(9), getbinuptime(9), getmicrouptime(9), getnanouptime(9), microuptime(9), nanouptime(9), tvtohz(9) HISTORY
The bintime functions first appeared in FreeBSD 5.0. The microtime and nanotime functions first appeared in FreeBSD 3.0 but have existed in other incarnations since 4.4BSD. AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>. BSD
September 16, 2004 BSD
Man Page

4 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

php on solaris

hiho, any ideas? why is this little script about 1000% slower on solaris than on linux: <?php function GetMicrotime(){ list($microseconds, $seconds) = explode(" ",microtime()) ; return ((float)$microseconds +... (0 Replies)
Discussion started by: pressy
0 Replies

2. Web Development

[PHP] Script to Time Remote Server Response and Email

Here is a simple PHP script I wrote that times getting a link using mtime with curl and emails if it does not meet my objective. I use it in production for checking the performance of a Content Delivery Network (CDN), but you can use it for any web server. <?php $heartbeat =... (1 Reply)
Discussion started by: Neo
1 Replies

3. Shell Programming and Scripting

Determine amount of time to process

Hello all, Hopefully someone can point me in the right direction... I have a script written in bash which is pretty basic and just stop/starts various services based on particular conditions. What I am trying to build is a reporting type function which will send out an email with various stats... (3 Replies)
Discussion started by: systrex
3 Replies

4. What is on Your Mind?

New Icons Coming from Font Awesome

Finally making some progress on getting rid of the 10 year old buttons with modern day fonts and icons thanks to a responsive web design tutorial by Brad Traversy who's video pointed me to Font Awesome. The buttons and icons were pretty easy to implement but it too me a number of hours... (39 Replies)
Discussion started by: Neo
39 Replies