Query: qinit
OS: osf1
Section: 9s
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
qinit(9S) Data Structures for Drivers qinit(9S) NAME
qinit - STREAMS queue processing procedures structure SYNOPSIS
#include <sys/stream.h> INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI) DESCRIPTION
The qinit structure contains pointers to processing procedures for a QUEUE. The streamtab structure for the module or driver contains pointers to one queue(9S) structure for both upstream and downstream processing. STRUCTURE MEMBERS
int (*qi_putp)(); /* put procedure */ int (*qi_srvp)(); /* service procedure */ int (*qi_qopen)(); /* open procedure */ int (*qi_qclose)(); /* close procedure */ int (*qi_qadmin)(); /* unused */ struct module_info *qi_minfo; /* module parameters */ struct module_stat *qi_mstat; /* module statistics */ SEE ALSO
queue(9S), streamtab(9S) Writing Device Drivers STREAMS Programming Guide NOTES
This release includes no support for module statistics. SunOS 5.10 11 Apr 1991 qinit(9S)
Related Man Pages |
---|
module_info(9s) - opensolaris |
fmodsw(9s) - opensolaris |
msgb(9s) - opensolaris |
queue(9s) - sunos |
msgb(9s) - debian |
Similar Topics in the Unix Linux Community |
---|
Stream Read And Write Queues |
Entry Points Routine |
Please update inittab/rc.shutdown/rc scripts to start/stop mqm (need help Urgent) |
AIX STREAMS driver question |