osf1 man page for pollwakeup

Query: pollwakeup

OS: osf1

Section: 9f

Links: osf1 man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

pollwakeup(9F)						   Kernel Functions for Drivers 					    pollwakeup(9F)

NAME
pollwakeup - inform a process that an event has occurred SYNOPSIS
#include <sys/poll.h> void pollwakeup(struct pollhead *php, short event); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
php Pointer to a pollhead structure. event Event to notify the process about. DESCRIPTION
pollwakeup() wakes a process waiting on the occurrence of an event. It should be called from a driver for each occurrence of an event. The pollhead structure will usually be associated with the driver's private data structure associated with the particular minor device where the event has occurred. See chpoll(9E) and poll(2) for more detail. CONTEXT
pollwakeup() can be called from user or interrupt context. SEE ALSO
poll(2), chpoll(9E) Writing Device Drivers NOTES
Driver defined locks should not be held across calls to this function. SunOS 5.10 11 Apr 1991 pollwakeup(9F)
Related Man Pages
pollwakeup(9f) - opensolaris
pollwakeup(9f) - sunos
chpoll(9e) - centos
pollwakeup(9f) - php
pollwakeup(9f) - v7
Similar Topics in the Unix Linux Community
Event driven programming / epoll / typedef union / session data array