opensolaris man page for scsi_rname

Query: scsi_rname

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_cname(9F)						   Kernel Functions for Drivers 					    scsi_cname(9F)

NAME
scsi_cname, scsi_dname, scsi_mname, scsi_rname, scsi_sname - decode a SCSI name
SYNOPSIS
#include <sys/scsi/scsi.h> char *scsi_cname(uchar_t cmd, char **cmdvec); char *scsi_dname(int dtype); char *scsi_mname(uchar_t msg); char *scsi_rname(uchar_t reason); char *scsi_sname(uchar_t sense_key);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
cmd A SCSI command value. cmdvec Pointer to an array of command strings. dtype Device type. msg A message value. reason A packet reason value. sense_key A SCSI sense key value.
DESCRIPTION
The scsi_cname() function decodes SCSI commands. cmdvec is a pointer to an array of strings. The first byte of the string is the command value, and the remainder is the name of the command. The scsi_dname() function decodes the peripheral device type (for example, direct access or sequential access) in the inquiry data. The scsi_mname() function decodes SCSI messages. The scsi_rname() function decodes packet completion reasons. The scsi_sname() function decodes SCSI sense keys.
RETURN VALUES
These functions return a pointer to a string. If an argument is invalid, they return a string to that effect.
CONTEXT
These functions can be called from user, interrupt, or kernel context.
EXAMPLES
Example 1 Decoding SCSI tape commands. The scsi_cname() function decodes SCSI tape commands as follows: static char *st_cmds[] = { "00test unit ready", "01rewind", "03request sense", "10read", "12write", "20write file mark", "21space", "22inquiry", "25mode select", "31erase tape", "32mode sense", "33load tape", NULL }; .. cmn_err(CE_CONT, "st: cmd=%s", scsi_cname(cmd, st_cmds));
SEE ALSO
Writing Device Drivers SunOS 5.11 16 Jan 2006 scsi_cname(9F)
Related Man Pages
scsi_mname(9f) - sunos
scsi_arq_status(9s) - opensolaris
scsi_rname(9f) - sunos
scsi_sname(9f) - sunos
scsi_arq_status(9s) - centos
Similar Topics in the Unix Linux Community
SCSI Tape Error
Installing SCSI