Query: putnextctl1
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
putnextctl1(9F) Kernel Functions for Drivers putnextctl1(9F)NAMEputnextctl1 - send a control message with a one-byte parameter to a queueSYNOPSIS#include <sys/stream.h> int putnextctl1(queue_t *q, int type, int p);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSq Queue to which the message is to be sent. type Type of message. p One-byte parameter.DESCRIPTIONThe putnextctl1() function, like putctl1(9F), tests the type argument to make sure a data type has not been specified, and attempts to allocate a message block. The p parameter can be used, for example, to specify how long the delay will be when an M_DELAY message is being sent. putnextctl1() fails if type is M_DATA, M_PROTO, or M_PCPROTO, or if a message block cannot be allocated. If successful, putnextctl1() calls the put(9E) routine of the queue pointed to by q with the newly allocated and initialized message. A call to putnextctl1(q,type, p) is an atomic equivalent of putctl1(q->q_next, type, p). The STREAMS framework provides whatever mutual exclusion is necessary to insure that dereferencing q through its q_next field and then invoking putctl1(9F) proceeds without interference from other threads. The putnextctl1() function should always be used in preference to putctl1(9F)RETURN VALUESOn success, 1 is returned. 0 is returned if type is a data type, or if a message block cannot be allocated.CONTEXTThe putnextctl1() function can be called from user, interrupt, or kernel context.EXAMPLESSee the putnextctl(9F) function page for an example of putnextctl1().SEE ALSOput(9E), allocb(9F), datamsg(9F), putctl1(9F), putnextctl(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 putnextctl1(9F)
Related Man Pages |
---|
putnextctl(9f) - php |
putnextctl(9f) - minix |
putnextctl(9f) - osx |
putnextctl(9f) - redhat |
putnextctl(9f) - linux |
Similar Topics in the Unix Linux Community |
---|
Trying to block signal |
What does this mean? |
Study UNIX Kernel |
%memused is high |
Shopt -s histappend |