opensolaris man page for putnext

Query: putnext

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

putnext(9F)						   Kernel Functions for Drivers 					       putnext(9F)

NAME
putnext - send a message to the next queue
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void putnext(queue_t *q, mblk_t *mp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue from which the message mp will be sent. mp Message to be passed.
DESCRIPTION
The putnext() function is used to pass a message to the put(9E) routine of the next queue in the stream.
RETURN VALUES
None.
CONTEXT
The putnext() function can be called from user, interrupt, or kernel context.
EXAMPLES
See allocb(9F) for an example of using putnext().
SEE ALSO
put(9E), allocb(9F), put(9F), qprocson(9F) Writing Device Drivers STREAMS Programming Guide
NOTES
The put() and putnext() functions should be called only after qprocson() is finished. SunOS 5.11 16 Jan 2006 putnext(9F)
Related Man Pages
putnext(9f) - minix
putnext(9f) - suse
putnext(9f) - osx
putnext(9f) - redhat
putnext(9f) - plan9
Similar Topics in the Unix Linux Community
[urgent help] error log on /var/adm/messages
Sun Fire E2900 crashed. Help analyze explorer
Sparc Solaris 8 crash dump
AIX STREAMS driver question