opensolaris man page for nvlist_lookup_nvpair

Query: nvlist_lookup_nvpair

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

nvlist_lookup_nvpair(9F)				   Kernel Functions for Drivers 				  nvlist_lookup_nvpair(9F)

NAME
nvlist_lookup_nvpair, nvlist_exists - lookup named pairs
SYNOPSIS
#include <libnvpair.h> int nvlist_lookup_nvpair(nvlist_t *nvl, const char *name, nvpair_t **nvp); boolean_t nvlist_exists(nvlist_t *nvl, const char *name);
DESCRIPTION
The nvlist_lookup_nvpair() function returns the nvpair with the matching name, regardless of type. It is valid only for lists allocated with NV_UNIQUE_NAME. See nvlist_alloc(9F). The nvlist_exists() function returns success if any nvpair exists with the given name. It is valid for all types of lists.
RETURN VALUES
The nvlist_lookup_nvpair() function returns 0 on success and an error value on failure. The nvlist_exists() function returns B_TRUE if an nvpair with the given name exists and B_FALSE otherwise.
ERRORS
The nvlist_lookup_nvpair() function will fail if: EINVAL There is an invalid argument. ENOENT No matching name-value pair is found. ENOTSUP The list was not allocated with NV_UNIQUE_NAME.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
nvlist_lookup_nvpair(3NVPAIR), nvlist_alloc(9F), attributes(5) SunOS 5.11 24 Oct 2007 nvlist_lookup_nvpair(9F)
Related Man Pages
nvlist_add_uint16(3nvpair) - opensolaris
nvlist_add_boolean_array(3nvpair) - opensolaris
nvlist_add_double(3nvpair) - opensolaris
nvlist_add_int16_array(3nvpair) - opensolaris
nvlist_exists(3nvpair) - opensolaris
Similar Topics in the Unix Linux Community
solaris zones vs container..
What does this mean?
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
What is good?
Shopt -s histappend